Rebuild an Index on Exchange 2013 for Specific Databases


***The  ResetSearchIndex.ps1 used in Exchange 2010 has been deprecated from Exchange 2013***

There are a few different ways to rebuild a search index in
Exchange 2013.

  1. Reseed the Search Catalog from another DAG member.
     If the server is part of a DAG, you can reseed the index (Catalog) by running the Update-MailboxDatabaseCopy
    using the –CatalogOnly switch (http://technet.microsoft.com/en-us/library/dd335201(v=exchg.150).aspx)

Example: Update-MailboxDatabaseCopy -Identity DB1\MBX1  -CatalogOnly

In the example above, the Database name is DB1 and the mailbox server is MBX1.

  1. Manual rebuild kickoff
    1. Stop the “Microsoft Exchange Search service” as
      well as the “Microsoft Exchange Host Controller.”
    2. Delete the Existing CI catalog folder or move it
      to a new location.
    3. Start the “Microsoft Exchange Search service” as
      well as the “Microsoft Exchange Host Controller” services.

 

Comments (2)

  1. If you want to stop the services via the Exchange Management Shell you can run:

    Stop-Service MSExchangeFastSearch
    Stop-Service HostControllerService

  2. Mobin says:

    Hi,

    Could you please at my post below and help me with Exchange Search.

    I’m running Exchanging 2013 with two mailbox servers in a DAG. Get-MailboxDatabaseCopyStatus * showed both servers in FailedAndSuspended state. I think this issue occurred after I extended disk space on the mailbox servers. I tried Update-MailboxDatabaseCopy -CatalogOnly but that didn’t help I presume as there was no Heatlty copy present.

    On the passive node I stopped Exchange Search and Exchange Host Controller service, renamed .single to .single.old and started the service again which created a new folder. But state was still showing FailedAndSuspended, so I tried to do same on the Active node and upon service start status was changed to Crawling on active node and passive was still showing FailedAndSuspended.

    It took more than 24 hours and status was changed from Crawling to Failed on Active node. Then again on the passive node I stopped and started Exchange Search and Exchange Host Controller service, after a while status was changed from Failed to Crawling and then to Healthy. Once status was healthy then I ran MailboxDatabaseCopy -CatalogOnly which made the active node healthy as well.

    Now the issue which I’m facing is that search still isn’t working other than recent emails (1 day old emails)

    .single.old size is showing as 30 GB while new folder .single is showing only 6 GB. Is there any possible solution I could fix the search issue?

    Could you please help me to resolve this.

    Regards,

    Mobin

Skip to main content