Exchange 5.5 related Security Bulletin (04-026)


As Paul already posted, there is a new security bulletin out - 04-026 - and it affects Exchange 5.5 OWA servers (and NOT Exchange 2000/2003 servers).


Please head over here to read more about it.


- Nino Bilic

Skip to main content