Incorrect display URL in search results – SharePoint 2010

Issue: In search results when we click on an item it takes us to an incorrect displayform URL. For example in an working scenario when we click on an item in search results it takes us to <url of the list>/dispform.aspx?id=<***>, but in case where there are multiple display form created for a list search…

1

Error while trying to enable enterprise features or upgrading Standard License to Enterprsie License in SharePoint 2010 multiple Server farm

Issue: Enabling enterprise features on SharePoint 2010 or upgrading from Standard license to Enterprise license fails on multiple server farm with the following error in GUI   An error occurred while enabling Enterprise features. Refer to the event logs on your server machines for more details. For more information on how to fix this error,…

4

Unable to re-use saved list templates in SharePoint 2010

Issue: ==== Recently we worked on an issue where none of the saved list or site template can be used to create new list or sites respectively. We do see the templates in galleries but when click on create we dont see them as an option. We noticed that in list template gallery none of the…

3

Configuring Outgoing email settings in SharePoint with Gmail SMTP

ConfiguringOutgoing email settings in SharePoint with Gmail SMTP Select SMTP Server in features in Servermanager.           2. Go to Start à AdministrativeTools à Internet Information Services (IIS) 6.0 Manager to open IIS 6.0 à right click on SMTP Server à Properties   3. In Access Tab go to Relay Restrictions   In Relay Restrictions 1) Check…

27

powershell equivalent of stsadm -o setproperty -pn peoplepicker-searchadforests

$wa = get-spwebapplication <>$searchad = $wa.peoplepickersettings.searchactivedirectorydomains$newdomain = new-object Microsoft.SharePoint.Administration.sppeoplepickersearchactivedirectorydomain$newdomain.domainname = <domain/forest DNS name>blogs$newdomain.Isforest = $true/$false$newdomain.loginname = <loginname>[System.Security.SecureString]$secureStringValue = Read-Host “Enter the service account password: ” -AsSecureString;$newdomain.setpassword($securestringvalue)$searchad.add($newdomain)$wa.update()

0

Could not create publishing site

Issue: Cannot Create a subsite based on Publishing Site template  or unable to enable publishing feature on a site. Symptoms: Whenever we try to create a subsite based on publishing template or try to activate the publishing feature it fails with the following error: Provisioning did not succeed. Details:Failed to initialize some site properties for…

1

error in site data web service

Issue: == Search is not returning any results for particular site collection in WSS 3.0 Symptom: ==== We see that when we do a search on a site collection results are returned from other site collections and not from this one, even if we add a new document to this site and run a full…

0

check permissions showing "none" for users added through AD groups in SharePoint 2010

Issue: When you try to do checkpermissions for a user added on thesite through AD group you get “none” even though group has permissions on thesite and user also doesn’t have any issue in logging into the site. It’s justthat the check permission doesn’t work for the group and the user.   Resolution: Take a…

3

In SharePoint 2010 whenever you try to go to list settings you get “An unexpected error has occurred ”

Issue: In SharePoint 2010 whenever you try to go to list settingsyou get “An unexpectederror has occurred ” and it occurs on all the Web applications. Even if youtry to create a new web app the error persists. Collect the ULS while reproducing the issue and if we getthe following stack: NullReferenceException:Object reference not set…

2

The search service is not able to connect to the machine that hosts the administration component

Issue: While going to SSA administration page you get the following error: “The search service is not able to connect to the machine that hosts the administration component. Verify that the administration component ‘GUID’ in search application ‘Search_ Service_ Application ‘ is in a good state and try again” And in topology we see admin…

1