Linux Integration Services 3.2


Вчера, без лишней помпы, Open Source Technology Center, узел разработки гетерогенных решений Microsoft, анонсировал выход релиза компонентов интеграции для Linux версии 3.2.

По сравнению с версией 3.1, о которой была заметка в августе, данный релиз включает в себя следующие возможности:

  • Поддержка синтетического драйвера мыши - теперь устройство мыши не привязано к консоли VMConnect и может использоваться в RDP сессии
  • Единый драйвер дисковой подсистемы для IDE и SCSI устройств
  • Возможность использования синтетического сетевого адаптера на гипервизорах Windows 8 - Microsoft уже сейчас дает возможность как минимум протестировать работу Linux на платформе виртуализации следующего поколения
  • Устранение проблемы с SCVMM, описанной в статье KB2586286
  • Упрощение процесса установки: пользователю с правами администратора достаточно запустить install.sh для определения архитектуры и установки необходимых драйверов

Помимо этого, хотелось бы упомянуть и ряд требований и ограничений, накладываемых на применение этого пакета интеграции:

  • Драйвера применимы к гостевым виртуальным машинам под управлением Red Hat Enterprise Linux Server 6.1 (в архитектуре x86 и x64) и CentOS 6.0 (в архитектуре x86 и x64). Для более ранних версией следует использовать компоненты интеграции версии 2.1
  • Фактически, это модифицированные драйвера, находящиеся в составе ядра Linux 3.2, но способные работать и с ядром Linux 2.6.32, поставляемым с Red Hat и CentOS

Напоследок хотелось бы заметить, что Microsoft работает с авторами дистрибутивов Linux, в будущем список официально поддерживаемых дистрибутивов будет расширен. Что касается новых возможностей, то работа также ведётся, но не следует ждать крупных анонсов до выхода следующей версии Hyper-V.

Comments (3)

  1. Anonymous says:

    Долгожданный апдейт, намучился хоткеями перемещаться по иксам в RDP сессии(Administrative tools нельзя установить на компьютер управления). Будет ли обновление с версии 3.1 происходить автоматически или необходимо сначала удалить старую версию?

  2. Igor Batin, полагаю, Вам нужно будет удалить старую версию компонентов интеграции.

  3. А у меня гостевая CentOS 6.0 x64 (установленная по стандартной конфиге Desktop), вставленный iso с IC 3.2 не распознает (чистый DVD и предложение его записать).

Skip to main content