Ошибка запуска виртуальных машин после установки драйвера Intel IPMI


?? ???????? ?????, ??????? ??????????? ?? ????????? ???????????? ? ???????, ?? ??????? ?????? ???????? ?????? ????????? ?????? ?????? ???????. ???????? ????????? ?????????? ????????? ? ????? ?? ?????????, ??????? ?????????? ?? ????????? ?????????. ????? ????????? ?????? ??? ????????? «Intel Active System Console» ?????? 3.0 ????? ??????? ??????? ??????????? ????? ????????????? ???????.


??????????? ???????????? ????????, ??? ???????? ??????????? ? ????????????? ? Windows Server 2008 ???????? Intel IPMI ?????? 13.0. ???? ??????? ?????? ??? ? Intel Active System Console, ??? ? ? Intel Active System Monitor. ??????????????? ??? ??? ? ??????????? ? ???, ??? ????? ????????? ???????? ??? ??????????? ?????? Hyper-V ????????? ???????????. ??? ???? ????????? ?????? ??????? ? ????? ???????????? ?????, ??????? ???????? ????????? ???????.



  • ? ?????????? ??????: The application encountered an error while attempting to change the state of 'VM name' - IDE/ATAPI: Couldn't attach 'path to disk.VHD' to location 0/0 of IDE Controller. Error: 'General access denied error' (0x80070005).

  • ??? ? ??????? ??????: ??????????? ?????????? ?????? ??? ??????? ?????? ????????? ????????? «??? ??».

? ?????????? ?????? ????? ?????? ????????? — ????? ??? ?????? ???????????? ????? ???? ????? ????? ????????? ???????. ? ??? ??? ???????? ???? ?????? ? ????? ?????????.



??????? ???????? ?? Intel ???????? ?? ?????? — ??????????? ?????? ??-???????? ?? ???????????. ? ?????????? ????????? ?????? ? ????? ???????????? ???????? ????????????? ?? ????? ????????? ?????? ?????????????? ????????????????? ???????.



  1. ??????? ????????????? ?? Intel, ???? ??? ?? ???? ??????? ?????.

  2. ????????? ?????? «Intel IPMI Service» ? «Intel Monitoring Agent» ? ????????? Disabled (?????????), ???? ??? ???????? ? ??????? ????? ???????? ??.

  3. ????????? ??????? IPMI, ???????? ???????? «4» ????? «Start» ????? «HKLM\System\CurrentControlSet\Services\imbdrv».

  4. ????? ?????????? ????? «HKLM\SYSTEM\CurrentControlSet\Control\Class\{4D36E97D-E325-11CE-BFC1-08002BE10318}».

  5. ???? ???? ?????? ????? (Full Control) ?? ??? ????? ? ?????? ????? ???? ????????? ????????? ????????????.

  6. ??????? ??? ?????.

  7. ???????????????.

?????? ?????????????????? ???????? ???????? ????????? ????????, ??? ????????? ?? ???? ???????? — ? ??? ?????, ? ? ?????? ????????. ???????, ????????, ??? ???? ?? ???? ????? ????? ???? ??????, ? ??? ? ???????????????? ????????? ???? ????????? ?? ??? — ???????? ????? «HKLM\SYSTEM\CurrentControlSet\Control\Class\{4D36E97D-E325-11CE-BFC1-08002BE10318}». ???????, ????? ?? ?? ???????? ? ???? ???? ????? ???????? ? ????? ??????. ??? ????? ??????????? ????????? ???????? ??????? ? ??????? ??????? ?????????????? (Elevated).


???? ???-?? ?????????? ? ???? ????????? — ??????????, ????????? ???????????? ?????? ??????? ? ???????? ? ????????????, ????? ???? ????????? ????????????. ???? ????????, ??? ???????????? ????? ???? ????????? ???????? ? Hyper-V, ?????? ?????? ??? ?????????? ?????? ????????. ?? ???????? ?????? ?? Intel ? ????? ???????? ????????????? ??????? ?????????? ? ????????? Intel.

Comments (15)

  1. Anonymous says:

    Добрый день! Раньше я был drk

    История blogs.technet.com/…/hyper-v-the-application-encountered-an-error-while-attempting-to-change-the-state-of-virtual-machine.aspx получила продолжение.

    Теперь проблема уже не с интеловским драйвером, а с каким-то железом ….

    Машина та-же, что и два года назад (Intel 5000psl, 2×4 Xeon 2.0 Gg). Приросли память (16G) и RAID Intel SRCSASBB8I.

    Когда был установлен win2008EE и развернут Hyper-v все работало отлично.

    Установил (заново) win2008r2 EE (c MS-овского диска).

    Все прошивки последние! После установки R2 обновил все драйвера с сайта интел на все возможные устройства.

    Cкрины- dr2c.blogspot.com/…/hyper-v.html

    Красным обведено какие драйверы заменил (Intel RAID Virtual device был раньше LSI…)+чипсет. Из того, что есть на сайте Intel для 5000psl остались не установленными только драйверы для SAS(Storport и Embedded) и AHCI SATA.

    После установки Hyper-v- серый экран, после ребута он-же, не входит даже в безопасный режим….

    С горя поставил 2008-й- все отлично!

    Восстановил машину из образа.

    Развернул App Server, Fax Server, File Server, Print, IIS.

    Работает! Перезагружается и выключается!

    Что за….

  2. Alex A says:

    Замечательно!

    А сам Active System Console/Monitor еще работает?

  3. Anonymous says:

    Дико извиняюсь- еще не вернулись? Проблема не решается…

  4. Alex A says:

    Не вернулся еще.

    Если проблема актуальна – напишите мне через форму E-mail на почту.

    Далее – по английски с картинками и пояснениями излагайте, я отправлю разработчикам, они за пару дней решат.

    Сам я все равно этого не видел и не повторю.

  5. Alex A says:

    Владислав, напишите мне письмом (через поле Email справа).

    Я до конца августа работаю в Африке с эпизодическим выходом в сеть, так что от вас попрошу развернутого письма на английском с картинками, – попрошу разработчиков решить вопрос.

  6. Alex A says:

    Интересно, что ветка появилась опять. Сама? Или при каждой перезагрузке сервера?

    Фикс должен быть от Интел. Сейчас мы просто лишили их решение логотипа, новую версию они наверняка захотят сертифицировать, а это потребует исправления ошибки.

  7. Alex A says:

    Ещё с ходу замечу.

    Попробуйте (на чистой установке) обновить всё кроме видео. Оставьте его вообще как Standard VGA.

    Есть известный баг с видео драйверами на хосте и ролью Hyper-V. Устраняется установкой SP1 Beta.

  8. Alex A says:

    Regmon в помощь, – создайте явный фильтр, что мониторить (данный ключ и его подключи), чтобы не попадало лишнего.

    В WS2008 каждая служба имеет свой SID, так что вы должны понять, кто именно это делает. (Если, конечно, это не поведение драйвера, – тогда не понять какого именно)

  9. Yuriy V. Popov says:

    помогло. после удаления ветки реестра и перезагрузка сообщение пропало и виртуалки поднялись.

  10. Владислав says:

    Не стал экспериментировать, отключил драйвер imb, cнёс ветки реестра + перезагрузил = помогает однозначно.

    Единственное, почему-то после выходных эта ветка «HKLMSYSTEMCurrentControlSetControlClass{4D36E97D-E325-11CE-BFC1-08002BE10318}» появилась опять, так что снёс её ещё раз + перезагрузился – опять помогло…

    Ждём фикса от Интел (или от МС).

  11. Владислав says:

    Сейчас опять появилась без перезагрузки сервера (прошло около полутора часов с последней перезагрузки). Удалил/перезагрузился = работает… интересно, как долго…

  12. Владислав says:

    на сей раз удаления ветки хватило на 4 часа…

    как бы узнать, какой из драйверов создаёт эту ветку? или может кто из суб-драйверов или служб запускает imb? 🙁

  13. Владислав says:

    Из софта Intel на сервере стоит только Intel Network Connections 13.1.33.0

  14. Sergey K says:

    На форуме Microsoft по этому вопросу приводят еще одно решение – включить Network Service в группу Administrators.

    Проверил – сразу помогает. Некорректно с точки зрения безопасности, конечно. Но как временное и очень быстрое решение – подходит. Перезагрузка не требуется.

Skip to main content