Обновление для бета-версии SCVMM 2008 — поддержка Hyper-V RC1 и будущих версий


Пару дней назад на сайт Microsoft Connect было выложено долгожданное обновление для System Center Virtual Machine Manager 2008. Как мы уже сообщали, сейчас этот продукт находится в стадии разработки. Но до недавнего времени перспективу экспериментов омрачал тот факт, что текущая (и единственная) общедоступная бета-версия SCVMM несовместима с текущими сборками Hyper-V — RC1 и далее. И вот теперь наконец вы можете попробовать в деле полную связку технологий виртуализации Microsoft — SCVMM 2008 с Hyper-V — а также, при необходимости, и Virtual Server 2005. На тот случай, если вы этого ещё не успели заняться этим вплотную — позволю себе дать здесь несколько советов.



  • Данное изменение для SCVMM поставляется именно что в виде обновления — то есть файла исправления (patch) Windows Installer. Иными словами — для того, чтобы воспользоваться его преимуществами, вам потребуется вначале установить бета-версию SCVMM из старого дистрибутива (версии 2.0.3194.0), если вы этого ещё не сделали. А затем уже поверх него установить свежее обновление — после этого версия вашей установки станет 2.0.3194.1.

  • После установки обновления вы больше не сможете управлять серверами с установленной ролью Hyper-V версии RC0. Если до установки обновления вы работали с серверами Hyper-V RC0, то перед обновлением самого VMM вам следует сначала обновить серверы Hyper-V до версии RC1.

  • Также перед установкой обновления вам необходимо вручную остановить службу «Virtual Machine Manager». А после успешной установки обновления — соответственно, снова запустить её. Другой вариант — вместо остановки службы перед установкой обновления вам потребуется перезагрузить весь сервер после завершения процедуры. (Впрочем, об этом подробно написано на главной странице программы бета-тестирования).

  • Удалить обновление будет невозможно. Таким образом, если что-то пойдёт не так или вы захотите вернуться к работе с Hyper-V RC0, вам потребуется полностью удалить и заново развернуть VMM.

  • Помимо перечисленных выше соображений, перед установкой обновления в любом случае стоит ознакомиться со списком «Известных проблем» (Known Issues) на странице программы бета-тестирования. Ну, или сразу после — если вы столкнётесь с каким-либо странным поведением VMM.

Данное обновление обеспечивает работу текущей бета-версии SCVMM как с Hyper-V RC1, так и с более поздними сборками — в том числе, и окончательной версией, выход которой уже совсем не за горами. Что же касается выпусков самого VMM, то до появления окончательной версии (которая сейчас планируется ориентировочно на август этого года) ожидается появление ещё одной общедоступной предварительной версии.

Comments (6)

  1. Alex A says:

    Не очень понял конекста вопроса.

    В качестве оснеовной системы для SCVMM вы как раз должны использовать именно WS08.

    Для управляемых хостов бета SCVMM требует WS2008 x64 + Hyper-V или WS2003 + VS2005 или VMware ESX 3.0/3.5.

    В Release Candidate (август) будет поддержка VS2005 и на WS2008 (x86/x64) + ESX 3i

  2. Alex A says:

    Если вы между установкой SCVMM и апдейта установили Installer 4.5 (автоматическое обновление с Windows Update), удалите его и поставьте update. Проблема известная.

  3. DiamondSteel says:

    «Ensure that windows installer version 3.1 or later is installed»

    Забавно так ругается…

  4. Fidan says:

    Не поддерживает Windows Server 2008 ?

    Очень странно …

  5. Fidan says:

    Вот и я так думал, однако мне не удалось установить сервер на виртуальную машину W2K8, ругнулся на то, что "ваша OS не поддерживается"… проверю-ка архив…

  6. Alex A. says:

    SCVMM 2008 требует х64 версию WS2008 – члена домена 2003/2008.

    На х86 или на недоменный серве установить не получится (без бубна).

Skip to main content