New Builds of the SoftGrid 4.2 Clients are Available


J.C put this post up today and it was certainly an important update for me. I went straight to the site and downloaded it, and installed the update to my vista client. Highly recommenced this update!


Just a quick heads up that there are new builds of the SoftGrid 4.2 clients available for download.  The new build number is 4.2.0.310 and the SoftGrid 4.2 KB article (http://support.microsoft.com/kb/941408) has been updated to point to the proper download locations.  Note that applies to the SoftGrid for Windows Desktops clients only.

These new client builds contain a fix for an issue where under rare circumstances, performing a Package Upgrade may result in an incomplete update leading to possible package corruption.  We recommend upgrading to the new client to prevent these problems going forward.  We will be posting future SoftGrid updates to the KB article above and on this blog so be sure to check back every so often for the latest news.

Comments (6)

  1. Anonymous says:

    Just adding this from the techcenter forum
    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=2109711&SiteID=17&mode=1

    TS client is 4.1.1.310 However the KB does give info on the SoftGrid for TS clients

    There is no 4.2 TS client.

    Latest version are;

    SoftGrid Virtual Application Server (VAS) version 4.1.1.302

    SoftGrid for Terminal Services Client  version 4.1.1.310

    SoftGrid Sequencer version 4.1.1.303 and 4.2.0.303
    respectively

    SoftGrid Clients 4.1.1.310 and 4.2.0.310
    respectively 

    Hope this helps…… I will probably blog this later to squash confusion  Will ping the lads and ladies an email to get the techcenters versions updated also for you all

    http://technet.microsoft.com/en-us/softgrid/bb676740.aspx#cv

  2. Anonymous says:

    Looks like the KB is only for desktop client – is there even such a thing as a 4.2 TS client? I didn’t see one, but I may have overlooked it.

  3. Anonymous says:

    After an enjoyable weekend watching the Rugby World Cup (Which is a great love of mine!). I thought I

  4. Anonymous says:

    Hey Nigel,

    You should be fine with you 4.2.303 sequenced packages to 4.1.1.310 clients but please bare in mind the following;

    http://blogs.technet.com/softgrid/archive/2007/07/12/sequencing-best-practices.aspx

    http://support.microsoft.com/kb/932137

    There are no gaurentees that your application will work from one platfrom to another. You may find yourself making some modifications of you packages to overcome certain upgrade issues with Vista.

    Each has its own challenges and may have to be taken on an application by application basis.

    In some instances you may well have to sequence an application on Vista as well as XP, some application install differently on Vista in comparrison to XP.

    SoftGrid is a great tool for application issolation and ondemand streaming however you will need to still test all your applications for the platforms.

    Hope this helps

    JZ

  5. Anonymous says:

    4.1.310 is latest TS build! Edited to reflect! But the KB has some TS release notes also.

  6. Nigel Bruce says:

    If I sequence an application with version 4.2.0.303 will I have any problem delivering it to a Citrix PS 4.0 server running 4.1.1.310? We want to sequence apps so that they run on 3 different platforms without modifications

    Windows XP clients

    Windows Vista clients

    Citrix PS 4 servers

    With this in mind which is the best version of each component to use?

    If we want run an app on both Vista and XP is it better to sequence it on a Vista machine or an XP machine? I have heard conflicting reports. Is there any way to guarnatee that a sequenced app will run on any version of Windows irrespective of which platform it was sequenced on?

    Many thanks for your help

    Nigel

    University of Leeds, UK