App-V 5.0 Standalone Mode – Adding and Publishing a Package


This post has moved here

Comments (29)

  1. Anonymous says:

    Can you confirm that this is for more than one package or is this issue package specific? Also have you installed the hotfix here: support.microsoft.com/…/2799153

  2. Anonymous says:

    Check out this post if you are facing the issues discussed: blogs.technet.com/…/0c80070057-app-v-error-code.aspx

  3. Anonymous says:

    So far I've just tried the one package: a small open-source application called Workrave (http://www.workrave.org)

    I chose it as I believed, perhaps erroneously, that it was a nice and simple application that I'd have no issues sequencing.

    I will try something even simpler and let you know how I get on.

  4. Anonymous says:

    Hi Luke,

    Is this application specific or are you seeing it across different packages?

  5. Anonymous says:

    Mark, thanks for your comment, it really does help to know who else is facing this issue and with which packages. I have just downloaded and sequenced the same package and hit exactly the same issue. I am now investigating this internally to see if we can identify a root cause

  6. Anonymous says:

    Is this issue package specific or is it affecting all applications? Does the add command work fine and the error occur for the publish?

  7. Anonymous says:

    Hi, the commands are exactly the same as detailed above for the updated package. Also read here for more information: http://blogs.technet.com/b/virtualvibes/archive/2014/02/18/differential-upgrades-with-app-v-5-0.aspx

  8. Anonymous says:

    Thanks for sharing! A useful combination of PowerShell commands to quickly test packages.

  9. Anonymous says:

    PS: I did check the AppV Client Event Log but all it contained was:

    <Event xmlns="schemas.microsoft.com/…/event">

    – <System>

     <Provider Name="Microsoft-AppV-Client" Guid="{E4F68870-5AE8-4E5B-9CE7-CA9ED75B0245}" />

     <EventID>1008</EventID>

     <Version>1</Version>

     <Level>2</Level>

     <Task>8</Task>

     <Opcode>0</Opcode>

     <Keywords>0x8000000000000100</Keywords>

     <TimeCreated SystemTime="2013-05-08T14:20:06.383335300Z" />

     <EventRecordID>2</EventRecordID>

     <Correlation ActivityID="{02AB7C68-F800-0005-46C3-7170EF4BCE01}" />

     <Execution ProcessID="8024" ThreadID="7644" />

     <Channel>Microsoft-AppV-Client/Admin</Channel>

     <Computer>win7sp1-x64</Computer>

     <Security UserID="<REMOVED>" />

     </System>

    – <EventData>

     <Data Name="Package">{3E2480EF-37C9-4B17-84BC-1B38A8D751EB}</Data>

     <Data Name="Version">{47C75130-7167-4297-B60C-C7F2101F5B62}</Data>

     <Data Name="Folder">C:ProgramDataApp-V3E2480EF-37C9-4B17-84BC-1B38A8D751EB47C75130-7167-4297-B60C-C7F2101F5B62</Data>

     <Data Name="ErrorHigh">1279269900</Data>

     <Data Name="ErrorLow">2147942487</Data>

     </EventData>

     </Event>

  10. Anonymous says:

    Thanks, great to know it has been useful!

  11. Anonymous says:

    I am also getting this error on two different applications.

    The event log for App-V isn't any help even after enabling all logs.

  12. Anonymous says:

    This post has been particularly in helping me test sequenced applications.

  13. Anonymous says:

    Hi,

    Can you confirm when you get this error? At add or at publish? Also are you using the -DynamicUserConfigurationPath argument?

    Please paste me the commands you are using so I can verify….

  14. Anonymous says:

    Hi Pat, your right that in App-V 4.x we had the "AllowIndependentFileStreaming" key in registry which had to be set to 1 in order to stream directly from a file location. This is no longer the case in 5.0. Standalone mode in App-V 4.x and 5.0 is fully supported for production use and we have seen some customers really embrace standalone mode beyond just testing packages.

    I know some customers using SCCM 2007 are using the methods described above to publish App-V 5.0 packages too.

  15. Anonymous says:

    Hello Thamim,

    I too am getting the aforementioned 0C80070057 error.

    Commands so far:

    PS C:Windowssystem32> Set-ExecutionPolicy Unrestricted -Scope CurrentUser

    PS C:Windowssystem32> Import-Module Appvclient

    PS C:Windowssystem32> Add-AppvClientPackage -Path '\domainsoftwarepublicApp-V 5.0 PackagesAppTest_1.10.0_x64AppTest_1.10.0_x64.appv'

    Add-AppvClientPackage : Application Virtualization Service failed to complete requested operation.

    Operation attempted: Configure AppV Package.

    AppV Error Code: 0C80070057.

    Error module: Streaming Manager. Internal error detail: 4C401C0C80070057.

    Please consult AppV Client Event Log for more details.

    At line:1 char:1

    + Add-AppvClientPackage -Path '\domainsoftwarepublicApp-V 5.0 PackagesApp …

    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

       + CategoryInfo          : InvalidResult: (:) [Add-AppvClientPackage], ClientException

       + FullyQualifiedErrorId : ConfigurePackageError,Microsoft.AppV.AppvClientPowerShell.AddAppvPackage

    The package was sequenced using App-V 5.0 SP1 using a clean VM running a fully patched instance of Windows 7 Enterprise SP1 (64-bit).

    The 'client' machine is also a fully patched instance of Windows 7 Enterprise SP1 (64-bit) and is running the App-V 5.0 SP1 Client.

    So far as I can tell hotfix KB2799153 is superseded by SP1.

    Any nudges in the right direction would be gratefully received… 🙂

  16. Anonymous says:

    Hmm… I've just sequenced a small utility I wrote (an executable and a manifest packaged as a .msi) and that seems to have worked just fine…

    PS C:Windowssystem32> Add-AppvClientPackage -Path '\domainsoftwarepublicMyIP_1.0_x86MyIP_1.0_x86.appv'

    PackageId            : 32aa1202-f82c-44ee-8095-aee6e34edc70

    VersionId            : 37de4c04-a147-4b16-a1c1-c0bc25a40db2

    Name                 : MyIP_1.0_x86

    Version              : 0.0.0.1

    Path                 : \domainsoftwarepublicMyIP_1.0_x86MyIP_1.0_x86.appv

    IsPublishedToUser    : False

    UserPending          : False

    IsPublishedGlobally  : False

    GlobalPending        : False

    InUse                : False

    InUseByCurrentUser   : False

    PackageSize          : 548047

    PercentLoaded        : 50

    IsLoading            : False

    HasAssetIntelligence : False

    PS C:Windowssystem32> Publish-AppvClientPackage MyIP_1.0_x86

    PackageId            : 32aa1202-f82c-44ee-8095-aee6e34edc70

    VersionId            : 37de4c04-a147-4b16-a1c1-c0bc25a40db2

    Name                 : MyIP_1.0_x86

    Version              : 0.0.0.1

    Path                 : \domainsoftwarepublicMyIP_1.0_x86MyIP_1.0_x86.appv

    IsPublishedToUser    : True

    UserPending          : False

    IsPublishedGlobally  : False

    GlobalPending        : False

    InUse                : False

    InUseByCurrentUser   : False

    PackageSize          : 548047

    PercentLoaded        : 50

    IsLoading            : False

    HasAssetIntelligence : True

    Maybe the issue is with the application I am trying to package?  I shall have to try a few others and see if I've just randomly picked one that has an issue…

    Luke

    PS: Thanks for taking the time to reply!  🙂

  17. Anonymous says:

    Hi Sambit,

    Looks like a syntax error, can you share the commands you are running?

  18. Anonymous says:

    Now that's interesting, I have just sequenced the same application and delivered it via standalone mode and hit the same exact error! Looks like this issue is specific to some apps, I will investigate further…

  19. Excellent says:

    Great post. Very useful for testing App-V packages.

  20. me says:

    Thamim,

    For the life of me, i cannot get this to work. i keep getting a 0c80070057 error, application virtualization service failed to complete requested operation. operation attempted: configure appv package.

    Error module: streaming manager. internal error detail: 4c401c0c80070057. the forums at microsoft do not have a fix. these errors hardly come up on search engines. people still have this issue. i have no idea why i cannot get the clients to download and install update publish packages. clients are unsuccessful. ive taken every troubleshooting measure and applied it and still same result.

  21. Pat Sheahan says:

    In App-v 4 there were some registry entrires that needed to be modified.  Is this not the case with App-v 5.0?  Also, is standalone mode supported for production use?

  22. Maheswaran says:

    Hi Thamim,

    I'm also got the same error "0c80070057 " during installation.(standalone mode installation).any solution on this?

  23. Mark Van Noy says:

    It probably does not help to chime in, but I am also seeing this with R 3.0.0.  I have tried sequencing it three different times.  Version prior to version 3.0.0 sequenced and streamed under App-V 4.6 without any problems.  Under version 5 SP1 it chokes with the "AppV Error Code: 0C80070057" every time regardless of if I am streaming through SCCM 2012 SP1 or executing the Powershell commands interactively after copying the files to the local hard disk.  In a seemingly related error, I am seeing Matlab 2013a fail to stream from SCCM 2012 SP1 with an error about a Stack Overflow, but when I interactively execute the Powershell after copying the files locally it runs just fine.  I am starting to wonder if we have a sequencing issue and am tempted to try sequencing R 3.0.0 under App-V 4.6 then use the App-V 5 Powershell convert command to see if it runs correctly.

  24. Sambit says:

    Hi,

    While publishing a application getting the error like below, any idea ..

    Publish-AppvClientPackage : Application Virtualization Service failed to

    complete requested operation.

    Operation attempted: Publish AppV Package.

    Windows Error: 0x80004005 –

    Error module: Integration Manager. Internal error detail: 5C00122180004005.

    Please consult AppV Client Event Log for more details.

    At line:1 char:1

    + Publish-AppvClientPackage -Name

    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

       + CategoryInfo          : InvalidResult: (:) [Publish-AppvClientPackage],

      ClientException

       + FullyQualifiedErrorId : PublishPackageError,Microsoft.AppV.AppvClientPow

      erShell.PublishAppvPackage

  25. Tiberivs says:

    Great post. To quickly test pacakges on a local client I use the following commandline

    Add-AppvClientPackage -Path "\servercontentpackage.appv" | Publish-AppvClientPackage -Global | Mount-AppvClientPackage -Verbose

    This commandline, imports, published global and loads (streams) the package to 100%.

  26. Charo says:

    Dear Thamim,

    I am facing the Error Code: 100000000C when I am adding Office 2010 x86 package in Standalone mode.

    Other applications are working fine.

    In the event viewer, I can see the following error logs as well:

    Error 1008: Package {51461a66-3949-41ba-afc7-0d47752c9d9c} version {a34dc5b3-bac7-49be-ae66-b255599e8064} failed configuration in folder 'C:ProgramDataApp-V51461A66-3949-41BA-AFC7-0D47752C9D9CA34DC5B3-BAC7-49BE-AE66-B255599E8064' with error 0x79100E10-0xC.

    Error 4009: machine script for event AddPackage with command line: '"C:ProgramDataApp-V51461A66-3949-41BA-AFC7-0D47752C9D9CA34DC5B3-BAC7-49BE-AE66-B255599E8064Root..ScriptsIntegrator.exe"' exited with failure error code: Fatal error during installation.. Because Rollback is set to true in the script definition, the current AppV Client operation was rolled back.

    I already set the Execution Policy to unrestricted, but still the same issue.

    The package contains the Integrator.exe script.

    Office 2010 is sequenced using the same OS version as best practice.

    Please advise.

    Thank you.

    Add-AppvClientPackage -Path "C:Office2010_x86_SP1Office2010_x86_SP1_3.appv" -Dynami

    cDeploymentConfiguration "C:Office2010_x86_SP1Office2010_x86_SP1_3_DeploymentConfig.xml" | Publish-AppvClientPackage – Global

    Add-AppvClientPackage : Embedded Script process exited with an error code indicating failure (return code other than

    0). Please ensure that Embedded Script process can complete successfully and exits with 0.

    Operation attempted: Configure AppV Package.

    AppV Error Code: 100000000C.

    Please consult AppV Client Event Log for more details.

    At line:1 char:1

    + Add-AppvClientPackage -Path "C:Office2010_x86_SP1Office2010_x86_SP1_3.appv" -D …

    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

       + CategoryInfo          : InvalidResult: (:) [Add-AppvClientPackage], ClientException

       + FullyQualifiedErrorId : ConfigurePackageError,Microsoft.AppV.AppvClientPowerShell.AddAppvPackage

  27. Arka Gayen says:

    I would like to know if there is any way to uninstall an AppV package manually. Thanks.

  28. Thamim Karim says:

    Of course Arka, you can use the unpublish-appvclientpackage and remove-appvclientpackage command to achieve this.

  29. susaa says:

    Nice post ,
    But when we want to publish the package and updated package on the client machine from the server .
    Can you please let me know the process and cmdlets for this process
    Tnq Inadvance !