Installing the App-V 5.0 Client and configuring it with a Publishing Server


This post has moved here

Comments (23)

  1. Anonymous says:

    Great Article.

  2. Anonymous says:

    Thanks

  3. Anonymous says:

    Good shout Danny and useful info.I tend to avoid adding the remote-signed stuff into the blogs so I don't need to repeat myself in every post that contains PowerShell but definitely worth note for those who aren't familiar with it!

  4. Anonymous says:

    Forgot to sign in, I have added the previous comment.

  5. Anonymous says:

    no probs!

  6. Anonymous says:

    Thanks John

  7. Good blog, just what i was looking for. You might want to add that before importing the appvlient module you need to enable running scripts with "Set-ExecutionPolicy RemoteSigned”.  SP1 for App-V 5 has been released  but the new setup based on SP1 has the same steps as listed above so you can also add that it Applies to App-V 5.0 SP1.

  8. Daniel says:

    It seems when using a publishing server the applications are not published globally to all users. Can the client obtain that configuration setting from the publishing server or does one need to modify each package at the client level?

  9. John Amosu says:

    Excellent blog, more greese to your elbows

  10. Arokiyaraj M says:

    Hi Thamim,

       I am really struggling answer for this Question..

      1. How can I use the XML files [Deployment Config and User Config] of App-v 5.0 packages, If I install the package only through MSI. Is there any command line options to pass these XML files along with MSI or how it will be handled. Thanks

  11. Thamim Karim says:

    Hi,

    There isn't a switch. You have to understand the .msi is simply a wrapper for the PowerShell commands that adds your package in via standalone mode. The .msi isn't really designed for mass deployment, rather offers an option for unmanaged end users. If you do need to use the .msi then simply run the relevant PowerShell afterwards to specify the .xml. Does that help?

  12. Arokiyaraj M says:

    Really I want to know what is the Command line I have to use for having this XML after installing the MSI.

  13. CHAROX says:

    Dear Thamim,

    Thank you for keep blogging on App-V.

    I have been using the product since 4.5 version, I like this product.

    I have an issue with App-V 5 SP1.

    I have 3 virtual machines as the following:

    – App-V Management Server (2012 R2) + IIS 8.5

    – App-V SQL Server 2012 SP1

    – App-V Publishing Server (2012 R2) + IIS 8.5

    I deleted the Default Website from the IIS and I am using Port 80 for the management, 81 for reporting and 82 for publishing server.

    The Publishing Server is installed on a separate Server.

    I can see all my published application in the App-V management Web.

    I have registered the App-V Publishing server under Servers TAB in the management Web as well.

    I noticed many events errors logged in the Publishing Server, Events ID: 214 & 215

    – Event ID214 @ The request URL doesn't contain the query string for the client version.

    – Event ID215 @ The request URL doesn't contain the query string for the client OS.

    If I browsed the Publishing Server URL, I can see all my published applications:

    – <Publishing Protocol="1.0">

    – <Packages>

     <Package PackageId="4711e502-bff3-4e38-a2f3-7c1f164cf2fc" VersionId="9fbd534c-d8ab-47da-b1c2-4540cd947fe0" PackageUrl="\172.16.20.114Content$Computer Lab AppsActiveInspire.appv" />

     <Package PackageId="51461a66-3949-41ba-afc7-0d47752c9d9c" VersionId="a34dc5b3-bac7-49be-ae66-b255599e8064" PackageUrl="\172.16.20.114Content$Office2010_x86_SP1Office2010_x86_SP1_3.appv" />

    – <Package PackageId="d24c3bdd-8fad-44d3-998c-933f8f053682" VersionId="eb698da1-efa9-4545-beb9-f67cbb959f40" PackageUrl="\172.16.20.114Content$Office365_x86O365ProPlusRetail_en-us_x86.appv">

     <DeploymentConfiguration ConfigurationId="13" Path="policies_67/6/13" Timestamp="2013-11-12T05:46:23.41" />

     </Package>

     </Packages>

    – <NoGroup>

     <Package PackageId="4711e502-bff3-4e38-a2f3-7c1f164cf2fc" />

     <Package PackageId="51461a66-3949-41ba-afc7-0d47752c9d9c" />

     <Package PackageId="d24c3bdd-8fad-44d3-998c-933f8f053682" />

     </NoGroup>

     </Publishing>

    However, on the client side, the Error Log ID: 19104 is logged

    Part or all packages publish failed.

    published: 2

    failed: 1

    Please check the error events of 'Configure/Publish Package' before this message for the details of the failure.

    How can this be solved please?

    Your support is highly appreciated.

    Thank you.

  14. Thamim Karim says:

    Hi Arokiyaraj M,

    For the deployment configuration xml please use: Add-AppvClientPackage C:pathto.appv -DynamicDeploymentConfiguration C:pathtoxml

    For the user configuration xml please use: Publish-AppvClientPackage C:pathto.appv -DynamicUserConfigurationPath C:pathtoxml

    Hope that helps

  15. Thamim Karim says:

    CHAROX,

    There should be a related event further down in the event log which will refer to the issue more specifically.Can you try and publish the application that is causing the issue using standalone mode (as detailed here: blogs.technet.com/…/app-v-5-0-standalone-mode-adding-and-publishing-a-package.aspx)? Does that also error?

  16. CHAROX says:

    Thank you dear Tamim for your kind reply,

    I tried to publish the application that is causing the issue using Standalone mode but I am not getting any output (Office 365 and Office 2010 x86).

    After I ran below PowerShell cmdlet… the PO is not returning any result (Still in waiting mode). However, I published other packages without any issue.

    PC C:Add-AppvClientPackage -Path "C:PackagesO365ProPlusRetail_en-us_x86.appv" -DynamicDeploymentConfiguration "C:PackagesO365ProPlusRetail_en-us_x86_DeploymentConfig.xml"  | Publish-AppvClientPackage -Global

    No Error logs in the event viewer on the client side.

    Client OS: Win 7 Pro X86 with SP1

    Sequencer: Win 7 Pro X86 with SP1

    I am having an issue with Office in general.

    Your support is highly appreciated.

    Thank you and regards,

  17. CHAROX says:

    Dear Tamim,

    I am running Windows Power Shell V4.0, is App-V 5 SP1 client supports Power Shell 4.0 yet?

    I tired the same packages on a client with POS 3.0 without any issue! Weird….

    Please advise.

    Thank you.

  18. Madhava says:

    Hi,

    When i am install app-v  5.0 Client in win 7 I am getting error

    Setup cannot continue

    Unspecified error  

  19. Ramesh says:

    Hi All,
    I am entire new to Application Virtualization.
    I have lot of questions in mind.
    1). Application Virtualization where we install either server/client system.
    2).Installation is done how to connect the APP V?

    Please let me know.

    Best Regards,
    Ramesh

  20. nick says:

    Hi Folks,

    What is the commandline to install App-V 5 client with publishing server name.

  21. Anonymous says:

    With App-V we have something called “Full Infrastructure”, this is used to refer to an App

  22. Srujana Vemuri says:

    Dear Thamin Karim,

    Any ideas on the error below error. I am getting this on non domain joined systems only. Works fine when I run it on domain joined systems. I am App V 5.0 Sp3.

    My App-v Client for desktop is installed on windows 2012 R2 and win 8 machine, hence i believe
    https://support.microsoft.com/en-us/kb/2778168 , this kb link is not applicable.

    Sync-AppvPublishingServer

    cmdlet Sync-AppvPublishingServer at command pipeline position 1
    Supply values for the following parameters:
    ServerId: 1
    Sync-AppvPublishingServer : Application Virtualization Service failed to complete requested operation.
    Operation attempted: RefreshPublishingServer.
    Windows Error: 0x80190191 –
    Error module: Publishing. Internal error detail: 45500D2780190191.
    Please consult AppV Client Event Log for more details.
    At line:1 char:1 + Sync-AppvPublishingServer

    I have run the following commands

    Get-AppvPublishingServer -Name * | Remove-AppvPublishingServer

    Add-AppvPublishingServer -Name MyServer -URL http://*mypublishingserver*:*port*

    I was not able to see package id of the published applications by accessing the publishing server url from the App-client desktop. Hence added Windows credential with Publishing server name & Username as DOMAINUsername.

    After adding windows credential i was able to view the package id for the published apps.

    Then i tried to run this command Sync-AppvPublishingServer -ServerId 1, but still getting error as follows:
    Sync-AppvPublishingServer : There were errors encountered when trying to publish packages from the server.

    Operation attempted: RefreshPublishingServer.

    AppV Error Code: 070000000B.

    Please consult AppV Client Event Log for more details.

    At line:1 char:1

    + Sync-AppvPublishingServer -ServerId 1

    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo : InvalidResult: (:) [Sync-AppvPublishingServer], ClientException

    + FullyQualifiedErrorId : RefreshPublishingServerError,Microsoft.AppV.AppvClientPowerShell.SyncAppvPublishingSer

    Virtual Applications are on UNC shared path on a different server than publishing server.Both these servers are domain joined.

    Are we missing anything. Our Non-domain joined desktop is windows 2012 R2 and Win 8 machines on which App-v 5.0 Sp3 desktop Client is installed.

    Do we need to run any hotfixes on App-v server or app-v client for resolving sync issues.

    Your support is highly appreciated.

    Thank you.