SfB Server: Cannot install KB2982006 – This update is not applicable to your computer.

In a previous post we explained how to install the KB2982006:

Prerequisite (KB2982006) not satisfied when trying to install Skype for Business Server 2015
https://blogs.technet.microsoft.com/uclobby/2015/07/11/prerequisite-kb2982006-not-satisfied-when-trying-to-install-sfb-server-2015/

However, in a recent deployment with all the Windows Updates installed, including the KB2919442 and KB2919355,  we couldn’t install the KB2982006:

We also got the same error in the Event Viewer > Windows Logs > Setup:

Log Name: Setup
Source: Microsoft-Windows-WUSA
Date: 04/09/2017 18:48:44
Event ID: 3
Task Category: None
Level: Error
Keywords:
User: RECORE\Administrator
Computer: sfbstd.recore.lab
Description:
Windows update could not be installed because of error 2149842967 “” (Command line: “”C:\Windows\system32\wusa.exe” “C:\UCLobby\Windows8.1-KB2982006-x64.msu” “)

The good news is we can use the DISM tool to manually add the KB2982006.

Before using DISM we need to make sure that KB2919442 and KB2919355 are already installed:

Get-Hotfix KB2919442,KB2919355,KB2982006

Please note that we cannot use a .msu file if we use the Online switch with DISM:

dism /Online /Add-Package /PackagePath:C:\UCLobby\Windows8.1-KB2982006-x64.msu

We have to expand the .msu file first using the steps described here:

How to use DISM to install a hotfix from within Windows
https://blogs.technet.microsoft.com/askcore/2011/02/15/how-to-use-dism-to-install-a-hotfix-from-within-windows/

An easy way is to create a folder and copy the Windows8.1-KB2982006-x64.msu file and also create a KB2982006 sub-folder:

Then we expand the .msu with the following cmdlet:

Expand -F:* C:\UCLobby\Windows8.1-KB2982006-x64.msu C:\UCLobby\KB2982006
https://technet.microsoft.com/en-gb/library/cc722332(v=ws.10).aspx

Since we have a .cab file we can proceed and manually add the KB2982006 with DISM:

dism /Online /Add-Package /PackagePath:C:\UCLobby\KB2982006\Windows8.1-KB2982006-x64.cab

With Get-Hotfix we confirm that KB2919442, KB2919355 and KB2982006 are installed:

Get-Hotfix KB2919442,KB2919355,KB2982006

Finally, we run Step 2 and confirm that the check for KB2982006 is successful: