LCS 2003 and Vista


I was contacted by Ian Fischer with an interesting question regarding LCS 2003 and Vista.

I now need to support Vista clients and I have found out  that Messenger 5.1 doesn't work on it.  It crashes constantly.  I run LCS 2003 and need a client to work on Vista.  I heard OC 2007 works, but I tried and it didn't.  Are there any tweaks to get it to work, or is there a workaround for Vista users who login to LCS 2003?

The plan is to eventually move to Office Communications Server 2007 but that won’t happen immediately and so an interim solution was needed.  Windows Messenger 5.1 is not supported on Vista and Office Communicator 2005 will not connect to LCS 2003. What does a customer do?

The options are few but here is the list of ideas I had:

1. Communicator Web Access – requires OCS 2007 (or LCS 2005 SP1), the Vista workstations can use a browser and not a desktop client.  Communicator Mobile would also be an option for any devices if needed.

2. Windows XP either as a host and Vista as virtual machine or Vista as host with XP in virtual machine. I would not say that it is the most elegant solution but it will work. The biggest issue I have found doing this in my labs is forgetting a VM is running and the client logged in and missing IM. I would not suspect this to be common for an end user as I am testing everything.

LCS 2005 Sp1 – for Ian this is not currently purchased so there are purchase and licensing implications of this step.

Skip to main content