Management Pack System Center Core Library não é actualizado no CU5


Se, depois de actualizar o ambiente SCOM 2007 R2 para o Cumulative Update 5, abrir a consola de Authoring e tentar editar um MP e esta apresentar erros de falta do Management Pack “System.Center.Library.mp” versão 6.1.7221.81, o mais provável é que tenha antes importado a versão 6.1.7221.61, conforme resolução apresentada na KB 2590414.

http://support.microsoft.com/kb/2590414/en-us

Existe um erro no script de actualização (CU5_Database.sql), que vai procurar a versão 6.1.7221.50 em vez da .61:

SET @compare = dbo.fn_VersionCompare (@ver, ‘6.1.7221.50’)

IF( @compare = -1)

 

Portanto, se fez a actualização recomendada na KB vai ter a versão .61 do MP instalada e o script de actualização não a vai reconhecer e não actualizará para a .81.

A solução passa por descarregar a nova versão neste site e importa-la na consola de SCOM:

download.microsoft.com/…/System%20Center%20Library%20Monitoring%20Pack%20for%20OpsMgr%202007%20R2.msi

 

 

Comments (0)

Skip to main content