May 2015 CU for SharePoint 2010 has been released


The product group released the May 2015 Cumulative Update for the SharePoint 2010 product family.

For May 2015 CU we again have full server packages (also known as Uber packages). No other CU is required to fully patch SharePoint.

Be aware that the May Cumulative Update for SharePoint 2010 is a Post-SP2 hotfix. It is required to have SP2 installed before installing the May CU.
It is required to have SP2 installed for the base product and all installed language packs to install May 2015 CU for SharePoint 2010.

This CU includes all SharePoint 2010 fixes released since SP2. The CU does not include SP2.

The KB articles for May CU are available at the following locations:

  • KB 3017815 - SharePoint Foundation 2010 - This is also a security fix!
  • KB 3015569 - SharePoint Server 2010
  • KB 2999496 - Project Server 2010

The Full Server Packages for May 2015 CU are available through the following links:

After installing the fixes you need to run the SharePoint 2010 Products Configuration Wizard on each machine in the farm.

Be aware that the SharePoint Server 2010 CU contains the SharePoint Foundation CU.
That means only one package has to be installed for the SharePoint 2010 product family.

Related Links:

Comments (7)

  1. Anonymous says:

    Ya tenemos disponibles las actualizaciones acumuladas para SharePoint 2010 y SharePoint 2013 correspondientes

  2. Anonymous says:

    Buenas, Está disponible ya la Actualización Pública para Project 2010 y Project Server 2010 , correspondiente

  3. TD says:

    Hello,

    Is the MS15-47/3017815 included in the KB2999496 package eventhough it isn't listed?

    Thanks
    TD

  4. thomas says:

    Hi Stefan,
    from March to May some of the MS Office SharePoint patches have been installed by our server team via LANDesk. To add to the problem in May there was a problem with LANDesk not installing all patches on all servers with all Language Packs.

    We do now experience problems when installing CU April/May 2015 on a three server farm (1 appl. 2 WFE server).

    First I installed CU April 2015 and the Config Wizard reported missing patches on 1st WFE server. Since I was sure these missing patches are due to the failing May Update I tried to install CU MAY 2015. No the Config Wizard reports missing patches on both WFE
    servers. The missing patches are the CUs April/May itself for several Language Packs.

    When I now try to install the CU again I get "There are no products affected by this package installed on the system".

    Is there a way to force the CU installation? Or any other method to get the missing patches installed?

    It is only a Preproduction system but I would really appreciate if you could help.

    Thanks and Regards
    Thomas

  5. Hi Thomas,
    you cannot force a fix to be installed again if it has been installed in the past.
    I would recommend to open a support case with Microsoft to get your specific system analyzed in detail to identify what is missing to resolve this issue in a supported way.
    Cheers,
    Stefan

  6. thomas says:

    Hi Stefan,
    thank you for your quick reply.
    When googling the exact error message I found this solution:

    Try checking whether server needs upgrade or not by running the following PowerShell command
    (Get-SPServer $env:computername).NeedsUpgrade
    It will return true, if it needs upgrade. After running this command in all the servers, try running Psconfig in server hosting Central Admin. This solved the issue for me.

    I run this on all three servers and the SP Config Wizard is currently running on the Application Server.

    Thank you and all the others contributing and publishing their solutions on the internet.

    Best Regards
    Thomas

Skip to main content