TMG services hang at startup due to third party service.

This post is once again about an issue I worked on few days back. Before I start discussing about the issue and how I resolved it, I would like to mention that objective of this post is to make TMG admins aware of the issue and what can be done to resolve it, The steps…

0

Data analysis with TMG data packager.

I have uploaded a presentation about Data analysis using with TMG data packager. Purpose is to help Peers and admins to let them help themselves in analyzing the data to certain point. I also want to add here that certain part of the data can only be analyzed by us only e.g. ISAtracing. In this presentation ISAtracing…


UAG DA Clients do not connect to the Internal network and on UAG server we get a Getting "A client certificate was not provided" warning

This is one of the most interesting cases ,I worked on recently , So I thought of sharing that with all to provide different angles to a problem we usually work and troubleshoot for resolution. This case was opened with a description as explained in the title i.e. DA clients were not able to connect…


Threat Management Gateway (TMG) services do not start with event Id 21235 in the event viewer

Here’s some info on an interesting support issue I worked the other day. If you happen torun into this one day, maybe this will help you get it resolved. Issue: Microsoft Forefront Threat Management Gateway (TMG) services do not start. To start the services, we needed to clear NLB and reconfigure NLB. Troubleshooting and Resolution…


Authentication issues on internal machines if external web server has NTLM authentication

I worked on a case recently  where we had external web server on which we had NTLM authentication and users who were trying to access the website on it were having problems accessing it. I have written blog on our ISA/TMG product team blog here is the link http://blogs.technet.com/b/isablog/archive/2012/05/25/authentication-failure-while-trying-to-access-a-website-through-tmg-as-forward-proxy.aspx   it turned out to be…


Cross site single sign on not working between two UAG servers

As usual I worked on a case regarding cross site single sign on and thought of sharing the experience and observations with all. Here customer has configured cross site single sign on as per the document http://technet.microsoft.com/en-us/library/ee921441.aspx But in his environment he had two separate UAG servers one with UAG RTM update 2 and other was UAG…


UAG Network Connector and configuration on Packaged TMG

Note: After working on this case, i got curious and did some lab work and found few interesting things, which tells that observations below are really rare and you dont have to do this as you run into following scenario very rarely. I will mention ny observations of lab work in next post that will…