WSS–Search is not working, no results being returned

Search is not working on your WSS 3.0 farm. Customer was receiving "No results were returned’. They had one web application and several site collections under it.

Environment Details:

  • WSS: build level:
  • Windows 2003 OS – SP2 –x86
  • SQL Server Version: 2005 – SP3 – x86
  • Search is running on 2 different servers on 2 different search databases


  • This customer had a ton of data (almost 2 TB and thousands of site collections), so we changed the indexing schedule for the search service to run once daily, instead of every 10 minutes that they had set
  • Stopped the crawl on both servers with the following command:
    stsadm –o spsearch –action fullcrawlstop
  • Verify that the crawl stopped by looking at the msscrawlurl table, see that it is no longer being populated
  • We found the following error codes on already running crawls on different documents:
    Error 3 – "Some parts of this document cannot be accessed"

    Error 4 – "Content for this URL is excluded by the server because a no-index attribute

    Error 7 – "The file reached the maximum download limit. Check that the full text of the document can be meaningfully crawled.

  • Started another crawl by this command:
    stasadm –o spsearch –action fullcrawlstart
  • Looked at the msscrawlurl table to see that it was being populated, which means that the crawl is running


Fight Comparison:
This was Larry Holmes vs Ernie Shavers…I got beat up and knocked down a bit, but pulled through

Comments (0)