SharePoint Farm Credentials – Error encrypting or decrypting credentials


I would give you the background on how this SharePoint environment ended up in such disarray, but considering that it took me 9 hours to get it back up and running, there were way too many things for me to take note of.  This little baby stuck out though.

I was running stsadm to update the Central Admin account (-o updatefarmcredentials), and I got this error message:

There was an error encrypting or decrypting credentials. Either a credential update is currently being performed, or you must update the farm account credentials on this server before you can perform this task.

The irony?  I’m trying to update the farm account credentials, and SharePoint is yelling at me to update the farm account credentials. 

So, if you come across this, save yourself the time of searching all over the www, and download this hotfix from Microsoft.  It will resolve the error for you. 

Windows SharePoint Services 3.0 hotfix package
http://support.microsoft.com/kb/957691

Excerpt:

When you use the stsadm -o updatefarmcredentials -userlogin DomainName\UserName -password NewPassword command to update Microsoft Office SharePoint Server farm credentials, you may receive the following error message: There was an error encrypting or decrypting credentials

Comments (1)

  1. will says:

    Yeah got this message after a failed attempt at updating the farm credentials. I was able to overcome the issue by doing the following:

    1) Run stsadm -o updatefarmcredentials -userlogin [domainuser] -password [password] -local
    2) Run stsadm -o updatefarmcredentials -userlogin [domainuwer] -password [password] -resume

    I think the resume parameter is a new add on with SP3, but it seems to resolve the problem. Perhaps, it is telling the moss instance to handle the situation where the credentials have gotten out of synch.

Skip to main content