Authentication Issues Accessing Companyweb from the Server Itself after 963027 or Windows 2008 SP 2

[Today’s post comes to us courtesy of  Ketan Thakkar, Manish Kapoor, Chris Puckett, and Justin Crosby]

You may experience authentication issues browsing http://companyweb on SBS 2003 and SBS 2008 servers after installing the cumulative security update for Internet Explorer (963027 or 969897) or Internet Explorer 8.0 or Windows Server 2008 Service Pack 2.

When you try to browse Companyweb you will be prompted for authentication 3 times and eventually receive a blank page or 401.1.  Your IIS logs will show your request failing with 401.1 Unauthorized.

Resolution

Please use one of the following resolutions depending on the version of SBS you are running.

SBS2003

On an SBS 2003 server this issue can be fixed by applying update KB961143.

Note: You must have .NET Framework 2.0 installed before you apply this update.

SBS2008

On an SBS 2008 server this issue can be fixed by applying SBS 2008 Update Rollup 2 (960911).  This update is now available on Microsoft Update and WSUS (must be approved by administrator).  

Updated 6/26/2009 to include 969897 MS09-019: Cumulative security update for Internet Explorer.  

Updated 5/1/2009 to include Windows 2008 SP 2. 

Updated 4/28/2009 due to release of Update Rollup 2.

The workaround provided in the following blog post for IE 8.0 also applied to IE 7.0 with 963027 installed.  http://blogs.technet.com/sbs/archive/2009/02/24/known-issues-after-installing-ie-8-on-small-business-server-2008-and-the-vista-clients-that-are-joined-to-the-sbs-domain.aspx.

Note: This issue will be fixed in upcoming update rollup for SBS 2008. We will update this post when it is available.

On SBS 2008 you can also implement method #2 from KB963027.