Search host controller service and content processing service on SharePoint Server is down. SharePoint 2013

Search host controller service and content processing service on SharePoint Server is down. In search topology we are cross mark for content processing . In ULS Failed to connect to Host controller in Server : xxxxxxxx. Exception : System.ServiceModel.EndpointNotFoundException: There was no endpoint listening at net.tcp://xxxxxxx/ceres/hostcontroller/nettcp that could accept the message. This is often caused…


SharePoint 2013 in Claims Authentication through PingFederate 6.6, crawl issue

SharePoint 2013 is running with Claims Authentication through PingFederate 6.6.  When we setup the search service it uses an AD account to authenticate and run the crawl.  Since it’s claims authentication we extended the site to use claims with NTML.  Unfortunately, when we look at the search results we are only seeing results when we…


XML Viewer web part SharePoint 2013

We are trying to add a XML Viewer web part on the page  and getting error "Cannot retrieve the URL specified in the XML Link property. For more assistance, contact your site administrator." where as same setting is working fine in Moss 2007   Reason : SharePoint is currently configured to block intranet calls  …


SP 2013 Error when upgrading the User Profile service application

      While upgrading UPA from SharePoint 2010 to SharePoint 2013 we got error in PowerShell.   New-SPProfileServiceApplication : Action of Microsoft.Office.Server.Upgrade.ProfileDatabaseSequence failed. At line:1 char:8 + $upa = New-SPProfileServiceApplication -Name ‘User Profile Service Application’  … + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~     + CategoryInfo          : InvalidData: (Microsoft.Offic…viceApplication:    SPCmdletNewProfileServiceApplication) [New-SPProfileServiceApplication], S   PUpgradeException     +…


SPS 2013 Error connecting to subsite – An unexpected error has occurred

  When we try to access subsite "https://testesite/xxxx/xxxxx/xxxxxx/" we get unexpected error   When we try to Stsadm –o Deactivatefeature   -name  navigation [-url] <URL name> sites loads fine.   03/18/2013 15:47:12.28 w3wp.exe (0x15D0) 0x21E0 Web Content Management Publishing 8vzf High PortalSiteMapProvider was unable to fetch children for node at URL: /sites/########/######, message: Thread was being…


Distributed Cache in SharePoint 2013 -"Unexpected exception in FeedCacheService.IsRepopulationNeeded: Cache cluster is down, restart the cache cluster and Retry."

  We had issue with Distributed Cache in SharePoint 2013 In ULS and event we were getting lots of errors related to Distributed cache.   Event ID:      6398 Task Category: Timer Level:         Critical Keywords:      User:          xxxxxxxxxxx Computer:      xxxxxxxxx Description: The Execute method of job definition Microsoft.Office.Server.UserProfiles.LMTRepopulationJob (ID ba320718-0e80-4295-a3f8-a4badea59f0d) threw an exception. More information is included…


"Unable to load Jit Compiler: (mscorjit.dll): File may be missing or corrupt.

After installed to various security updates for windows 2003 non of the SharePoint sites are loading, central admin site is also not loading. We are getting error "Unable to load Jit Compiler: (mscorjit.dll): File may be missing or corrupt. Please check or rerun setup. " While running aspnet_regiis –i we got error      …


An error occurred while trying to connect to a Web service.

  While opening InfoPath form at name newfrom we getting error. An error occurred while trying to conned to a Web service, An entry has been added to the Windows event log of the server. Log ID:5566 Correlation ID:ed55029c-xxxx-703b-xxxxx-5balBl xxxxxx   In ULs we can see       Solution for the issue is….


Trying to install SharePoint 2013 on server 2012 Unable to install the application to web server IIS role

    We were trying to install SharePoint 2013 (Foundation) on server 2012 and getting error during prerequisite installation.   We collection data from temp directory. In logs we can clearly see that it throws error while enabling ASP.NET v4.0.30319   2013-02-19 13:16:28 – "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe" -i 2013-02-19 13:16:28 – Install process returned (0) 2013-02-19 13:16:28…


ESP Prerequisite Visual C++runtime libraries

  During a ESP 5.3 multi node installation we were getting error. The required C/C++ runtime libraries are not installed on host ‘’. Please install the ‘Microsoft Visual C++ 2005 Redistributable Package’ (SP1 or newer) available from   When we checked machine we found that its already installed         On sever…