Testing AD FS Signon Page - An Error Occurred


There are many causes for receiving errors when signing onto AD FS.  However some are more genuine than others.  This is a quick tip to check that you are on the right track before diving into the details and potentially spending time troubleshooting when in fact nothing is wrong.  Just lately, for some reason I’m seeing this more frequently.  That has prompted the draft from last October to be finished off and posted!  This also manifests it self where one person says AD FS is working but the other says no, as they are doing different things…..

AD FS 2012 R2 and 2016 has the ldpinitiatedsignon.aspx page, where we can quickly test out the solution to see if it is working as expected.  Though if things are not quite peachy, the below may be displayed.

AD FS 2012 An Error Occured

Drilling into the error text on the right hand side will show the below:

AD FS 2012 An Error Occured - Details

And for make benefit most glorious search engines:

An error occurred

An error occurred. Contact your administrator for more information.

Error details

  • Activity ID: 00000000-0000-0000-1a00-0080000000d0
  • Error time: Wed, 16 Nov 2016 18:14:42 GMT
  • Cookie: enabled
  • User agent string: Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 10.0; WOW64; Trident/7.0; Touch; .NET4.0C; .NET4.0E; .NET CLR 2.0.50727; .NET CLR 3.0.30729; .NET CLR 3.5.30729; Tablet PC 2.0)

Is something really wrong? In this case, actually it is not….

Typos Will Burn You Every Time

As discussed in the original posts to install and configure AD FS for Office 365, the URL that was used for testing was:

https://adfs.tailspintoys.ca/adfs/ls/idpinitiatedsignon.aspx

 

However, if you look really closely the URL in the initial screenshot is this:

https://adfs.tailspintoys.ca/adfs/ls/ldpinitiatedsignon.aspx

Don’t squint and hurt your eyes, they are different. 
Wrong URL: https://adfs.tailspintoys.ca/adfs/ls/ldpinitiatedsignon.aspx
Correct URL: https://adfs.tailspintoys.ca/adfs/ls/idpinitiatedsignon.aspx

Note that the wrong URL has Ldpinitiatedsignon – a “L” was used mistakenly instead of an “I”.

One handy trick for troubleshooting issues like this is to take the text and past into notepad, that way you can do a side by side comparison.  Crank up the font size to make it easier to see.

The devil is in the details, but as IT admins we all know that already!

Cheers,

Rhoderick

Comments (3)

  1. turbomcp says:

    Thanks
    small notice on 2016 server...that link doesn't work by default
    you need to enable it...

    1. Yes! Separate post on that is already in draft, but I've been floored by how often this has come up on 2012 R2 in the last few weeks 🙁

      Cheers,
      Rhoderick

  2. Occam's razor applies... If this page doesn't show up on ADFS 2012 R2, it is very likely a simple typo 🙂 And I do see that on a monthly basis on site...

Skip to main content