Lync 2013 Client: Users unable to logon from specific workstations


Recently, a customer came to me and asked if I could help them troubleshoot an issue with user logon. The symptom was that no users could logon with the Lync 2013 client from specific workstations. First thing I asked for was both the .etl and uccapi logs. I started with the UCCAPI logs and found the following error messages:

After researching this issue it had to do with permissions on the network profiles keys within the Registry.

Resolution:

http://blogs.technet.com/b/networking/archive/2009/06/19/missing-network-map-under-network-and-sharing-center-in-windows-vista-or-windows-server-2008.aspx

  1. Right Click over the registry location: HKLM\Software\Microsoft\WindowsNT\CurrentVersion\NetworkList\ and then choose Permissions
  2. Click Add
  3. Please choose your computer for "From this location:" instead of your Active Directory domain, by clicking on Locations
  4. Under "Enter the object names to select" type NT SERVICE\netprofm and then click on Check Names (make sure you type the username exactly how it's shown or it will not work)
  5. Press OK to confirm
  6. Once we have netprofm in place, click on Advanced as we need to specify special permissions (as per the below figure) for netprofm.

      7. Reboot the Workstation

 

Hope this helps!!!


			

 


Comments (1)
  1. VK says:

    In traces we get networksavaiable=0 which indicates permissions issue on the network profiles keys within the Registry

Comments are closed.

Skip to main content