Invalid version of project database: 4.0.0.0. The supported version is ‘15.0.347.0’ or higher.


Issue

While upgrading Project Server database from Project Server 2013 to Project Server 2016, below error message is noticed.

 

Migrate-SPProjectDatabase : Invalid version of project database: 4.0.0.0. The

supported version is ‘15.0.347.0’ or higher.

    Use Project Server 15 to upgrade the database and then retry the migration

command

At line:1 char:1

+ Migrate-SPProjectDatabase

+ ~~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo          : InvalidArgument: (Microsoft.Offic…ProjectDatab

   ase:PSCmdletMigrateSPProjectDatabase) [Migrate-SPProjectDatabase], SPExcep

  tion

    + FullyQualifiedErrorId : Microsoft.Office.Project.Server.Cmdlet.PSCmdletM

   igrateSPProjectDatabase

 

Potential Cause

Project Server database was attempted to upgrade as the content database first. In other words, the content database upgrade command was used, instead of the Project Server database upgrade command.

 

Resolution

Restore the Project Server database and attempt the migration again.


Comments (0)

Skip to main content