“The installation of this package failed” error while installing April 2013 CU (KB 2726992) for SharePoint 2013


There have been issues reported where the installation of April 2013 CU for SharePoint 2013 fails with the following error:

“The installation of this package failed”

If you navigate to the temp file location (open windows explorer and type %tmp% in the address bar) and open the log file, “OPatchInstall(1).log”, located in %Userprofile%\AppData\Local\Temp\2 folder, you will see the following error:

OPatchInstall: Getting the data from the file 'C:\temp\UBERSRV_1.CAB'
OPatchInstall: Thrown CDetectionExceptionWin32(2)

If you extract the contents from the executable ZIP file, you will see it contains two files; an exe and a cabinet file.

j5ccjl4o

If you only copy the ubersrv2013-kb2726992-fullfile-x64-glb.exe to a different location and try to install the CU, the operation will fail with the aforementioned error. The is because the CU is dependent on the 'ubersrv_1.cab' file and hence both the exe and the cab file need to be in the same location for the installation to complete successfully.

To investigate and resolve update installation failures, see KB 954713

Update

The issue can also occur while installing June 2013 CU (KB 2817363) for SharePoint 2010.

Comments (18)

  1. Ed (DareDevil57) says:

    I had the same problem but i had both files, i downloaded the file again and it worked. Thanks for sharing.

  2. Ed (DareDevil57) says:

    I had the same problem but i had both files, i downloaded the file again and it worked. Thanks for sharing.

  3. ktaber says:

    The same error occurs when installing the June 2013 CU for SharePoint Services 3.0.

    However, in this case the extracted hotfix only contains the file uberwss2007-kb2817329-fullfile-x64-glb.exe

    There is no CAB shipped with this update. Any ideas?

  4. Praveen says:

    @ktaber,

    We do have cab file in the hotfix package

    ubersrv2010-kb2817527-fullfile-x64-glb.exe

    ubersrv_1.cab

    Could you recheck the package?

  5. ktaber says:

    @Praveen that is a different file than I'm using.. the file name for the WSS 3.0 June CU  starts with uberwss2007 not ubersrv2010.

  6. Xopher says:

    I had this problem and tried all sorts of different ideas before I finally got the June update to work.

    I initially downloaded the file on one server, unzipped it and copied it around from server to server. This apparently was what was causing the install to fail. I had to download the update on each server for it to run successfully.

  7. what says:

    not helpful at all

  8. Anonymous says:

    # Issue 1:
    During Installing SharePoint 2013 Prerequisites there was an error in installing Application

  9. Sathishg1 says:

    Still facing the problem

  10. Manny says:

    You need all three files for it to work: ubersrv.exe, ubersrv_1.cab and ubersrv_2.cab. like here

    http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=2881061&kbln=en-us

  11. Kerpse says:

    Great to find things out but how can Microsoft not provide any instructions whatsoever for the installation? First confusion was with the fact that the June 2014 CU contains 3 files to download. The second confusion was with the actual installation. If
    you only extract the ubersrv.exe from the 476037_intl_x64_zip.exe and try to install it, it gives the error. You have to extract all the files to the same directory before you can install the CU. How am I suppose to know that if there is no instructions in
    the KB article http://support.microsoft.com/kb/2881061. The knowledge base article seems like it is written by a lawyer.

  12. Lizrdb says:

    Thank you for the comment about the June 2014 CU! I was tearing my hair out trying to figure out why the install kept failing. In my case, I had the .exe and one .cab file and then a whole bunch of other files – the third .exe would self-extract the .cab
    instead of leaving it whole. I finally had to use Winzip to extract the file. Frustrating! And yes, instructions explaining that you need to extract the downloaded files to the same directory and that you will end up with one .exe and two .cab files would
    be been very welcomed.

  13. Ravi says:

    Thanks alot

  14. Sohail says:

    Extract/Unzip all hotfix *_zip.exe files into one directory and run exe files. This will install CU.

    Cheers
    Sohail

  15. ashton says:

    Thank you, it worked for me, June CU.

  16. alex says:

    I had the same issue with August 15 update, resolution: move .exe and two .cab files to appdatalocaltemp and run .exe as admin.

  17. Nice Post..

    For this particular CU there were two additional .cab files that needed to be downloaded. Once I downloaded and extracted these .cab files to the same directory as the .exe from the uber package the installation ran as expected.

  18. Vinod Kumar says:

    When am try to Install the LYNC-2013 at 64-bit its showing the error msg: The Installation of this package is failed. Please kindly help me its very important for me…

Skip to main content