Deploying the Office Web Apps Server 2013 – "Microsoft Office Web Apps Server 2013 Encountered an error during setup"


If you are planning to deploy an Office Web Apps Farm, the following data could be useful for you in case you are encountering the "Microsoft Office Web Apps Server 2013 Encountered an error during setup" error while running the installation package.
It specifically happens on virtual environments with Windows Server 2012 (R 2) and the error looks like in the screenshot bellow:

In the Event Viewer this error is recorded with following data:

  "Microsoft Office Web Apps Server 2013 Encountered an error during setup"
In the event viewer is reported the following log:
Faulting application name: MsiExec.exe, version: 5.0.9600.17415, time stamp: 0x54505262
Faulting module name: KERNELBASE.dll, version: 6.3.9600.17415, time stamp: 0x54505737
Exception code: 0xe06d7363
Fault offset: 0x0000000000008b9c
Faulting process id: 0x78c
Faulting application start time: 0x01d098872e5fe7d6
Faulting application path: C:\Windows\System32\MsiExec.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll

Also if you take a look into the installation logs you can see the following entries:

———————————————————————————————————

[DATE] [TIME] ::[PID] MSI(INFO): 'CustomAction ArpWrite returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)'

|

|

|

[DATE] [TIME] ::[PID] MSI(INFO): 'Property(S): ERRORSUPPORTTEXT_PROBLEM = If problem persists, contact Microsoft Product Support Services (PSS) for assistance.  For information about how to contact PSS, see C:\Users\UserName\AppData\Local\Temp\2\Setup000007c4\PSS10R.CHM.'
[DATE] [TIME] ::[PID] MSI(INFO):'Property(S): ERRORSUPPORTTEXT_PERMISSION = Verify that you have sufficient permissions to access the registry or contact Microsoft Product Support Services (PSS) for assistance.  For information about how to contact PSS, see C:\Users\UserName\AppData\Local\Temp\2\Setup000007c4\PSS10R.CHM.'
[DATE] [TIME] ::[PID] MSI(INFO): 'Property(S): ERRORSUPPORTTEXT = Contact Microsoft Product Support Services (PSS) for assistance.  For information about how to contact PSS, see C:\Users\UserName\AppData\Local\Temp\2\Setup000007c4\PSS10R.CHM.'
[DATE] [TIME] ::[PID] MSI(INFO): 'Property(S): ArpWrite = CacheLocation;Contact;Comments;DisplayIcon;DisplayName;DisplayVersion;HelpLink;HelpTelephone;InstallLocation;ModifyPath;NoElevateOnModify;NoModify;NoRemove;NoRepair;PackageRefs;ProductCodes;ShellUITransformLanguage;SkuComponents;SPPSkuId;SystemComponent;UninstallString;URLInfoAbout;URLUpdateInfo;VersionMajor;VersionMinor'

|

|

|

[DATE] [TIME] ::[PID] MSI(INFO):'Property(S): SETUPSUPPORTURL = http://support.microsoft.com/?kbid=xxxxxx'
[DATE] [TIME] ::[PID] MSI(INFO):'Property(S): ERRORSUPPORTTEXT_RETAIL_DEFAULT_PROBLEM_PRE = If problem persists, contact Microsoft Product Support Services (PSS) for assistance.  For information about how to contact PSS, see '
[DATE] [TIME] ::[PID] MSI(INFO): 'Property(S): ERRORSUPPORTTEXT_RETAIL_DEFAULT_PROBLEM_POST = .'
[DATE] [TIME] ::[PID] MSI(INFO):'Property(S): ERRORSUPPORTTEXT_RETAIL_DEFAULT_PERMISSION_PRE = Verify that you have sufficient permissions to access the registry or contact Microsoft Product Support Services (PSS) for assistance.  For information about how to contact PSS, see '
[DATE] [TIME] ::[PID] MSI(INFO):'Property(S): ERRORSUPPORTTEXT_RETAIL_DEFAULT_PERMISSION_POST = .'
[DATE] [TIME] ::[PID] MSI(INFO): 'Property(S): ERRORSUPPORTTEXT_RETAIL_DEFAULT_PRE = Contact Microsoft Product Support Services (PSS) for assistance.  For information about how to contact PSS, see '
[DATE] [TIME] ::[PID] MSI(INFO): 'Property(S): ERRORSUPPORTTEXT_RETAIL_DEFAULT_POST = .'
[DATE] [TIME] ::[PID] MSI(INFO): 'Property(S): ERRORSUPPORTTEXT_OEM_DEFAULT = Contact your computer manufacturer's product support for assistance.'
[DATE] [TIME] ::[PID] MSI(INFO): 'Property(S): ERRORSUPPORTTEXT_OEM_DEFAULT_PERMISSION = Verify that you have sufficient permissions to access the registry or contact your computer manufacturer's product support for assistance.'
[DATE] [TIME] ::[PID] MSI(INFO): 'Property(S): ERRORSUPPORTTEXT_OEM_DEFAULT_PROBLEM = If problem persists, contact your computer manufacturer's product support for assistance.'
[DATE] [TIME] ::[PID] MSI(INFO): 'Property(S): InstalledByServerCatalyst_Ref = 0'

|

|

|

[DATE] [TIME] ::[PID] MSI(INFO): Error: Failed to install product:  C:\OWA\wacserver.ww\wacserver.MSI ErrorCode: 1603(0x643).

|

|

|

[DATE] [TIME] ::[PID] MSI(INFO):Catalyst execution finished: [Date][Time].  Return code: 1603.

———————————————————————————————————

CAUSE:

The BIOS SETTINGS  on server or the POWER OPTIONS profile on machine (or both), are set to "BEST PERFORMANCE" or "HIGH PERFORMANCE"

WORKAROUND:

Set the BIOS SETTINGS  on server or the POWER OPTIONS on machine (or both), to the BALANCED ( performance/power profile).

UPDATE:

=======

Please note that after a series of tests it was identified that the issue could occur while installing language packs for Office WebApps.  

IMPORTANT: The same workaround is applicable here as well.  

Comments (6)

  1. DK says:

    My god… I really hope whoever was responsible for the Office Web Apps installer has been fired by now.

  2. JJ says:

    I completely agree. I spoke to several consultants from Microsoft Consulting Services (MCS) and support engineers from Microsoft Premier about Office Web Apps Server, they all describe it as poorly-supported and difficult to troubleshoot. The installation
    setup logs are almost completely useless.

  3. Ken says:

    Here’s another one… on a new fully patched Server 2012 box, you can’t install… it says .Net is missing…

    Fully patched, .Net is now 4.6…. and it won’t install

  4. Sarthak says:

    Am trying to install it on a 2012 R2 VM and Power options are set to balanced , still does’t work for me

    1. Rafiq says:

      Hi did it work then?? I am stuck with the same problem, looking for a fix

  5. Eve says:

    I changed the power options to High Performance and it worked for me. It was giving me the same error as yours

Skip to main content