PerformancePoint 2013 Dashboard Designer fails to start after October 2013 CU


Issue:

After the SharePoint 2013 October 2013 cumulative update (CU) the PerformancePoint 2013 dashboard designer fails to start and gives error "Application cannot be started.  Contact the application vendor."

Note: We have seen rare circumstances where this issue occurs at later patch levels (post SP1) and is NOT limited to and/or is not fixed by the update to SP1 or later CU updates. Also note that SP1 is the minimum supported patch level for SharePoint 2013.

 

Cause:

The dashboard designer files were not signed correctly during the CU build process.

 

Workaround:

Replace the “1033” folder at the following location with the “1033” folder attached to this article:
C:\Program Files\Common Files\Microsoft Shared\Web ServerExtensions\15\TEMPLATE\LAYOUTS\ppsma\

WARNING: These files are from SharePoint 2013 SP1 October 2015 CU (15.0.4763.1000). If you are PAST this update, you will need to obtain this file structure from a later version or open a support incident for further assistance as you may be experiencing a different issue.

Note that a simple update to a later CU may not fix this problem as these files are NOT replaced/updated in every CU.

DesignerFiles.zip

Comments (43)

  1. Anonymous says:

    I just confirmed this works on our farm as well replacing all the files listed above. Thanks! 🙂

  2. Anonymous says:

    http://www.designeroffices.com
    Designer office

    I would like to thank you for the efforts you have made in writing this article.

  3. Anonymous says:

    http://www.designeroffices.com/about-us.html
    ABD Design Studio
    I would like to thank you for the efforts you have made in writing this article. I mostly agree with you most of the point

  4. Anonymous says:

    Does you have these files from pt-br Sharepoint Version?

  5. Anonymous says:

    Thank you it worked like charm for me !!

  6. Anonymous says:

    Thanks

  7. Anonymous says:

    Hi,
    It is not been resolved in SharePoint 2013 SP1 also.

  8. Anonymous says:

    works with Dec 2013 CU applied, then apply this! Thanks a lot!!!

  9. Anonymous says:

    Hi,
    I have installed the SP1 and April 2014 CU on our SharePoint 2013 farm. we are still facing some of the users are not able to launch the Dashboard Designer. Is this specific to language , any body faced the issue has any workarround?

    ERROR DETAILS
    Following errors were detected during this operation.
    * [8/21/2014 12:29:19 PM] System.Deployment.Application.InvalidDeploymentException (Zone)
    – Deployment and application do not have matching security zones.
    – Source: System.Deployment
    – Stack trace:
    at System.Deployment.Application.DownloadManager.DownloadApplicationManifest(AssemblyManifest deploymentManifest, String targetDir, Uri deploymentUri, IDownloadNotification notification, DownloadOptions options, Uri& appSourceUri, String& appManifestPath)
    at System.Deployment.Application.DownloadManager.DownloadApplicationManifest(AssemblyManifest deploymentManifest, String targetDir, Uri deploymentUri, Uri& appSourceUri, String& appManifestPath)
    at System.Deployment.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp)
    at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)
    at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
    at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

    COMPONENT STORE TRANSACTION DETAILS
    No transaction information is available.

  10. Anonymous says:

    Do the files in PPS.zip also work with the December 2013 CU?

  11. Anonymous says:

    Hi,

    Just wanted to let you know that the files attached didn’t work in our installation.

    I’ve used them before, but they failed working when we recently upgraded to December 2014 CU. Thankfully, I managed to pull out the files from production before we upgraded this (this is running 15.0.4615, which is Service Pack 1 + MS14-022). I copied the files
    out from production, and overwrote the files on DEV and TEST, and everything was OK.

  12. Hesham says:

    I have the same problem, When should we expect a hot fix to be available?

  13. Ray Avila says:

    Still have issue after replaced files.  Please fix as soon as possible.

    ====

    ERROR DETAILS

    Following errors were detected during this operation.

    * [11/27/2013 9:36:40 AM] System.Deployment.Application.InvalidDeploymentException (HashValidation)

    – File, Microsoft.SharePoint.Client.Runtime.dll, has a different computed hash than specified in manifest.

    – Source: System.Deployment

    – Stack trace:

    at System.Deployment.Application.ComponentVerifier.VerifyFileHash(String filePath, Hash hash)

    at System.Deployment.Application.ComponentVerifier.VerifyFileHash(String filePath, HashCollection hashCollection)

    at System.Deployment.Application.ComponentVerifier.VerifyComponents()

    at System.Deployment.Application.DownloadManager.DownloadDependencies(SubscriptionState subState, AssemblyManifest deployManifest, AssemblyManifest appManifest, Uri sourceUriBase, String targetDirectory, String group, IDownloadNotification notification, DownloadOptions options)

    at System.Deployment.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp)

    at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)

    at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)

    at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

  14. Marc says:

    The fix doesn't work for other language packs likce 1031 German. Cause the resource dlls are different.

  15. YOGESHA H P says:

    Still have issue after replacing the files, it does not work for some people and it work for some who are accessing for the first time and it does not work for other Languages.

  16. bj fentress says:

    Agreed. This fix does not work for my farm which is patched at this level. And I have replaced the files listed in this article

  17. Sreekumar says:

    The latest files don't fix the problem

  18. Sreekumar says:

    Following errors were detected during this operation.

    * [12/5/2013 4:19:35 AM] System.Deployment.Application.InvalidDeploymentException (HashValidation)

    – File, Microsoft.SharePoint.Client.Runtime.dll, has a different computed hash than specified in manifest.

    – Source: System.Deployment

    – Stack trace:

    at System.Deployment.Application.ComponentVerifier.VerifyFileHash(String filePath, Hash hash)

    at System.Deployment.Application.ComponentVerifier.VerifyFileHash(String filePath, HashCollection hashCollection)

    at System.Deployment.Application.ComponentVerifier.VerifyComponents()

    at System.Deployment.Application.DownloadManager.DownloadDependencies(SubscriptionState subState, AssemblyManifest deployManifest, AssemblyManifest appManifest, Uri sourceUriBase, String targetDirectory, String group, IDownloadNotification notification, DownloadOptions options)

    at System.Deployment.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp)

    at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)

    at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)

    at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

  19. jb says:

    <publisherIdentity name="CN=REDMONDbrenwil"   ???

  20. jb says:

    Replacing these with a CU EARIER than October (i.e. from another farm that did not yet have October CU on it) worked for me, my fellow SharePoint peeps… Quite lame that there isn't even a KB article on this problem. :/

  21. jb says:

    Upon further inspection, it gets a bit further, but still does not work… 🙁

    + File, Microsoft.SharePoint.Client.dll, has a different computed hash than specified in manifest.

  22. Splichal says:

    Replacing the 2 files does work, however, that will only work on machines that have never launched Dashboard Designer before or from the Server directly. To fix it on machines that have previously launched Dashboard Designer, you need to replace all the files below.

    C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions15TEMPLATELAYOUTSppsma1033Designer.Application

    C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions15TEMPLATELAYOUTSppsma1033DesignerInstallDesigner.exe.manifest

    C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions15TEMPLATELAYOUTSppsma1033DesignerInstallMicrosoft.SharePoint.Client.Runtime.dll

    C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions15TEMPLATELAYOUTSppsma1033DesignerInstallMicrosoft.PerformancePoint.Scorecards.Client.dll

    C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions15TEMPLATELAYOUTSppsma1033DesignerInstallMicrosoft.PerformancePoint.Scorecards.DesignerPlugins.dll

    C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions15TEMPLATELAYOUTSppsma1033DesignerInstallMicrosoft.SharePoint.Client.dll

    I new zip file with the corrected files will be uploaded soon.

  23. PM says:

    Please upload the zip file as fast as possible

  24. Splic-MSFT says:

    This posting has been updated

  25. PM says:

    The zip is corrupted, could you please reupload it?

  26. mike says:

    I can confirm the new file does appears to resolve this issue.

  27. jb says:

    FYI, I used the 6 files from the August 2013 CU with 100% success…seems like a much better thing to do vs. using the RTM files.

  28. Yogesha H P says:

    After replacing the all the below files , it started successfully.

    C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions15TEMPLATELAYOUTSppsma1033Designer.Application

    C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions15TEMPLATELAYOUTSppsma1033DesignerInstallDesigner.exe.manifest

    C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions15TEMPLATELAYOUTSppsma1033DesignerInstallMicrosoft.SharePoint.Client.Runtime.dll

    C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions15TEMPLATELAYOUTSppsma1033DesignerInstallMicrosoft.PerformancePoint.Scorecards.Client.dll

    C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions15TEMPLATELAYOUTSppsma1033DesignerInstallMicrosoft.PerformancePoint.Scorecards.DesignerPlugins.dll

    C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions15TEMPLATELAYOUTSppsma1033DesignerInstallMicrosoft.SharePoint.Client.dll

  29. YOGESHA H P says:

    After replacing the all the below files , it started successfully.

    C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions15TEMPLATELAYOUTSppsma1033Designer.Application

    C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions15TEMPLATELAYOUTSppsma1033DesignerInstallDesigner.exe.manifest

    C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions15TEMPLATELAYOUTSppsma1033DesignerInstallMicrosoft.SharePoint.Client.Runtime.dll

    C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions15TEMPLATELAYOUTSppsma1033DesignerInstallMicrosoft.PerformancePoint.Scorecards.Client.dll

    C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions15TEMPLATELAYOUTSppsma1033DesignerInstallMicrosoft.PerformancePoint.Scorecards.DesignerPlugins.dll

    C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions15TEMPLATELAYOUTSppsma1033DesignerInstallMicrosoft.SharePoint.Client.dll

  30. prashant says:

    Is this Fix still works for all Language Packs, Can someone confirm this for us.

  31. anony.muos says:

    I tried this fix for another language then EN and it doesnt work. Is it so hard four MS to release a real working fix for this?

  32. GMuff says:

    I have the same problem with a customer "DE 1031" when it will be fixed in Feb????

  33. Hrishi says:

    Is this impacts creating data source with Analysis Services?

  34. Anitha says:

    After replacing the files also, I could not able to run dashboard designer from the site. I need to go to 15 hive folder to run the deisgner.exe.

  35. leandro says:

    This doesnot work for pr-br site languages

  36. Thirupathi Reddy says:

    Its worked for me. But Data connection error in dashboard designer.

  37. A. M. Robinson says:

    I followed the steps above exactly and I still cannot get Dashboard Designer to properly initialize…

  38. Sameh Sabil says:

    It worked for me after replacing the files, but again you may refresh the cash for some users who tried to launch it before

  39. 77831 says:

    Service Pack 1 resolve the issue for me !

  40. Anonymous says:

    Issue Small update on an earlier blog post by Warren around this PerformancePoint Services/Dashboard

Skip to main content