ACT Connector 与 ACT 5.6

Application Compatibility Toolkit Connector (ACT Connector) 可以帮助IT管理员收集企业里计算机和应用程序的兼容性信息,进而帮助管理员制定Windows部署的计划。ACT Connector的运行要依赖于Microsoft Application Compatibility Toolkit 5.5 (ACT 5.5) 。在今年的6月7日,ACT发布了新版本:ACT 5.6。 那么ACT Connector能与ACT 5.6兼容吗?答案是肯定的。不过有一个局限,就是ACT Connector目前还不能利用到ACT 5.6里面新增加的64位操作系统兼容性的支持。ACT Connector汇总上来的应用程序兼容性数据都是仅仅针对32位操作系统的。 假如您直接从ACT 5.5升级到ACT 5.6,并且依照ACT配置向导(ACT Configuration Wizard)的提示完成ACT数据库的升级,那么您可以像以前一样继续正常使用ACT Connector的功能。具体步骤如下:在升级到ACT 5.6以后,运行如下图所示的ACT配置向导,并且选择旧有的ACT数据库。在数据库名称的旁边,您可以看到有一个新的Update按钮出现。点击Update按钮,然后按照弹出对话框中的说明来更新旧的ACT数据库。 另外,有可能您直接安装了ACT 5.6,而不是从ACT 5.5升级而来。在这种情况下,不要使用Configuration Manager控制台中Application Compatibility Toolkit Connector/Application Compatibility Toolkit Server节点下的Configure ACT Server来配置ACT 5.6数据库;而要使用在这篇文章(http://blogs.technet.com/b/configurationmgr/archive/2009/07/01/support-for-act-5-5-with-the-act-connector.aspx)中描述的VB脚本(ActConfig.vbs)来配置ACT数据库。如果ACT数据库位于一个SQL命名实例上,那么在传给ActConfig.vbs的ACT Server参数中应当包含命名实例的名称。比如:ActConfig.vbs <Site server> <Site code> <ACT Server>\<SQL named instance> <ACT database> <Machine Account>….

1