Troubleshooting OpsMgr 2007 and OpsMgr 2012 certificate issues with PowerShell

The steps for configuring certificates in Operations Manager are numerous and one can easily get them confused. I see posts to the newsgroups and discussion lists regularly trying to troubleshoot why certificate authentication is not working, perhaps for a workgroup machine or gateway. Sometimes it takes 3 or 4 messages back and forth before I or anyone else can diagnose what the problem actually is but once this is finally done we can suggest how to fix the problem.

In an attempt to make this diagnosis stage eaiser, I put together a PowerShell script that automatically checks installed certificates for the needed properties and configuration.  If you think everything is set up correctly but the machines just won’t communicate, try running this script on each computer and it will hopefully point you to the issue. I have tried to provide useful knowledge for fixing the problems.

This script is for stand-alone Powershell 1.0 – it does not require the Ops Mgr PowerShell snapins.

Please leave a comment if you find bugs or if the script gives a faulty verdict for you – either it says your setup is fine but actually it’s not working OR it says your setup is busted but the machines communicate anyways.  I appreciate this feedback and will use it to improve and update the script.

Thanks!  

Lincoln

Update 2/6/2009:  Added some fixes to the script thanks to feedback from a few sources and a bit of extra testing.

Update 7/1/2009: Fix for computer name checking for workgroup machines

OMv3CertCheck.ps1