Przejścia z dyskiem Seagate


Jak widać przez dłuższy czas na blogu była cisza i wyglądało jakbym się zapadł pod ziemię.

Kilka osób już się nawet mnie pytało, czy to nie czasem fakt ogłoszenia przez Microsoft wyników za 3 kwartał i informacjach, że Microsoft na całym świecie zwalnia 5000 osób.

Powody w zasadzie były dwa i jeden z nich opiszę w tym poście. O drugim napiszę myślę, za tydzień – bo chwilowo musi to zostać tajemnicą.

Wstęp

Kilka dni temu postanowiłem wreszcie na poważnie zabrać się za Windows 7. Do tej pory testowałem go tylko na maszynie wirtualnej i tylko w wersji Milestone 3.

Teraz wyszła publiczna beta (jeszcze tylko do 10 lutego może ją pobrać każdy, w subskrypcji TechNet takiego ograniczenia nie ma).

Postanowiłem więc, że zainstaluje ją sobie na moim produkcyjnym laptopie, z którego na codzień korzystam.

Backup

Nie wiem czy znacie to powiedzenie, że ludzie dzielą się na tych co robią backupy i na tych co będą je robić od następnego razu 🙂

Ja już miałem okazję raz stracić dane i nie odzyskać ich (OnTrack chciał mega pieniądze, inna firma próbowała odzyskać dane 3x i się nie udało). Od tej pory robię regularne backupy.

Tym razem jednak pomyślałem, że zrobię sobie dwa backupy w Viście. Jeden pełny (do pliku VHD) a drugi korzystając z narzędzia Easy Transfer.

W pierwszym wypadku chciałem mieć kompletny backup całego komputera, w drugim chodziło mi o dokumenty i ustawienia systemu oraz programów (głównie Outlooka – reguły, podpisy, konta, itp.)

Backupy zrobiły się bez problemu.

Instalacja Windows 7

Instalacja poszła nadzwyczaj dobrze i nie dziwie się już opiniom w internecie, że faktycznie zrobiliśmy coś naprawdę dobrze (zwłaszcza, że to jeszcze beta). I tych opinii jest naprawdę zdecydowana większość.

System się szybko zainstalował, znalazł chyba wszystkie sterowniki (do karty graficznej dopiero dociągnął z Windows Update) i odpalał się błyskawicznie.

Nie będę więcej pisał o tym systemie, bo na to przyjdzie czas jak go do końca dobrze przetestuje (może pod koniec lutego?) w codziennej pracy.

No więc mam goły system, dołączam go do naszej domeny, kilka drobnych konfiguracji i trzeba się zabrać za odzyskanie danych z backupu.

I tu wkracza Seagate

Wszystkie moje dane zgrałem na duży 500GB dysk (plik VHD miał 93 GB, a plik z Easy Transfer miał 45 GB) właśnie marki Seagate z serii FreeAgent Desktop.

Zacząłem odtwarzanie z pliku stworzonego przez Easy Transfer (plik .MIG). Ładnie wszystko zaczęło się odtwarzać, ale niestety przy 45 GB trochę to trwało.

Mniej więcej w 1/3 nagle narzędzie zaczęło mi sypać błędami. Na koniec okazało się, że mam 200.000 błędów! Dotyczą one nieprzetransferowania plików z backupu.

Nagle dysk przestał też być widziany w komputerze mimo, że cały czas się świecił jako włączony. Jego odłączenie i ponowne włączenie nie pomagało – dysk nie był wykrywany.

Śledztwo

Moje śledztwo trwało w zasadzie 3 dni.

Próbowałem m.in.:

  • podłączać dysk w innym komputerze,
  • podłączać dysk na innym systemie (XP w domu)
  • zmienić kabel zasilający
  • zmienić kabel USB
  • odpalić dysk nawet na Fedorze 10 🙂
  • zmieniać uprawnienia do pliku
  • przejmować plik na własność
  • robić to na koncie administratora i zwykłego użytkownika

Objawy w zasadzie zawsze były te same, bo dysk po podłączeniu był widoczny, później jak chciałem odtworzyć backup to w trakcie przestawał być widoczny (jakby się rozłączał), po odłączeniu i ponownym podłączeniu nie chciał się wykryć.

Wykryć się dawał dopiero po pewnym bliżej nieokreślonym czasie. Ale później cała sytuacja się powtarzała.

W międzyczasie dysk/Windows sypał błędami typu:

  • delayed write failed
  • file is no longer exist

Oczywiście korzystałem z wyszukiwarki dla tych błędów ale najczęstszą radą było “wymień kabel USB”, co u mnie w niczym nie pomogło.

Próbowałem też przegrać dane z dysku na inny, bo już myślałem, że coś musi być z dyskiem (chociaż narzędzia diagnostyczne mówiły, że dysk jest OK). Ale to też się nie udawało, bo kopiowanie przerywało się po pewnym czasie i działo się to co opisałem.

W międzyczasie pojawił się też wątek na forum WSS.pl, gdzie ktoś pisał o jajach z dyskami Seagate i problemem z ich firmware.

Rozwiązanie

Rozwiązanie problemu przyszło do mnie po 3 dniach.

A w zasadzie to ja sam po nie poszedłem. Zszedłem piętro niżej do chłopaków z naszego IT, żeby pożyczyć jakiś większy dysk do zgrania całości.

Dysku nie mieli, ale jak się zgadało o problemach to jeden z nich (wielkie dzięki Piotrek!) wspomniał że kiedyś miał stosunkowo podobny problem.

W domowym komputerze podczas oglądania dłuższych filmów, film potrafił nagle zacząć zwalniać aby się później zatrzymać, i też nagle znikał dysk z listy dysków. Podpowiedział mi, że u niego problem był z tym, że dysk się przegrzewał

Czy już wiecie w czym był problem u mnie? 🙂

Dokładnie tak się działo. I mimo, że miałem (po pierwszym dniu niepowodzeń) zainstalowane narzędzie Seagate do badania dysku (narzędzia notabene mówiły, że z dyskiem jest wszystko OK) to nie skorzystałem z nich, żeby sprawdzić temperaturę dysku.

Dysk jest w obudowie, a raczej nie była ona gorąca ani nawet ciepła. Więc to nie wzbudziło moich podejrzeń. No ale jak już wiedziałem czego szukać to badałem sobie temperaturę dysku podczas kopiowania i to jak sobie rosła od 25 st. C do 55 st. C!

Mniej więcej po osiągnięciu tej temperatury dysk się wyłączał (pewnie oczywiście ze względów bezpieczeństwa i chwała mu za to) i później nie chciał się podpiąć dopóki się nie schłodził.

Co zrobiłem?

No więc coś trzeba było z tym zrobić. Wyjęcie dysku z obudowy nie wchodziło w grę (bo gwarancja), więc trzeba było dane przegrać na inny, mniej grzejący się dysk.

Tylko jak to zrobić, skoro w połowie kopiowania dysk się przegrzewał?

Być może nie był to najbardziej optymalny pomysł (może znacie inne? z chęcią poznam), ale wtedy po 3 dniach nie chciało mi się już myśleć i szukać co z tym zrobić łatwiej.

Wykorzystałem więc nasz wewnętrzny program (choć pewnie są też i publicznie dostępne odpowiedniki) do kopiowania plików z możliwością dogrywania danych do przerwanego transferu (swoją drogą kilku znajomych doradzało Total Commander, ale on ma tą opcję tylko dla przesyłu przez FTP).

Uruchamiałem wtedy kopiowanie na inny dysk i monitorowałem temperaturę. Jak zbliżała się do 50 st. C to pauzowałem transfer, odłączałem dysk, pozwalałem mu się schłodzić i podłączałem ponownie.

Po około 2h miałem dane zgrane na inny dysk (dzięki Tomek za użyczenie!), z którym już nie było żadnych problemów i po kolejnej godzinie miałem już swoje dane odzyskane z narzędzia Easy Transfer.

Swoją drogą to nowa funkcjonalność w Windows 7, a mianowicie – podpinanie plików VHD jako dodatkowych dysków, w połączeniu z backupem do plików VHD to idealna sprawa. Teraz jak mam ochotę to mogę sobie mój pełny backup jednym kliknięciem podłączyć jako dodatkowy dysk!

Podsumowanie

Rozpisałem się strasznie widzę, ale po 3 dniach walki warto byłoby to opisać jakby to miało pomóc choć jednej osobie.

Bo jak ja szukałem rozwiązania problemu, to nikt nie poruszył tematu przegrzewającego się dysku!

Oby to komuś pomogło oszczędzić 3 dni pracy 🙂

A teraz wracam w miarę do życia i na pewno na początku tygodnia pojawi się tu mały konkurs, w którym do wygrania będą vouchery 40% na egzaminy Microsoft – mam ich 10 sztuk 🙂

Comments (4)

  1. @pgardy: Wiesz – tak teraz miałem dopiero czas do tego siąść i widzę, że to chyba wina tej konkretnej sztuki. Bo mam jeszcze 4 dokładnie te same dyski i z nimi nie ma tego problemu. Że też musiałem backup robić akurat na ten 🙂 Tak byłbym 3 dni do przodu.

    Także dyski są całkiem przyjemne i nie narzekam na nie konkretnie, ale szkoda, że wcześniej nie pomyślałem, że to przegrzewanie (bo obudowa nie była nic a nic ciepła).

  2. @Borass: Tu akurat nie jest problem Easy Transfer… Po prostu dysk się przegrzewał przy zbyt długim działaniu/obciążeniu. Bo to samo się działo przy zwykłym kopiowaniu plików.

  3. Anonymous says:

    Ciekawe.

    Sam mam FreeAgenta, tyle ze GO! i 250GB.

    Uzywam go bardzo czesto i dlugo (odpalam z niego wirtualki) i zadnych problemów Twojego typu nie mialem.

    Moze seria GO nie jest podatna?

  4. _Borass_ says:

    No ciekawe, dobrze wiedziec.

    Ja mam FreeAgenta 80GB 2,5 calowy, i kopiowalem na niego juz po 80 GB na raz (pliki okolo 700 mb, rozszerzenia nie podam 🙂 ),  nie bylo takich problemow. Byc moze easy tranfser bardziej obciaza dysk niz zwykle kopiowanie?

    Tak czy inaczej fajnie wiedziec, pozdrowienia z WSS! <cheers>

Skip to main content