Retrieving the COM class factory for component with CLSID {OFFICE14-0005-0000-0000-000000000000} failed due to the following error 8007042d


When browsing the settings for the Search Service Application in SharePoint 2010, I received the error “Retrieving the COM class factory for component with CLSID {OFFICE14-0005-0000-0000-000000000000} failed due to the following error 8007042d”.

search14error

I checked the SharePoint Server Search Service “SharePoint Server Search 14” in the services MMC and noticed that the service was Stopped due to a login failure. Updated the login information, started the service, and I was able to browse the search service application settings pages successfully.


Comments (2)

  1. Larry W Virden says:

    Hello! I had this problem, tried updating the password – even though it had not changed – and the crawl started. Now, almost a week later, I come in and find the same error again.

    I know for certain that the password has not changed.

    So does anyone know what is really going on here?

    Today, I went into the services, found the search service disabled – I had marked it as automatic last week – re-marked it as Automatic and started it, and things looked like they were starting up. However, a few minutes later, things are down again. I go into the service, type in the same password I typed in last week, start the service, and when I look at the crawl logs – just like last week – I see 31,000+ documents crawled successfully in just a few minutes.

    So it does not look like the password is bad to me.

    What is going on?

  2. sarang says:

    facing same problem and still i did not find any solution