Installing and configuring a 4-server SharePoint farm–a successful order


Translate this page

Below is the order I followed recently to install and configure a 4-server SharePoint Farm.

 

  1. Ran PrerequisitesInstaller.exe on Application Server 01 – installer downloaded and installed prerequisites
  2. Installed SharePoint Server 2010
  3. Ran the Configuration Wizard – wizard completed (created the farm)
  4. Ran PrerequisitesInstaller.exe on Application Server 02 – installer downloaded and installed prerequisites
  5. Installed SharePoint Server 2010
  6. Ran the Configuration Wizard – wizard completed (added the server to the farm and chose that the app server to host the Central Administration for redundancy)
  7. Ran PrerequisitesInstaller.exe on Web front-end Server 01 – installer downloaded and installed prerequisites
  8. Installed SharePoint Server 2010
  9. Ran the Configuration Wizard – wizard completed (added the server to the farm )
  10. Ran PrerequisitesInstaller.exe on Web front-end Server 02 – installer downloaded and installed prerequisites
  11. Installed SharePoint Server 2010
  12. Ran the Configuration Wizard – wizard completed (added the server to the farm )
  13. Installed a SharePoint Foundation Language Pack on all servers
  14. Installed a SharePoint Server Language Pack on all servers
  15. Ran the Configuration Wizard on all servers in order (App01, App02, WFE01,WFE02)
  16. For each server in the farm and in the order (App01,App02,WFE01,WFE02)
    • Installed SharePoint Foundation 2010 Service Pack 1
    • Installed Service Pack 1 for SharePoint Foundation 2010 Language Pack
    • Installed Dec 2011 CU for SharePoint Foundation 2010*
    • Installed SharePoint Server 2010 Service Pack 1
    • Installed Service Pack 1 for Server Language Pack 2010
    • Installed Dec 2011 CU for SharePoint Server 2010
  17. Ran the Configuration Wizard on all servers in order (App01, App02, WFE01,WFE02)

* Update: I was discussing the order of installation with a colleague and got the news that the Dec 2011 CU Hotfix package (2597014) “The full server package for SharePoint Server 2010 and contains also the MSF2010 [SharePoint Foundation] fixes so you need only this one package.” – no need to apply the CU for SharePoint Foundation.    

Good luck!


Comments (2)

  1. Anonymous says:

    You are correct, after SP1 you don't need to apply a CU both for foundation and Server, a server CU is cumulative even for Foundation!