Exchange Server 2010 with Window Server 2016 Domain Controllers


I recently wrote a blog post, and have since updated it, about the Exchange supportability matrix, stating that Exchange 2010 could not be run anywhere, within a forest with even a single Windows Server 2016 Domain Controller (DC). The Exchange product group has now updated that stance with the June 2018 updates. You must install at least Exchange Server 2010 SP3 RU 22. Once you have performed those upgrades to all of your 2010 Exchange servers, you can then promote Windows Server 2016 DC’s within the forest.

Comments (0)

Skip to main content