Problemas de disponibilidad cuando OAuth está habilitado.


Por: Adrian Kruss

Exchange 2013 introdujo una forma extra de autenticación, OAuth. La autenticación OAuth es el mecanismo que usa la plataforma de Exchange Local y Exchange Online por defecto para hacer la autenticación de servidor a servidor remplazando la autenticación WSSecurity la cual es usada por servidores anteriores and la configuración hibrida.

Cuando OAuth está habilitado, ya sea en el Exchange local, en Exchange Online o en ambos, los pedidos de disponibilidad van a utilizar OAuth y solamente OAuth para la autenticación de servidor a servidor y si esta falla NO utilizara la autenticación WSSecurity.

Recientemente experimente con un problema de disponibilidad el cual estaba fallando cuando usuarios de Office 365 trataban de ver la disponibilidad de usuarios locales. Utilizando OWA se podía ver el error: “Free/busy information isn't available because your server is busy. Please try again later.” (Figura 1) cuando se buscaba la disponibilidad de buzones locales. A su vez buscando la disponibilidad desde un buzón en Office 365 hacia otro buzón en Office 365 como desde un buzón en el ambiente local hacia un buzón en Office 365 trabajaba sin problemas.

clip_image002

Figura 1

 

Mirando el tráfico en el TMG este mostraba un error: “500 Internal server error”:

clip_image004

Deshabilitando los conectores de la organización local IntraOrganizationConnector y el de Exchange Online IntraOrganizationConnector, lo cual forzó el uso de WSSecurity como el mecanismo de autenticación de disponibilidad) permitió que la disponibilidad entre los buzones locales y la nube (y viceversa) trabaje sin problemas.

Revisado la configuración de OAuth usando https://technet.microsoft.com/es-es/library/dn594521(v=exchg.150).aspx no se detectó ningún problema de configuración. Pero, al comparar los atributos con otra organización la cual estaba trabajando correctamente pudimos ver que el PartnerApplication no tenía un valor en el LinkedAccount:

clip_image006

Una vez que se identificó esta falta lo agregamos la cuenta:

Set-PartnerApplication -Identity "Exchange Online" -LinkedAccount "domain.local/Users/Exchange Online-ApplicationAccount"

clip_image008

Luego de reiniciar IIS la disponibilidad desde buzones hospedados en Office 365 hacia buzones hospedados en el servidor local comenzó a trabajar:

clip_image010

En breves cuentas, el valor LinkedAccount debajo de PartnerApplication no tenía la información necesaria, al agregar la cuenta de Exchange Online-ApplicationAccount y reiniciando IIS, después de 15 minutos (pero el tiempo de espera/replicación puede varias), resolvió el problema

Comments (0)

Skip to main content