Exchange 2007 Troubleshooting Case : Exchange Server 2007 install on Windows Server 2008 error 0x80040a02


Many people told me Exchange Server 2007 install on Windows Server 2008 not stability and occur many error .


Today , i will share my little case of troubleshooting with you.


I setup Exchange 2007 with sp1 (x86 or x64) on Windows Server 2008 ,  when install Hub transport role phase, display Service “MSExchangeTransport” on server not reach state “Running” . in Eventlog application logs , i find Event ID 2114 , Level is Error . Description: Process MSEXCHANGEADTOPOLOGYSERVICE.EXE(PID=2776). Topology discovery failed,error 0x80040a02(DSC_E_NO_SUITABLE_CDC).


The same way to install on Windows Server 2003 you can’t encounter this error . I find Windows Server 2008 TCP/IP protocol including IPv4 and IPv6 , because i haven’t IPv6 topology , so i unselected TCP/IPv6 , result in this fails.


when i selected TCP/IPv6 and reinstall Exchange Server 2007 , setup successful! J


Enjoy!


Justin Gao


Microsoft(China)

Comments (4)

  1. Anonymous says:

    Good, Thanks very much about this information.

  2. koen says:

    Thanks you saved my day.

    i had a small business server 2008 and after reboot it took a very long time before i could log on. More then one hour.(i let the night pass by before i checked again 🙂

    I could not start the store and had the same error as you discribed. On the machine ipv6 was disabled after enabling everything was ok !!!!!!!!

    Thanks a lot for sharing the information.

  3. Andre says:

    Thanks, you helped me too, saving me a ton of time!

  4. IyalC says:

    Thank you Justin. You save my day 🙂