Microsoft Security Bulletin: June 2011 Release


clip_image002

What is the purpose of this alert?

This alert is to provide you with an overview of the new security bulletins being released on June 14, 2011. Security bulletins are released monthly to resolve critical problem vulnerabilities.

New Security Bulletins

Microsoft is releasing the following 16 new security bulletins for newly discovered vulnerabilities:

Bulletin ID

Bulletin Title

Maximum Severity Rating

Vulnerability Impact

Restart Requirement

Affected Software

MS11-037

Vulnerability in MHTML Could Allow Information Disclosure (2544893)

Important

Information Disclosure

May require restart

Microsoft Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008, Windows 7, and Windows Server 2008 R2.

MS11-038

Vulnerability in OLE Automation Could Allow Remote Code Execution (2476490)

Critical

Remote Code Execution

Requires restart

Microsoft Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008, Windows 7, and Windows Server 2008 R2.

MS11-039

Vulnerability in .NET Framework and Microsoft Silverlight Could Allow Remote Code Execution (2514842)

Critical

Remote Code Execution

May require restart

Microsoft Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008, Windows 7, Windows Server 2008 R2, and Silverlight.

MS11-040

Vulnerability in Threat Management Gateway Firewall Client Could Allow Remote Code Execution (2520426)

Critical

Remote Code Execution

Requires restart

Microsoft Forefront Threat Management Gateway 2010 Client

MS11-041

Vulnerability in Windows Kernel-Mode Drivers Could Allow Remote Code Execution (2525694)

Critical

Remote Code Execution

Requires restart

Microsoft Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008, Windows 7, and Windows Server 2008 R2.

MS11-042

Vulnerabilities in Distributed File System Could Allow Remote Code Execution (2535512)

Critical

Remote Code Execution

Requires restart

Microsoft Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008, Windows 7, and Windows Server 2008 R2.

MS11-043

Vulnerability in SMB Client Could Allow Remote Code Execution (2536276)

Critical

Remote Code Execution

Requires restart

Microsoft Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008, Windows 7, and Windows Server 2008 R2.

MS11-044

Vulnerability in .NET Framework Could Allow Remote Code Execution (2538814)

Critical

Remote Code Execution

May require restart

Microsoft Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008, Windows 7, and Windows Server 2008 R2.

MS11-045

Vulnerabilities in Microsoft Excel Could Allow Remote Code Execution (2537146)

Important

Remote Code Execution

May require restart

Microsoft Excel 2002, Excel 2003, Excel 2007, Excel 2010, Office 2004 for Mac, Office 2008 for Mac, Office for Mac 2011, Open XML File Format Converter for Mac, Excel Viewer, and Office Compatibility Pack for Word, Excel, and PowerPoint 2007 File Formats.

MS11-046

Vulnerability in Ancillary Function Driver Could Allow Elevation of Privilege (2503665)

Important

Elevation of Privilege

Requires restart

Microsoft Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008, Windows 7, and Windows Server 2008 R2.

MS11-047

Vulnerability in Hyper-V Could Allow Denial of Service (2525835)

Important

Denial of Service

Requires restart

Microsoft Windows Server 2008 for x64-based Systems and Windows Server 2008 R2 for x64-based Systems.

MS11-048

Vulnerability in SMB Server Could Allow Denial of Service (2536275)

Important

Denial of Service

Requires restart

Microsoft Windows Vista, Windows Server 2008, Windows 7, and Windows Server 2008 R2.

MS11-049

Vulnerability in the Microsoft XML Editor Could Allow Information Disclosure (2543893)

Important

Information Disclosure

May require restart

Microsoft InfoPath 2007, InfoPath 2010, SQL Server 2005, SQL Server 2008, SQL Server 2008 R2, Visual Studio 2005, Visual Studio 2008, and Visual Studio 2010.

MS11-050

Cumulative Security Update for Internet Explorer (2530548)

Critical

Remote Code Execution

Requires restart

Microsoft Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008, Windows 7, and Windows Server 2008 R2.

MS11-051

Vulnerability in Active Directory Certificate Services Web Enrolment Could Allow Elevation of Privilege (2518295)

Important

Elevation of Privilege

May require restart

Microsoft Windows Server 2003, Windows Server 2008, and Windows Server 2008 R2.

MS11-052

Vulnerability in Vector Mark-up Language Could Allow Remote Code Execution (2544521)

Critical

Remote Code Execution

May require restart

Microsoft Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008, Windows 7, and Windows Server 2008 R2.

Summaries for new bulletin(s) may be found at http://www.microsoft.com/technet/security/bulletin/MS11-jun.mspx.

Jeffa

Digg This
Comments (0)

Skip to main content