Erreur lors de l’installation d’une mise à jour


Bonjour,

Dans cet article, je voulais revenir sur un problème qui peut affecter l’installation des mises à jour pour Project Server 2007, 2010 et 2013.

Lors de l’installation du package de correctifs, l’erreur suivante se produit:

"The expected version of the product was not found on the system."

Les premiers points à vérifier dans ce cas sont les suivants:

  1. les correctifs s’appliquent-ils bien à la version installée, 2007, 2010 ou 2013 ?
  2. les correctifs sont-ils compilés dans la version correspondante à celle installée, x86 ou x64 ?
  3. les correctifs sont-ils de même langage ou sont-ils compatibles avec le pack de langages installé ?
  4. les prérequis sont-ils installés ? (se référer aux prérequis mentionnés dans la page de téléchargement? Par exemple, un Service Pack peut être nécessaire)
  5. Avez-vous bien exécuté un PSConfig après l’installation des correctifs précédents ? Dans le doute, vous pouvez effectuer cette manipulation de nouveau sans aucun risque.

 

Si malgré toutes ces vérifications vous ne pouvez pas corriger ce problème, vous pouvez en dernier lieu forcer l’installation des correctifs en utilisant le paramètre PACKAGE.BYPASS.DETECTION.CHECK=1

Voici un exemple avec la ligne de commande suivante :

office-kb2596986-fullfile-x86-glb.exe PACKAGE.BYPASS.DETECTION.CHECK=1

Bonne journée,

Marc Biarnès

Comments (1)

  1. Didier Maignan | e-Labor conseil dit :

    Bravo, ceci est à communiquer à nos jeunes recrues, et à tous ceux qui se lancent en autodidacte dans une installation sans forcement maitriser le processus.

Skip to main content