"0x80070057" error message when you back up files in Windows 7

KB Article: http://support.microsoft.com/kb/982736


When you back up files by using Windows Backup on a computer that is running Windows 7, the backup fails and you receive the following error message:

An internal error has occurred: The parameter is incorrect: (0x80070057)

Comments (15)

  1. Anonymous says:

    In my computer's registry there was no key named "system" under HKEY_LOCAL_MACHINESOFTWAREPoliciesMicrosoft; I only found one under …MicrosoftWindows. Is this a mistake in the above article or do I have to create a new "system" key under Microsoft?

  2. Anonymous says:

    Neither their suggested ‘solutions’ solved the problem. How can Microsoft be so BAD at understanding, much less supporting THEIR product? I am still unable to change from weekly to monthly backups. Buy a clue.

  3. Robert says:

    I tried the registry fix, but BU still told me Internal error 0x80070057.

    So I'm stuck using the fix (replacing [,] with [.] systemwide).

    Using w7 Ultimate SP1 64b Se/Sv on a C2D E8400, if that's of any relevance.

    This error is really irritating

  4. Maciej says:

    HP ProBook 4530s zaproponowane rozwiązanie nie naprawia problemu.

    Microsoft zróbcie coś z tym!

  5. Bengt says:

    Didn't find System in the registry. But then found: reset the national settings of numbers and language.

  6. Joe says:

    The Fix it did not work for me … until I rebooted, after which the backup worked just fine. Might want to mention the need to reboot in KB982736.

  7. ugo says:

    I have still the same problem after using automatic MS Fix.it or manually fix solution

    Running HP pavilion dv6 windows 7 home premium 64 bit

  8. yvan says:

    Problem not solved with fix-it or "."

    Cannot make backup on external hd , still get the same error .

    HP dv7 , win 7 home premium

  9. Sigvard says:

    Since this folder doesn't exist, HKEY_LOCAL_MACHINESOFTWAREPoliciesMicrosoftSystem, I tried these instead, each at a time:



    But I still get the error message !

    win7 home prem

  10. Sigvard says:

    Testar Fix-it, men inte heller det fungerar. (Den tycks skapa HKEY_LOCAL_MACHINESOFTWAREPoliciesMicrosoftSystem)

    Men samma felmeddelande !

  11. Rasmusrat says:

    thanks for the Help

    it works !!!!!!!!!!!!

  12. philipp Sch. says:

    I used the fix-it offered on the page, rebooted, but the error persists.  🙁

    I am now running without option to backup for quite some time, very annoying.

  13. franki sco says:

    As the above comments: first changed ‘,’into ‘.’ with no effect. FixIt didn’t work either.
    what is the solution?

  14. DLR says:

    I had problems to execute the backup, I had a directory junction (MKLINK) in ProgramData that made crash the backup task

  15. RJPM says:

    It still does not work.