Released: Update Rollup 6 for Exchange 2010 Service Pack 3


The Exchange team is announcing today the availability of Update Rollup 6 for Exchange Server 2010 Service Pack 3. Update Rollup 6 is the latest rollup of customer fixes available for Exchange Server 2010 Service Pack 3. The release contains fixes for customer reported issues and previously released security bulletins. Update Rollup 6 is not considered a security release as it contains no new previously unreleased security bulletins. A complete list of issues resolved in Exchange Server 2010 Service Pack 3 Update Rollup 6 may be found in KB2936871. Customers running any Service Pack 3 Update Rollup for Exchange Server 2010 can move to Update Rollup 6 directly.

The release is now available on the Microsoft Download Center. Update Rollup 6 will be available on Microsoft Update in early July.

Note: KB articles may not be fully available at the time of publishing of this post.

The Exchange Team

Comments (40)
  1. Anonymous says:

    This rollup, 2936871, when installed on a server having Forefront integrated with Exchange services, causing Information Store not starting. For this we have to disable the integration and start the services. When again you try to integrate and start the
    services, Exchange services will not start. So you should not integrate Forefront with Exchange services at all, finally.

    Has anybody already in this soup?

    Whether Microsoft has checked this? Any solution?

  2. Anonymous says:

    SP3 & the Rollup Updates are not supposed to require you to disable Forefront anymore, but it doesn’t hurt to be safe and disable/enable it anyways. Make sure you are running Forefront Rollup 4 (http://support.microsoft.com/kb/2619883)
    & the latest security update (http://www.microsoft.com/en-us/download/details.aspx?id=41836).

  3. Anonymous says:

    Installed in our test env. Nothign blew up but didn’t have time to test anything out.

  4. Anonymous says:

    @GPNS, Have seen issues with services when integrate Forefront…Whats there in app’s logs? Is Forefront eventing service crashing first? In my case there was issue with permissions.. sorted out with help of Procmon! You may try that..

  5. Anonymous says:

    Hassan Sayed Issa I think this is a good way to research in the computer world and computer skills by coming up with new ideas that are admired by others within the computerized world and computer knowledge seeker and even getting praise from a high ranking
    place in computer knowledge Hybrid IT Infrastructure.this is a good opportunity to say to you with an open heart congratulations and well done my good dear friends on microsoft msdns technet wiki blog. Thank you very much.
    den 30 april kl. 16:55

  6. Anonymous says:

    nice work

  7. Anonymous says:

    Hooray! My users have been feeling pain for entirely way too long waiting for this one:
    2925273 Folder views are not updated when you arrange by categories in Outlook after you apply Exchange Server 2010 Service Pack 3 Update Rollup 3 or Update Rollup 4

  8. Anonymous says:

    Hey,

    we have Policies for Mailbox Server Shutdown and Start in which we call the MS Script’s StartDagServerMaintenance.ps1 and StopDagServerMaintenance.ps1.
    We haven’t installed RU5 and now we have Ex2010 SP3 RU6 (German) and the Management Pack 4.
    After the Installation of this Updates we have problems with this MS Script’s, we get an Execption from the DagCommonLibrary.ps1.

    We’re patching our DAG with WSUS at night, so we need the automatical distribution of the Mailbox Databases based on our Rules – the activation preference of the Mailbox Databases.

    In Addition we have separate colleague’s for deploying Virus Scanner or swap corrupt Hardware.

    Until RU6 there was no Problem, cause after an necessary Systemboot, the MS Script’s correct the database distribution.
    In my expirience only Shutdwon without an correct move of the cluster functionality or the Move of the active Database – it could happend that the index of the search or even an database will be corrupted.

    Script and an part of the Exception

    …..Exchange ServerV14Scripts> .StartDagServerMaintenance.ps1 -serverName

    In C:Program FilesMicrosoftExchange ServerV14ScriptsDagCommonLibrary.ps1:494 Zeichen:6
    + return $moveSuccessful
    ….
    Der Ablauf des Steuerelements kann einen finally-Block nicht verlassen.
    In C:Program FilesMicrosoftExchange ServerV14ScriptsDagCommonLibrary.ps1:926 Zeichen:5
    + return $success
    ….
    Der Ablauf des Steuerelements kann einen finally-Block nicht verlassen.
    + CategoryInfo : ParserError: (:) [], ParseException
    + FullyQualifiedErrorId : ControlLeavingFinally

    Test-RsatClusteringInstalled : Die Benennung "Test-RsatClusteringInstalled" wurde nicht als Name eines Cmdlet, einer

    Funktion, einer Skriptdatei oder eines ausführbaren Programms erkannt. ….
    In C:Program FilesMicrosoftExchange ServerV14ScriptsStartDagServerMaintenance.ps1:78 Zeichen:2
    .
    .
    .

    Is there an Solution for our Problem?

  9. Anonymous says:

    Nico_85: No, "interim updates" in this case means any special Exchange hotfixes that may have occurred to resolve specific issues in between update rollups (such as through a Microsoft support case). You can always apply new rollups over the existing.

  10. Anonymous says:

    Hello,
    To apply this update rollup, the prerequisites says that you have to Remove all interim updates for Exchange Server 2010 SP3 before you apply this update rollup.
    Interim updates is the other update rollup like kb2905616 or kb2803727 ?

  11. Anonymous says:

    @GPNS: Per a MS Document somewhere but I can’t find the source again:
    If you don’t disable Forefront before installing a rollup or service pack, and enable afterwards, you run the risk of Exchange related services not starting. You can disable Forefront by going to a command prompt and navigating to the Forefront directory and
    running FSCUtility /disable. To enable Forefront after installation of a UR or SP, run FSCUtility /enable.

  12. Jason says:

    Installing in our test env.

  13. x01e says:

    Would be nice if we could upgrade 2013 so easily.. than what you guys make us go through now.. doesn’t matter Exchange admins will be out of a job soon anyway.

  14. tony says:

    Any updates from someone who already installed it in production?

  15. RED says:

    Really all customers with Ex2010 SP3 RU3 or RU4 need to remove all interim updates before installing RU6 a stated in the prerequisite section of KB2936871 ?!?
    "Prerequisites
    To apply this update rollup, you must have Exchange Server 2010 SP3 installed.
    Important Remove all interim updates for Exchange Server 2010 SP3 before you apply this update rollup."

    Tnx.

    Red.

  16. DZ-Man says:

    Installed in our production environment and nothing negative noted thus far. But very THANKFUL the categories bug is now squashed!

  17. kai says:

    when will powershell 3.0 be supportet?

  18. bright says:

    Unable to install on SBS 2011.

  19. Jelmer says:

    Is the mailbox automapping issue fixed? this was broken with ru5.

  20. Knipfer Harald says:

    Hey,

    we have Policies for Shutdown and Start in which we call the MS Script’s StartDagServerMaintenance.ps1 and StopDagServerMaintenance.ps1 .

    We haven’t installed RU5 and now we have Ex2010 SP3 RU6 (German) and the Management Pack 4.

    After Installation, we have problems with this MS Script’s, we get an Execption from the DagCommonLibrary.ps1.

    We’re patching our DAG with WSUS at night, so we need the automatical distribution of the Mailbox Databases based on our Rules – the activation preference of the Mailbox Databases.

    In Addition we have separate colleague’s for deploying Virus Scanner or swap Hardware. Until RU6 there was no Problem, cause after an necessary Systemboot, the MS Script’s correct the database distribution and now it could be a little bit more difficult.

    What happens now? – in my expirience only Shutdwon without an correct move of the cluster functionality or the Move of the active Database – it could happend that the index of the search will be corrupted or even the database will be corrupted…..

    Here is an shorted Version of the Exception,

    …..Exchange ServerV14Scripts> .StartDagServerMaintenance.ps1 -serverName

    In C:Program FilesMicrosoftExchange ServerV14ScriptsDagCommonLibrary.ps1:494 Zeichen:6
    + return $moveSuccessful

    Der Ablauf des Steuerelements kann einen finally-Block nicht verlassen.
    In C:Program FilesMicrosoftExchange ServerV14ScriptsDagCommonLibrary.ps1:926 Zeichen:5
    + return $success

    Der Ablauf des Steuerelements kann einen finally-Block nicht verlassen.
    + CategoryInfo : ParserError: (:) [], ParseException
    + FullyQualifiedErrorId : ControlLeavingFinally

    … Test-RsatClusteringInstalled : Die Benennung "Test-RsatClusteringInstalled" wurde nicht als Name eines Cmdlet, einer ….
    ….. log-verbose : Die Benennung "log-verbose" wurde nicht als Name eines Cmdlet, einer ….
    … In StartDagServerMaintenance.ps1:232 Zeichen:4
    + log-verbose ($StartDagServerMaintenance_LocalizedStrings.res_0015 )
    + ~~~~~~~~~~~
    + CategoryInfo : ObjectNotFound: (log-verbose:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

    log-verbose : Die Benennung "log-verbose" wurde nicht als Name eines Cmdlet, ….
    In C:Program FilesMicrosoftExchange ServerV14ScriptsStartDagServerMaintenance.ps1:97 Zeichen:3
    + log-verbose ($StartDagServerMaintenance_LocalizedStrings.res_0008 -f $shortSer …

    Is there an Solution for our Problem?

    Greets Harald

  21. Don says:

    Is the issue with Auto-mapped mailboxes from UR5 resolved?

  22. Goodgolfer says:

    Been trying to install but keep getting sufficient permissions error. Tried running from a evaluated cmd prompt did not even work. I am a Domain and Enterprise admin and still receiving the permission error. How much more evaluated can you get ?

  23. Nico85 says:

    The documentation says that is important to unistall all Interim Update for Exchange Server 2013 before install Update Rollup 6.
    What is excatly Interim Update ? Is there other previous Update Rollup (5, 4, 3,…) ?

  24. HossFly says:

    Can not install due to requirement of Windows Installer 4.5 although Server 2008 comes with Windows Installer 5.0 and there is no way to uninstall this version.

  25. Phil says:

    @GPNS

    Use a script to automagically disable forefront and renable it.

    See my blog post here (complete with powershell script):

    http://www.rebee.clara.net/blog/archives/2012/05/entry_199.html

    Phil

  26. Dave says:

    Is there a FULL install with SP3 Rollup 6 (slipstreamed) available ? I wanted to install exchange 2010 on another server would love to not have to do the update after installing…

  27. Franko says:

    @Nico_85 I’ve asked the same question in other threads. Interim updates are very rare and they are handed out to individuals by Microsoft support after lengthy support cases. Essentially you’d know if you had installed one. No need to uninstall previous
    Update Rollups :)

  28. Max says:

    We have some users which are complaining about mails stucking in outbox since some days. We installed UR3 last weekend. We found out, only users which dont use the Exchange cached mode are involved. Is it may related to UR3 or does somebody else facing
    similar issues since this update? Thanks, Max

  29. Oliver says:

    @hknipfer: If you mean with "Management Pack 4" == "Windows Management Framework 4.0",

    Powershell 4.0 is curently not supported on Ex2010.
    Uninstall Windows Management Framework 4.0.
    Look also here:
    http://blogs.msdn.com/b/powershell/archive/2013/10/25/windows-management-framework-4-0-is-now-available.aspx

  30. RF says:

    This seems to have broken the redistributeactivedatabases.ps1 script – is anyone else experiencing this?

  31. Peter Hutchison says:

    Rollup date 6 seems to have caused access issues to share mailboxes added using automapping feature.
    Removing the mailbox permissions and re-adding them with no automapping seems to work.

  32. shaikat1 says:

    Installed in DEV environment, and noticed everything is working as expected, email flow, DAG and other necessary services, etc. now planing to install in PROD environment by end of this month.

  33. Karsten says:

    This SP3 RU6 seems to have a bug with dynamic distribution groups containing a static group: If you create a dyn. group the following way the preview button of the dyngroup in EMC shows an empty window if the members of the static group are not in the
    OU "Users":

    $groupidentity = $(Get-DistributionGroup verteiler).Identity.DistinguishedName
    new-DynamicDistributionGroup dyn-verteiler -RecipientFilter "MemberOfGroup -eq ‘$groupidentity’"

  34. Karsten says:

    This SP3 RU6 seems to have a bug with dynamic distribution groups containing a static group: If you create a dyn. group the following way the preview button of the dyngroup in EMC shows an empty window if the members of the static group are not in the
    OU "Users":

    $groupidentity = $(Get-DistributionGroup verteiler).Identity.DistinguishedName
    new-DynamicDistributionGroup dyn-verteiler -RecipientFilter "MemberOfGroup -eq ‘$groupidentity’"

  35. Brian says:

    I patched our Exchange 2010 servers with this rollup yesterday. We now have a lot of users that have "full access" to shared mailboxes that can no longer access the mailboxes. The mailbox has always "automapped" in the Outlook and was accessible to the
    user. I see another user with the same complaint:
    http://social.technet.microsoft.com/Forums/exchange/en-US/5591e2b6-b406-4e9b-b511-b135d1c3616f/exchange-auto-mapping?forum=exchangesvrclients. Is there a fix for this?

  36. Diamondas says:

    Thats realy great update like RU3v2 and RU4v4 !

  37. charlez says:

    Microsoft.Exchange.RpcClientAccess.Service.exe running at 50% cpu after this update.
    Anyone with the same issue?

  38. Serry says:

    Hi, since I’ve install this upgrade, when I give full access to a mailbox to a user, the mailbox automatically appear in his outlook but he want be able to access it saying that he does not have the required permissions. The I go and add it manually and
    it will work but the user will have 2 copies of the mailbox. One that works and one that is not. Any clue what it could be ?

Comments are closed.