Re-released Exchange 2010 and Exchange 2007 update rollups


Earlier today we re-released the following Rollup Updates. These updates address an issue in which digital signatures on files produced and signed by Microsoft will expire prematurely, as described in Microsoft Security Advisory 2749655. Also see Security Advisory 2749655 and timestamping on the Security, Research & Defense blog.

The re-released Exchange 2010 SP2 RU4 includes the following additional fix:

2756987 Only one result is returned after you click “view all results” in Outlook 2010 or in Outlook 2013 in an Exchange Server 2010 environment

It is not required to uninstall the previous rollups to install the re-released rollups listed above.

Exchange Team

Updates:

  • 10/9/2012 Removed note about knowledgebase articles not being available at the time of publishing.
  • 10/10/2012 Added link to Security Advisory 2749655 and timestamping on the Security, Research & Defense blog for additional background information.
  • 10/10/2012 Added info about not requiring previous versions of rollups to be uninstalled before installing re-released rollups.
Comments (30)
  1. Mike says:

    Treat this like an Interim upgrade an uninstall original RU8 first like the last re-release or install over the top?

  2. Bharat Suneja [MSFT] says:

    @Mike: You don't need to uninstall the original rollup to install the re-released one.

  3. Grzegorz Wierzbicki says:

    When do these signatures expire exactly ?

    Can I skip this one and wait for RU5 ?

  4. Ron Mitchell says:

    KB2756485 will not install on any of my systems.  During the installation, it fails and just says "ended prematurely"

    ron@bcdcon.com

    Ron Mitchell

  5. I've got the same problem as Ron Mitchell.

    WindowsUpdateLog says notthing, EventViewer the same. RU4 (V1) is already installed.

    Any Idea where to look for the error?

  6. RB says:

    If Update Rollup 4-v1 for Exchange Server 2010 SP2 is already installed on our systems, we do not need to install this v2 version?  Problem was only with the original installation v1 file?

  7. s33butler@hotmail.com says:

    None of the links or articles give the premature expiration date.  So from a change management aspect, how long do I have to get these updates approved and installed before the previous signed binaries expire?

    Scott

  8. sadda@outlook.com says:

    We should uninstall existing Update Rollup 4 before installing the v2!

  9. Bharat Suneja [MSFT] says:

    @Sven: The issue mentioned in that thread not a known issue.

  10. Bharat Suneja [MSFT] says:

    @Grzegorz Wierzbicki, @s33butler: As mentioned in the SRD blog post (Security Advisory 2749655 and timestamping):

    For some of the affected files and packages, that signing key expiration date falls in the next few months.

  11. Chris says:

    Next few months?

    Is there a way to tell with more specificity?  ie, "Next week" is within the next few months.

    Is there a command I can run on a file to see when it will expire?  Then I can at least scan around for it.

  12. Kerschenbauer Wolfgang says:

    I have downloaded Update Rollup 8-v2 for E2k7 with SP3 and tried to install it. But i always get a message from the installer that "the feature you are trying to use is on a network resource that is unavailable. …. Use source: d:exsp3".

    But this is not true!!!

    There must be a problem. I have currently installed Rollup7.

    Thanks

    Kerschenbauer Wolfgang

  13. @Sadda:

    Uninstallation of RU4 failed because it can not uninstall RU2 oO

    On a clean Exchange 2010 SP2 the installation von RU4 V2 works fine.

  14. sadda@outlook.com says:

    @Thomas,

    In a test environment, I can't even install RU v2 on top of RU v1. I'm able to uninstall RU2 v1 and then reinstalled re-release RU2 v2.

    However Bharat mentioned that uninstallation of RU v1 is not required!

    Update:

    10/10/2012 Added info about not requiring previous versions of rollups to be uninstalled before installing re-released rollups.

  15. sadda@outlook.com says:

    Oops!, please read "RU4" instead of "RU2" my previous reply!

  16. Guilherme says:

    I'm a bit confused right now. Is it necessary to uninstall the v1 version or not?

    Another question: what is the impact of doing the uninstall of the v1 version for my enviroment?

  17. Black says:

    You don't need to uninstall Update Rollup 4-v1 for Exchange Server 2010 Service Pack 2 in order to install Update Rollup 4-v2 for Exchange Server 2010 Service Pack 2.

  18. Mike says:

    service startup on RU8v2 takes years

  19. Rick says:

    EX 2007 SP3 rollup 8-v2 will not install on PC with management console.  Have tried the install through WSUS and also downloading x64 package and running locally.  No error messages in Event log or update log.  Downloaded package stalled at the 'Stopping Services…' screen.  Waited several hours before aborting it.

  20. Vince K. says:

    Wondering if anyone knows if the build # changes between 2010 SP2 RU4 and 2010 SP2 RU4-v2.  If not, it will be simple to re-customize OWA (just copy the same files customized for RU4 back on top once installed).  RU4 was 14.2.318.2 within OWA.  Just wondering if I'll have to manually customize again…

  21. sadda@outlook.com says:

    @Mike & Rick,

    Did you guys ran the installation from elevated command prompt? Also make sure to uncheck this option "Check for publisher's certificate revocation" in IE settings.

    @VInce.

    As per the KB article, "When you apply an update rollup package, the update process updates the Outlook Web App files if they are required. Therefore, any customizations to the Logon.aspx file or to other Outlook Web App files are overwritten, and you must re-create the Outlook Web App customizations in Logon.aspx"

  22. Graeme Frog says:

    Just installed Exchange 2010 SP1 Rollup 7-v2 to an SBS2011 server, and all is well.  Version 1 had previously been installed, and I did not remove that first.  Version 2 took about 25 minutes to run, and I rebooted the server immediately afterwards.  Hope this helps.

  23. michael.hughes@chaffey.edu says:

    2010 SP2 with the first update installed fine on both CAS. Then I tried to update to v2 on a DAG member and it failed, so I tried to uninstall the original – the uninstall failed – can't go forward, can't go back – any ideas on where I go from here? I don't want to tempt fate on any of the other DAG members so any ideas are welcome!

  24. Leo says:

    What a mess.  I won't even go there.

  25. Uwe says:

    Update Rollup 4-v2 for Exchange Server 2010 Service Pack 2 (KB2756485)

    does not proper install – immediately Rollback…

    on a Full Patched Windows 2008 R2 SP1 with Exchange 2010 SP2 RU-4 V1.

  26. Petri X says:

    Is there any hope that you fix the bug in the ExTRA? Try to use it with the CCR cluster and you end up into this:

    \exchangeCCRnamec$Perflogs "The Network Name cannot be found"

    Could you fix it also on the E2007 and E2010. The solution is:

    Now you run the command:

    cmd /c md \exchangeCCRnamec$Perflogs

    That fails because of W2008 cluster scoping feature (blogs.technet.com/…/file-share-scoping-in-windows-server-2008-failover-clusters.aspx). But if you could check using the EMS what is the active node and then run the command:

    cmd /c md \exchangeCCRActiveNodec$Perflogs

    You get the happy customers!

    Thank you for listening….

  27. Stojozano says:

    I've come into an environment where the Exchange 2010 servers have been sitting behind a WSUS since sp1.  What am I up against as far as bringing this current? Do I have phase things in or just sp3?

  28. Susan says:

    Why is there a v3 of these updates that was released in November?

  29. KiwiExchange says:

    Hi all,

    I am on Exchange 2007 SP3 Update Rollup 6.

    Do I need to install Update Rollup 7 before installing Update Rollup 8 version 3?

Comments are closed.