Released: Update Rollup 4 for Exchange 2010 Service Pack 2


On August 13th 2012, the Exchange CXP team released Update Rollup 4 for Exchange Server 2010 SP2 to the Download Center.

This update contains fixes for a number of customer reported and internally found issues. See KB 2706690 Description of Update Rollup 4 for Exchange Server 2010 Service Pack 2 for more details.

In particular we would like to specifically call out the following fixes which are included in this release:

Note: Some of the following KB articles may not be available at the time of publishing this post.

  • New updates for August DST – Exchange 2010 – SP2 RU4 – Display name for OWA.
  • 2685001 Retention policies do not work for the Calendar and Tasks folders in an Exchange Server 2010 SP1 environment
  • 2686540 Exchange 2010 Messages are not delivered to Journal Mailbox
  • 2701162 Granting Full Mailbox Access Does Not Allow Full Details of Free/Busy To Be Displayed
  • 2724188 Information loss due to unexpected subject modification while copying a message in Outlook
  • 2743871 Stop Forefront services in RU setup so no manual steps are required
  • 2740358: MS12-058: Vulnerability in Microsoft Exchange Server WebReady document viewing could allow remote code execution: August 14, 2012

For DST Changes: http://www.microsoft.com/time

Exchange Team

Update 6:59 PM: Updated link 2740358: MS12-058: Vulnerability in Microsoft Exchange Server WebReady document viewing could allow remote code execution: August 14, 2012.

Comments (44)
  1. Milind Naphade says:

    support.microsoft.com/…/2743246 does not seem to be working yet.

  2. ES says:

    Hallelujah! You finally automated the Forefront steps!!

  3. @Milind, yes as the note states some KB pages may not be live yet. Coming soon though!

  4. Bharat Suneja [MSFT] says:

    @Milind: Which is why we specifically state the following in RU blogs :)

    Note: Some of the following KB articles may not be available at the time of publishing this post.

  5. Matthew Van Sickler says:

    Does 2743246 (not available yet) mean it is safe to enable WebReady document viewing after installation of this RU?

  6. Once you have deployed the RU to all CAS servers in your organization, you can re-enable WebReady Document Viewing.  This is outlined in the Security Bulletin.

  7. GoodThings2Life says:

    OMG, thank you for the Forefront fix! :) And also for the hard work on the other fixes too.

  8. deiruch says:

    Thanks a bunch for KB 2743871!!!

  9. Phil says:

    The 'disabling Forefront' thing wasn't that difficult a problem, but it's nice to see it included in the rollups.

    I blogged the solution here earlier this year: http://www.rebee.clara.net/…/entry_199.html

    If you've some other vendor's Antivirus which needs disabling the above might give you a clue as to how to do it automatically.

  10. Grzegorz Wierzbicki says:

    Two days and it's already on Windows Update. You must be pretty confident about that one.

  11. Phil says:

    @Grzegorz

    Presumably because it contains a critical security update

  12. Peter F says:

    For anyone still stuck on 2010 SP1, Update Rollup 7 has been released (with just the security fix, it seems)

    support.microsoft.com/…/2743248

  13. Rollup Update 7 was released to provide a supported fix to MS12-058 for customers who are still running Exchange Server 2010 SP1.  The only new fix delivered in Rollup Update 7 was the release of the updated binaries to address MS12-058.  As with all of our Rollups, Rollup Update 7 is cumulative and will also include all previously released fixes for Exchange Server 2010 SP1.

  14. Greg Taylor [msft] says:

    Just wanted to make sure anyone reading this and using Exchange 2010 SP2 with ABP's for a multi-tenancy platform also is aware that there is an important fix in this RU which prevents a specific scenario whereby a list of all accepted domains can end up being downloaded to client machines. Please install the RU4 update to prevent that from happening and don't enable any Outlook Protection Rules.

    There will be a KB specific to this issue out soon, and the fix is in RU4 though it is not listed in the accompanying KB.

    The latest iteration of the Hosting and Multi-Tenancy Guidance includes some details about this specific scenario (the document says RU5 though we managed to get it into RU4 as a result of some great work by the Sustained Engineering team in Exchange, I will be updating and re-releasing the doc when I get a moment), so download a fresh copy of that and have a read to understand the issue. http://www.microsoft.com/…/details.aspx

    Greg

  15. Milind Naphade says:

    Bharat, Brian, thanks for that guys. I looked at that post commenting. :-)

  16. Paulchen says:

    Hello

    does the RUP4 solves the "Unhandled Exception "User setting 'PreferredSite' is not available." problem?

    blogs.technet.com/…/released-update-rollup-3-for-exchange-2010-service-pack-2.aspx

  17. After installing SP2 UR4 I get:

    You must restart your system for the configuration changes made to MS Exchange Server to take effect.

    SP2 UR4 also requires a server restart?

  18. Paulchen says:

    Hi Martijn,

    after hotfix, SP or Rolluppackage installation MS recommends to restart the system. To be sure that all the changes will be work you have to restart the server!

  19. Jürgen says:

    The fix for Article ID: 2632409 "Sent item is copied to the Sent Items folder of the wrong mailbox in an Exchange Server 2010 environment when a user is granted the Send As permission" doesn't seem to work. We´ve got a mixed environment (Exchange 2003 and 2010), but both Mailboxes are on 2010.

    Tried the following scenerio:

    •A user has a mailbox (MB1) on Exchange 2010

    •Granted the user the Full Access permission and the Send As permission for another mailbox (MB2), which is on Exchange 2010 as well.

    •The user MB1 sends an email message as MB2 using Outlook 2010.

    • The mail is sent, MB2 is shown in the From-Header, but the sent item isn't moved to the sent items folder of MB2…

    Anyone got the same problem?

  20. sadda@outlook.com says:

    Can we get a separate patch for the vulnerability described in the above post?

  21. xC0000005 says:

    @Jürgen – What are the shared mailbox's sent items options set to?

  22. Knipfer Harald (Exchange Admin) says:

    Please avoid it in the future security patches put quickly in a rollup installation without the possibility for a separate single installation.

  23. Jürgen says:

    …waited 3 Days, created an new Outlook 2010 Profile and now the fix described in KB-Article ID: 2632409 works!

    Thanxxx!!!

  24. llacasse says:

    Two things. 1. The new "Sent Items" in the options seems to be showing up in english only. We have both french and english available on our system and the "Sent Items" is the only thing in english even when in french.

    2. The following problem that was fixed in SP2 RU1 (support.microsoft.com/…/2589982) seems to be back for me. I was running SP2 RU2 before going to RU4 and I did not get the issue.

    Thanks!

  25. It appears the documentation update which tells how to invoke the functionality referenced in KB 2632409 is not completed yet.  This fix introduced a change in behavior which must be enabled by the system Administrator to enable the new functionality.  We will get this guidance published.

  26. bitjaeger says:

    Also here, the new "SentItems" Option in OWA is in english when the Userinterface is in German. Seems to be a bug…

  27. With regard to the 'Sent Items' options tab in ECP not being localized, we are aware of this issue.  This functionality was added as part of the new Sent Items handling added in RU4.  Rollup Updates are not localized and this behavior is expected.  When SP3 is released this feature will be fully localized.

  28. Mailbox move to another DB on the same server (E2K10 SP UR4) gives warning/error:

    The Microsoft Exchange Mailbox Replication service completed request <mailbox> with warnings.

    Warning: Failed to clean up the source mailbox after the move.

    Error details: MapiExceptionUnexpectedMailboxState: Unable to delete mailbox. (hr=0x80004005, ec=2634)

    The mailbox has been moved and can be accessed.

    See also social.technet.microsoft.com/…/6043b74f-a41e-4674-b2b1-08c3b1a3afbd

    Is this a known issue?

  29. Zussamen says:

    @Martijn Westera,

    I have always had that error when I move a mailbox with 2010 SP2 UR1 through 4.

    The move does work though. The source mailbox shows as disconnected (SoftDeleted). I use this to check the disconnect reason:

    Get-MailboxDatabase | Get-MailboxStatistics | where {$_.DisconnectReason -ne $null} | ft  displayname,database,disconnectreason -auto

    and use this to remove:

    Remove-StoreMailbox -database SourceMboxDBName -Identity "Smith, John" -MailboxState SoftDeleted

  30. hemant.sohoni@toyota-fs.com says:

    @Brent – would you know when its likely that the documentation for enabling Sent item fix: KB 2632409 is likely to be available.  Is there any other information that you can provide in the meantime to get this to work?

  31. Anyone else experiencing errors with MSFTESQL after installing UR4?

    Details of the errors in this post:  social.technet.microsoft.com/…/df0e3031-6efd-4611-a2ee-4f40e523ac3c

  32. DD says:

    Echo HemSo…

    @Brent – when will the documentation for enabling Sent item fix: KB 2632409 be available?

  33. Shawn Martin says:

    Is anyone else having a problem in OWA opening other mailboxes when the default SMTP address is not an address that's the default domain? I can fix this issue by changing the default SMTP address of the mailbox, but this is not an optimal solution.

    Thanks

    Exception

    Exception type: System.ArgumentNullException

    Exception message: Value cannot be null. Parameter name: organizationId

    Call stack

    Microsoft.Exchange.Data.Directory.ScopeSet.GetOrgWideDefaultScopeSet(OrganizationId organizationId, QueryFilter recipientReadFilter)

    Microsoft.Exchange.Data.Directory.ADSessionSettings.FromOrganizationIdWithoutRbacScopesServiceOnly(OrganizationId scopingOrganizationId)

    Microsoft.Exchange.Clients.Owa.Core.Utilities.CreateADRecipientSession(Boolean readOnly, ConsistencyMode consistencyMode, SmtpDomain smtpDomain)

    Microsoft.Exchange.Clients.Owa.Core.OwaMiniRecipientIdentity.UpgradePartialIdentity()

    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.PrepareRequestWithoutSession(OwaContext owaContext, UserContextCookie userContextCookie)

    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.AcquireAndPreprocessUserContext(OwaContext owaContext, HttpRequest request)

    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.InternalDispatchRequest(OwaContext owaContext)

    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.DispatchRequest(OwaContext owaContext)

    Microsoft.Exchange.Clients.Owa.Core.OwaRequestEventInspector.OnPostAuthorizeRequest(Object sender, EventArgs e)

    System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

    System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

  34. We are actively working on the documentation for KB 2632409.  As soon as it is complete, it will be made available.  At this time, I cannot commit to a particular date.

  35. Nico Wagner says:

    @Shawn Martin

    Yes, we have had the same issue in out test environment.

    To fix this issue you need to create an accepted domain !

    Rgds

    Nico

    ==============================================

    Is anyone else having a problem in OWA opening other mailboxes when the default SMTP address is not an address that's the default domain? I can fix this issue by changing the default SMTP address of the mailbox, but this is not an optimal solution.

    Thanks

    Exception

    Exception type: System.ArgumentNullException

    Exception message: Value cannot be null. Parameter name: organizationId

    Call stack

    Microsoft.Exchange.Data.Directory.ScopeSet.GetOrgWideDefaultScopeSet(OrganizationId organizationId, QueryFilter recipientReadFilter)

    Microsoft.Exchange.Data.Directory.ADSessionSettings.FromOrganizationIdWithoutRbacScopesServiceOnly(OrganizationId scopingOrganizationId)

    Microsoft.Exchange.Clients.Owa.Core.Utilities.CreateADRecipientSession(Boolean readOnly, ConsistencyMode consistencyMode, SmtpDomain smtpDomain)

    Microsoft.Exchange.Clients.Owa.Core.OwaMiniRecipientIdentity.UpgradePartialIdentity()

    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.PrepareRequestWithoutSession(OwaContext owaContext, UserContextCookie userContextCookie)

    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.AcquireAndPreprocessUserContext(OwaContext owaContext, HttpRequest request)

    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.InternalDispatchRequest(OwaContext owaContext)

    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.DispatchRequest(OwaContext owaContext)

    Microsoft.Exchange.Clients.Owa.Core.OwaRequestEventInspector.OnPostAuthorizeRequest(Object sender, EventArgs e)

    System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

    System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

  36. postmaster@voith.com says:

    @Paulchen: No

    @M$: How hard can it be? Here's the code you need: //

    Klaus

  37. KyleR1980 says:

    After installing SP2 rollup 4 I am seeing that online mailbox moves is broken. Is anyone else seeing this same issue and is there a fix for this?

  38. SanDHeeP says:

    See this commands and error, the command is copied from "technet.microsoft.com/…/gg181092.aspx" however when i ran the command im getting the below error, this is  started after RU4 installation, till then the same command was working fine. any suggestions/comments?

    [PS] C:Windowssystem32>Get-MailboxStatistics -Database DB07 | where {$_.DisconnectReason -eq "SoftDeleted"} | foreach

    {Remove-StoreMailbox -Database $_.database -Identity $_.mailboxguid -MailboxState SoftDeleted}

    Pipeline not executed because a pipeline is already executing. Pipelines cannot be executed concurrently.

       + CategoryInfo          : OperationStopped: (Microsoft.Power…tHelperRunspace:ExecutionCmdletHelperRunspace) [],

      PSInvalidOperationException

       + FullyQualifiedErrorId : RemotePipelineExecutionFailed

  39. Doug G says:

    With regards to the mailbox moves causing the completed with warnings in RU4, could this be caused by the DB setting having the tick box "Do not permanently delete items until a DB backup has occurred" being ticked?  I have unticked this on my DBs and the moves complete with warnings, but still do the waiting 30 seconds for 6 attempts thing that holds up the move request and is very annoying

  40. Doug G says:

    Scratch that, still happens randomly even with the tick box unticked :(

  41. DD says:

    @Brent                      Still waiting on the documentation for KB 2632409

  42. Jon Beets says:

    There also seems to have been some undocumented changes to programmatic support which forced me to run the script C:Program FilesMicrosoftExchange ServerV14binRemoteExchange.ps1 to allow Exchange cmdlet invocation from c#, which was not required before RU4.  This script introduces a problem where some cmdlet invocations return the error

    Method not found: 'Microsoft.Exchange.Management.SystemConfigurationTasks.ArbitrationMailboxStatus Microsoft.Exchange.Management.SystemConfigurationTasks.AdminAuditLogHelper.CheckArbitrationMailboxStatus(Microsoft.Exchange.Data.Directory.OrganizationId, Microsoft.Exchange.Data.Directory.Recipient.ADUser ByRef, Microsoft.Exchange.Data.Storage.ExchangePrincipal ByRef, System.String ByRef)'.

    This error is also returned with RU4 un-installed, however I do not have to run the script so I have a work around.  I have not had time to work out what the problem is here, as yet.

    Jon

  43. hager@chello.at says:

    We got some special bugs with Free/Busy in our Enterprise Company and RU 4 resolved it.

    It looks like RU4 fixed more Free/Busy problems then " Granting Full Mailbox Access Does Not Allow Full Details of Free/Busy To Be Displayed".

    Thanks 4 the good work…

  44. si2424@hotmail.com says:

    Windows update is now showing Update Rollup 4-v2 for Exchange Server 2010 Service Pack 2 (KB2756485).

Comments are closed.