Announcing the re-release of Exchange 2010 SP1 Rollup 4


Earlier today the Exchange CXP team released an updated version of Update Rollup 4 for Exchange Server 2010 SP1 to the Download Center. This updated release is being made available after a complete review and revalidation of the list of fixes included in the previously released version of Rollup 4 dated June 22, 2011.

The review completed by the Exchange CXP team determined that the issue identified in ‘KB 2581545: The copy or move operation on a folder that contains subfolders does not work as expected after you install Update Rollup 4 for Exchange Server 2010 SP1 dated June 22, 2011’ introduced a serious regression in the original release of Rollup 4. As a result, a new version of Rollup 4 dated July 23, 2011 has been tested and released with the change that caused the regression removed. The re-release of Rollup 4 is tracked by ‘KB 2579150: Description of Update Rollup 4 for Exchange Server 2010 Service Pack 1′.

The updated Rollup 4 is being released to allow customers to install the list of fixes previously committed to on the normal rollup schedule using normal rollup installation routines without the need for further action. The re-released version of Rollup 4 is functionally equivalent to the combination of the original Rollup 4 release and (the interim updatein) KB 2581545. Here are answers to some install questions:

  • Customers who have installed KB 2509910 (Rollup 4, dated June 22, 2011) and KB2581545 (fix for Rollup 4 regression) do not need to install KB 2579150 (re-released Rollup 4) but may do so if they choose to.
  • Customers who have already installed KB 2581545 and want to update their systems to the updated Rollup 4 should first uninstall KB 2581545 (or any interim updates) prior to installing the new rollup.
  • You do not need to uninstall original RU4 (KB 2509910) to install the re-released RU4 package (KB2579150).
  • The re-release of Rollup 4 does not change the release plans for Update Rollup 5 for Exchange Server 2010 Service Pack 1. Rollup 5 is currently scheduled to release in August 2011.

Some of the above KnowledgeBase articles are not replicated/live at the time of writing this post. Please check back later in the day if you can’t reach them.

General Notes

Note for Exchange 2010 Customers using the Arabic and Hebrew language version: We introduced two new languages with the release of Service Pack 1, Arabic and Hebrew. At present we are working through the process of modifying our installers to incorporate these two languages. Customers running either of the two language versions affected are advised to download and install the English language version of the rollup which contains all of the same fixes.

Note for Forefront users: For those of you running Forefront Security for Exchange, be sure you perform these important steps from the command line in the Forefront directory before and after this rollup’s installation process. Without these steps, Exchange services for Information Store and Transport will not start after you apply this update. Before installing the update, disable ForeFront by using this command: fscutility /disable. After installing the update, re-enable ForeFront by running fscutility /enable.

Brent Alinger

Comments (18)
  1. ML49448 says:

    Excellent. I'm deploying exchange for a client right now so I'm going to give it a shot tomorrow. I hope I don't regret it. :)

  2. GS says:

    Usually wait for atleast 2 months before i install new rollup.  That way i never regret.  

  3. Garry says:

    I have Exchange 2010 SP1 RU4 installed (KB2509910). I then contact MS and got the interim update. However, looking at my server it is listed as KB2575734. This KB number is different from the KB number listed in this article. Could someone please explain why the KBs don't match? Thanks.

    p.s. Sorry if this is a double post but I can't see my orginal one so I have posted again.

  4. Courtenay says:

    Fortune favors the brave – I'm writing my Change Request now :-)

  5. SanDHeeP says:

    I guess its always good to uninstall the RU4v1 before we proceed with RU4v2.

  6. jirka.burian@metro.st says:

    I've got a question I was not able to find an answer to anywhere. When installing RU manually with Forefront installed, I understand I need to run fscutility /disable (/enable), but what if I use WindowsUpdate to install RU for me? Is that fscutility /disable (/enable) done automatically or I have to run that before/after I start WindowsUpdate?

  7. Simon says:

    Have the same question as Jirka.B.

    Also, why can't you just include the Forefront steps in your updater?!

  8. Andy says:

    When will v2 be released to Microsoft Update?

  9. HotFix says:

    @Jirka.B & @Simon – if you apply the update through Windows Update, the process of applying the update with Forefront still enabled will leave your Transport service in a non-running state if the update doesn't require the server to reboot (I don't think Exchange RUs do, but just making that statement.

    So if you have automatic updates turned on, you will find one day that your Exchange Hub Transport servers are not sending or receiving email because they recently automatically applied an Exchange RU through Windows Update. You can choose to either start the Transport service or reboot the server (which essentially does the same thing)

    As to why they don't build in support for it, while I agree it is frustrating, the Exchange team and Forefront team are two separate teams in Microsoft that don't directly work together on an everyday basis. If you think about it, its no different than any other antivirus vendor, in that Microsoft doesn't build in support for those products being installed on top of Exchange, and whatever wacky requirements they have for applying Exchange Service Packs or RUs. Again I agree it's frustrating, but there is a logical explanaition.

  10. Hi Guys

    I had installed the orginal RU4 and now installed RU4v2 on my Exchange 2010 SP1. I am still not able to recover deleted Public Folders with ExFolders 2.8. There is a Error Message "Recovery partially succeeded". Any Ideas? This works fine with RU3.

    Regards Andres

  11. Netadmin Jerry says:

    Will the interim update or RU5 finally fix the "No items to show in this view" problem in Outlook?  It was listed as being fixed in RU4, however it doesn't seemed to fix the problem.  

  12. Chris says:

    Does RU4 address the UDP Push issues when using Outlook 2003 in online mode? RU3 and adding the resgistry key did not comletely resolve the issues. Users still receive an "unknown error" message.

    Thanks. Chris

  13. courtenay_snell@live.com says:

    4 days in, and all going smoothly from my part. The upgrade was clean and painless – Thanks Brent.

  14. I apply Update Rollup 4 for Exchange 2010 SP1 and the build number remais the same (218.15) after update complete.

    Is this correct?

  15. bert.vets@t-systems.be says:

    The update fixed some problems we were experiencing, for which my customers and me are very gratefull. :-)   However, I did ran into a problem.  After the update the webmail stopped working.  The eventlog showed multiple event id's 116 with the following message:

    "Outlook Web App failed to load the following theme folder: D:Program FilesMicrosoftExchangeClientAccessowa14.1.323.3themesgoth

    The following files are missing: gradienth.png, gradientv.png, csssprites.css, csssprites.png, csssprites2.css, csssprites2.png"

    Since the installation went fine on my test-server (a clone of the production server) I was able to copy the missing files from that machine, which solved the problem.  The same issue occured in RU1 (or was it RU2?).  I wasn't the only one experiencing that problem back then, but it seems that I'm the first one now.

    The fix is easy, but perhaps you should look into why this happens on some machines.

  16. zapata says:

    After applying this RU IMAP4 no longer works. The server replies with NO Server Unavailable. 15

  17. unaischr@hotmail.com says:

    HI Guys,

    How can we enable mail box for Existing AD users  with Alias & Mail ID same as AD log on account while selecting Multiple AD Users. While selecting Multiple AD account alias and mail id get changes and creating automatic. I need to create mail ID as same AD logon (samaccount).

    Thanks

    UNAIS

Comments are closed.