Released: Update Rollup 3 for Exchange 2010 SP1 and Exchange 2007 SP3


Earlier today the Exchange CXP team released the following Update Rollups for Exchange Server 2010 and 2007 to the Download Center. Release via Microsoft Update will occur on March 22nd 2011.

Update Rollup 3 for Exchange Server 2010 SP1

This update contains a number of customer reported and internally found issues since the release of RU2. In particular we would like to specifically call out the following fixes which are included in this release:

  • 2432494 ‘Database Copies’ list is being populated incorrectly (case sensitive) in EMC with DAG in place after upgrade to E14 SP1
  • 2489822 Users without mailbox can’t delete items in shared mailbox via OWA premium
  • 2009942 Folders take a long time to update when an Exchange Server 2010 user uses Outlook 2003 in online mode

Update Rollup 4 for Exchange Server 2010 Service Pack 1 is currently scheduled to release in May 2011.

Update Rollup 3 for Exchange Server 2007 SP3

This update contains a number of customer reported and internally found issues since the release of RU2. In particular we would like to specifically call out the following fixes which are included in this release:

  • 2267661 Exchange should support promotion of multipart/mixed messages into a single aggregate body
  • 2479939 Resource Booking using ScheduleOnlyDuringWorkHours does not consider mailbox’s time zone

Update Rollup 4 for Exchange Server 2007 Service Pack 3 is currently scheduled to release in May 2011.

General Notes

Note for Exchange 2010 Customers using the Arabic and Hebrew language version: We introduced two new languages with the release of Service Pack 1, Arabic and Hebrew. At present we are working through the process of modifying our installers to incorporate these two languages. Customers running either of the two language versions affected are advised to download and install the English language version of the rollup which contains all of the same fixes.

Note for Forefront users: For those of you running Forefront, be sure you perform these important steps from the command line in the Forefront directory before and after this rollup’s installation process. Without these steps, Exchange services for Information Store and Transport will not start back up. You will need to disable ForeFront via “fscutility /disable” before installing the patch and then re-enable after the patch by running “fscutility /enable” to start it up again post installation.

Kevin Bellinger

Updates:
4/6/2011: The updated Exchange 2010 SP1 RU3 has been re-released. See Announcing the Re-release of Exchange 2010 Service Pack 1 Update Rollup 3 (V2).
3/31/2011: The updated Exchange 2007 SP3 RU3 has been released. See Announcing the Re-release of Exchange 2007 Service Pack 3 Update Rollup 3 (V2).
3/30/2011: We posted a status update for both updates. See Exchange 2007/2010 Rollup 3 Status Update.
3/29/2011: We posted about an issue with Exchange 2007 SP3 RU3. See Potential for database corruption as a result of installing Exchange 2007 SP3 RU3. The download was deactivated.
3/14/2011: We posted about an issue with Exchange 2010 SP1 RU3. See Exchange 2010 SP1 Rollup 3 and BlackBerrys sending duplicate messages. The download was deactivated.

Comments (51)
  1. Dave Stork says:

    Nice! Was waiting for Rollup 3 for Exchange 2010 SP1.

    BTW: the links to the KB articles do not work correctly. Or am I to fast?

  2. WorkingHardInIt says:

    Nope thelinks don’t seem to work. To speedy I guess ;-)

  3. Kevin Bellinger (MSFT) says:

    The content takes a little while to replicate – we’re working through this now to make sure that it is just replication lag and nothing more serious.

  4. mderooij says:

    Congratulations team on yet another milestone and listening to customers, e.g. the Outlook 2003 population.

  5. Korbyn says:

    re: 2511471/2009942 – That would be the UDP packet notification coming back, correct?  

  6. HotFix says:

    Any clue if the warning message regarding Extended Protection has been addressed with this update?

    http://social.technet.microsoft.com/Forums/en/exchangesvradmin/thread/80e3b96d-0f17-4ead-92ab-9875cc663ef3

  7. TommyG says:

    Is it required to uninstall Rollup 1 or Rollup 2 prior installing Rollup3?

  8. Ashley says:

    I am both a Forefront and a WSUS user. If I automatically deploy RU3 with WSUS, will it automatically disable/enable Forefront during the installation?

  9. Cristian says:

    " Ashley said:

    I am both a Forefront and a WSUS user. If I automatically deploy RU3 with WSUS, will it automatically disable/enable Forefront during the installation? "

    i have the same question…

  10. ryan says:

    Are you referring to Forefront for Exchange or Forefront Client Security or Forefront TMG server?  Also, do we need to uninstall RU1 & RU2?

  11. Jay Newton says:

    Big thank you from Oklahoma!!  Great job, guys!!

  12. Flashlights torch says:

    Powerfrugal and bright flashlights mean a lot for night stalkers, police and even the drivers.

  13. tony says:

    I’m using Forefront Protection 2010 for Exchange. When I try to run "fscutility /disable", i get an error:

    "Microsoft Forefront Protection cannot be disabled at this time: Please stop the following services and then rerun this utility again:

    FSCController

    MSExchangeTransport

    MSExchangeIS

    Should I stop them and run command again?

  14. biD1 says:

    hmm real shame the Outlook 2011 calendar colors to exchange is not fixed, categories colors in Outlook 2011 cant see in outlook 2010 or webmail, please fix this Bug.

  15. Neil Hiorns says:

    Is the issue with RBAC Scopes detailed in Article ID: 2410571 included in Rollup Pack 3 as it states?

  16. Jeremy Wood says:

    Does RU3 cover all of the issues addresses by the RU2 Interim Rollup as well?

  17. Frank T says:

    Yes, update rollups are always cumulative (i.e. they include all changes from previous UR’s for the same Service Pack.)

  18. Frank T says:

    aaccck missed the word ‘interim’ in your post Jeremy. Anyway in my experience it’s not always the case that issues fixed in an Interim update make it to the next UR released. So if your issue is not listed in the kb, it probably didn’t.

  19. Regarding the Outlook 2003 problem, here is the correct kb article id:

    http://support.microsoft.com/kb/2009942

    Folders take a long time to update when an Exchange Server 2010 user uses Outlook 2003 in online mode

    Yizhar

  20. Ente says:

    For me the  UDP packet notification for Outlook 2003 is not working although I did everything mentioned here: http://support.microsoft.com/kb/2009942 (of course after installing RU3)

    Has anyone else already tried if it’s working?

  21. MonsterAxe says:

    Hi Ente,

    I have been posting over on the http://msexchangeteam.com/archive/2011/01/28/457845.aspx page regarding this. I also, have applied the Rollup and done the registry change, and have the same client experience. You are the first other person I have found that has also found that this is still not working.

    I haven’t heard whether anyone has found that this has resolved the UDP packet notification problem yet.

    Has anyone had any success with this issue after applying the steps mentioned in http://support.microsoft.com/kb/2009942 ?

  22. Karsten says:

    @MonsterAxe

    I tried first with SP1 RU3 whithout the Registry key metioned in kb/2009942 – I deleted items and it took a time until this was shown in Outlook. So the error still occured.

    I addedt the "ParametersSystem" Key and the EnablePushNotifications Entry on the CAS Server.  Then I rebooted  the CAS Server. Deleting items in the Mailbox shows  now up in a timely manner.

    The problem still occoured with Public Folders. I added the key on the mailbox/public folder server and rebooted this server. I am not shure if it is working correctly now concerning the public folder. It still takes about 5 seconds until a deleted mail is gone.

    But I dont get these errors "the element you want to delte is not here"

  23. MonsterAxe says:

    @Karsten

    I too can delete e-mails and some do delete as expected, but if I have a list of 10 e-mails and delete them one-by-one, not all will move to the Deleted Items folder. The deleted items folder updates with the correct number of items, but those items that did not delete correctly "remain" in the Inbox.

    When you were able to delete these, what was a timely manner? If I delete e-mails straight after each other, I end up with problems as before. Some e-mails delete, and some remain and subsequent attempted deletes or moves result in "Unknown Error" or "Can’t move this item".

    I am not aware of the public folder issues, and I will attempt to test this on my systems.

    Can anyone else shed some light on this (successful or not)?

  24. JBH2941 says:

    Hi there- I’m seeing RPC AVERAGE latencies up to 250 MS when blackberry dynamic messaging agents are configured on my BES server ONLY AFTER installing this patch.  Are RIM and Microsoft still pointing fingers with the blackberry message delays issue?  Removing the dynamic agent config on BES decreased the average latencies down to 15 MS.  

    Any ideas?  

  25. Korbyn says:

    I noticed the installer prebuilt the .NET assemblies before actully starting the install, reducing a lot of downtime for the exchange services.  great job, if this isn’t new, sorry for not noticing sooner.  Lab testing of hfru3 and win2k8r2 sp1 have gone good for me, but i no longer have O2003 to weigh in on.

  26. JK27 says:

    With Outlook 2003 we are still seeing the "Unknown Error" message in our test lab. There is no apparent change to the Outlook 2003 delay issues after installing RU3. We talked to Microsoft Support, and were told that we will have to educate our users to move and delete items from their mailboxes slower until we upgrade their Outlook clients…our migration project to Exchange 2010 has been stalled for nearly a year because of this problem, we are extremely dissapointed.

  27. James K says:

    Exchange 2010 SP1 RU3 appears to introduce a bug with BES 5.0 SP2 MR4 and causes duplicate Sent items to show up on the handhelds.  Rolling back to RU2 seems to have fixed the issue.  The UDP notifications were not enabled on RU3.

    From looking at the duplicate messages on the device itself using ALT and typing V-I-E-W, the message RefID appears to be different on the two messages.  So almost like something is causing the message to be modified once it gets sent.  These messages are not actually sent out multiple times, nor do they show up as multiple items in the person's Outlook Sent Items.  Only duplicated on the devices themselves.

  28. Federico Moschini says:

    Unfortunately after deplying Rollup 3 for Exchange 2010 SP1 I cannot access OWA because there is only a blank page. Anyone have this issue? After uninstalling Rollup 3, I can access OWA again.

  29. itmonkey says:

    Am i being dumb here or are the links to download RU3 missing/dead?

    Thanks

  30. itmonkey says:

    Ah ok, i was being a little dumb

    blogs.technet.com/…/exchange-2010-sp1-rollup-3-and-blackberrys-sending-duplicate-messages.aspx

    For any one else wondering the downloads have been disabled until they find a solution to the BES issues – MS could have at least but a holding page up

  31. Albert Gotink says:

    Does using old Outlook versions (with UDP) affect serverperformance ?

    In the "Exchange 2010 Mailbox Server Role Requirements Calculator" this is not mentioned.

    My guess is that the servers -when using Outlook 2010 in cached mode- can handle more cliënts.

  32. Amir Haque [MSFT] says:

    Those who are seeing issues with UDP fix (as in KB:2009942) included in E2010 SP1 RU3, could you please call in to provide more details so that we can investigate those issues. Thank you.

  33. MWeb says:

    What about installing UR3 Exchange 2007 SP3 on Windows server 2008 R2 with SP1 already installed? On the download page this option is not mentioned.

  34. Jeff25 says:

    Reply to   M. Amir Haque [MSFT

    Those who are seeing issues with UDP fix (as in KB:2009942) included in E2010 SP1 RU3, could you please call in to provide more details so that we can investigate those issues. Thank you.

    Applied RU3 and requested registry changes, when a user deletes multiple emails in a row not by selecting each but by pressing the delete key on each message about 30% of them will give the error "Unknown Error". Also the outbox does not refresh when sending emails. If I look in the outbox I do not see the email but the folder is still BOLD. Also the notification  for new email is very inconsistant. You requested we call in but did not provide any call in details. My mail box and CAS server is a single box hosting about 400 users.  I am useing Outlook 2003 on a 2008R2  RDS so cache mode is not an option. Also do we need to change or delete the poll  value set to 5 seconds as a work around?

  35. smutsbullen@hotmail.com says:

    Can Microsoft please state an official comment why RU3 did not fix the delay problems Outlook 2003 users are still having even after updating to RU3?

    2009942  (support.microsoft.com/…/2009942 ) Folders take a long time to update when an Exchange Server 2010 user uses Outlook 2003 in online mode

  36. selina says:

    Updates and more updates…

  37. felix says:

    After installing Exchange 2007 SP3 my Outlook 2007 SP2 Users couldn't see in serveral emails the attachments. Outlook 2007 shows the attachment icon but no files are showed. With OWA the attachments are shown.

    Felix

  38. Ken S. says:

    Wow, any update on this?  I'm eager to see if it fixes some of the issues I'm having but I also run BES and don't want that headache.  Can someone at least tell us the status or an estimated re-release date?

  39. Bharat Suneja [MSFT] says:

    @Ken S. and others: Last evening we posted an update in the post addressing the issue: Exchange 2010 SP1 Rollup 3 and BlackBerrys sending duplicate messages.

  40. ExchangeConfused says:

    Anybody ever had the Exchange Transport just stop for no reason? Our 2010 exchange server randomly just shuts the transport off and I can't seem to figure out what is happening. I have to go in and manually restart it.  If anyone knows where to look for a fix it would be much appreciated.

  41. slc2@pge.com says:

    Exchange 2010 sp1 RU3 is suppose to have the UDP fix for the Outlook 2003 delay when you delete or move a msg.  We applied the fix mentioned on support.microsoft.com/…/2009942  but, continue to experience the same symptoms.  Not all clients are seeing the delay.  In one case, there was no delays for single msg deletes, however, yesterday this person deleted about 20 msgs at once and noticed a long delay. Eventually, the person switched folders and back and it finally refreshed.

  42. Chris says:

    The link to download Exch 2010 SP1 RU 3 does not work.  I've tried the link from several sources and from different computers and internet connections.  MS please fix.

  43. Bharat Suneja [MSFT] says:

    @Chris: Please see Exchange 2010 SP1 Rollup 3 and BlackBerrys sending duplicate messages for updates re RU3.

  44. Federico Munoz says:

    Hi!

    Link about Rollup 3 for Exchange 2010 SP1 is wrong. When could it be available?

    Thanks!

  45. MonsterAxe says:

    Hi MS. Any update either the BES issue or the Outlook 2003 UDP issue not being resolved?

    I have noticed that the support.microsoft.com/…/2009942 article about the UDP issue for Outlook 2003 users has been "updated" to not include Update Rollup 3 as a fix for the issue.

    Has there been any progress made in resolving any of these issues?

  46. Magnus says:

    The link for Update Rollup 3 for exchange 2010 SP1 is not working. And its not released through windows update either. Windows Update only gives Rollup 2.

  47. Adi says:

    I think they realised it was a messy update an revoked it. Anyway, it is good that they are taking actions.

  48. paul says:

    Any word on when we can see an update to Retention Tags/Policies?

    social.technet.microsoft.com/…/56260407-4b15-407e-9079-2a97c79abf0c

    social.technet.microsoft.com/…/38074262-3f40-4a24-b628-e7c3e3eb7c76

    I'm particularly curious about if/when Calendar and Tasks will fall under control of Retention Tags/Policies.

  49. Tim Hetzel says:

    The link for 2010 seems to be broken still. Is this available anywhere?  Not very professional to say it is available and then leave people wondering why they get a dead link.

  50. Bharat Suneja [MSFT] says:

    @Tim Hetzel and all: Sorry for the inconvenience folks – we've posted subsequent updates in follow-up posts. This post now has an Updates section with links to the subsequent posts. Note, Exchange 2007 SP3 RU3 has been re-released as V2.

    The download link for Exchange 2010 SP1 RU3 has been removed. It will be updated again when a new download is available.

  51. Steve Gordon says:

    Ok saw a mention that OWA is now broken after RU3. This is definately the case.

    I get the following evt log reports :

    Outlook Web App failed to load the following theme folder: C:Program FilesMicrosoftExchange ServerV14ClientAccessowa14.1.287.0themespnk-plm

    The following files are missing: gradienth.png, gradientv.png, csssprites.css, csssprites.png, csssprites2.css, csssprites2.png

    Ive checked the folder location mentioned and its empty as it says.

    Has anyone seen this issue and found a relevant fix ?

    Thanks in advance

    Steve

Comments are closed.