Exmon for Exchange 2007 SP1? Check!


EDIT 6/25/2009: We have updated the download package to remove the need for dependency on Visual C++ 2008 SP1 Redistributable package. The tool can be found in the same place as before, but the version has now changed to 14.00.0611.003.

Just a quick note to share the news that we have just published the updated Microsoft Exchange Server User Monitor tool, aka. Exmon, for Exchange 2007 SP1.

The updated tool can be downloaded here: http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=9a49c22e-e0c7-4b7c-acef-729d48af7bc9. If the download page says that the version is 14.00.0611.003 - then you are looking at the correct, new version. If it is something else, go ahead and refresh the page as the updated download might still be replicating though Microsoft Download Center.

The updated documentation can be found here: http://go.microsoft.com/fwlink/?LinkId=142433.

Note: At this time, Exmon can not coexist on the same machine with the Jetstress tool.

Happy Exmon-ing!

- Chris, Erin, Mike and Nino

Comments (32)
  1. Waseem says:

    I downloaded and tried on both Exchange 2007 SP1 and even on Windows 2003 w/o Exchnage tool is not working some how I am getting error

  2. Waseem says:

    Error is

    "This application has failed to start becuase application configuration is incorrect. Reinstall the application may it fix the problem"

    Even I removed, reinstalled many time but no luck.

  3. Nima says:

    I get the same error. "This application has failed to start becuase application configuration is incorrect. Reinstall the application may it fix the problem" .  Running it on exchange 2007 SP1 R6 64bit.

  4. TheMasta says:

    I get the same error. "This application has failed to start becuase application configuration is incorrect . Reinstall the application may it fix the problem" .  Running it on exchange 2007 SP1 R7 64bit.

  5. sacalder says:

    Same issue here anyone got around this error yet.

  6. paul says:

    It’s working for me just fine.  I had to give it some time to run though.

  7. Blacktoe says:

    I’m currently having the same issues as well.  I’ve installed this on my primary node mailbox server in my mailbox cluster and I’m getting the same error.  I’ve made sure that the registry edit was entered and it is still not working.  Any recommendations?  Paul, was there anything special you had to do to get this to work?

  8. Mark says:

    Same here. "This application has failed to start because application configuration is incorrect. Reinstall the application may it fix the problem" .  Running it on exchange 2007 SP1 R6 64bit.

  9. T Man says:

    Same error as the others.  App config incorrect.  Exchange 2007 SP1 R7 64bit.

  10. T Man says:

    To follow up, here are the errors in the System event log about SideBySide errors.

    Event Type: Error

    Event Source: SideBySide

    Event Category: None

    Event ID: 32

    Date: 4/23/2009

    Time: 9:19:37 AM

    User: N/A

    Computer:

    Description:

    Dependent Assembly Microsoft.VC90.CRT could not be found and Last Error was The referenced assembly is not installed on your system.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Event Type: Error

    Event Source: SideBySide

    Event Category: None

    Event ID: 59

    Date: 4/23/2009

    Time: 9:19:37 AM

    User: N/A

    Computer:

    Description:

    Resolve Partial Assembly failed for Microsoft.VC90.CRT. Reference error message: The referenced assembly is not installed on your system.

    .

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Event Type: Error

    Event Source: SideBySide

    Event Category: None

    Event ID: 59

    Date: 4/23/2009

    Time: 9:19:37 AM

    User: N/A

    Computer:

    Description:

    Generate Activation Context failed for C:Program Files (x86)Exchange User MonitorExMon.exe. Reference error message: The referenced assembly is not installed on your system.

    .

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

  11. Derek Morris says:

    Same error for me too!

    "This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem."

    Well, reinstalling did not fix the problem!!

  12. Mike Lagase says:

    Folks,

    It appears that you will need to install the Visual C++ 2008 SP1 Redistributable to get this version working. You can get this from

    http://www.microsoft.com/downloads/details.aspx?familyid=A5C84275-3B97-4AB7-A40D-3802B2AF5FC2&displaylang=en.

    We are currently investigating this and will post back once we have further information.

  13. derekmorris7 says:

    It worked after installing this just fine. Thanks!!

  14. Blacktoe says:

    Everything is working correctly.  Will the Visual C++ 2008 SP1 affect the Exchange server at all?

  15. Mark says:

    Confirmed Working with the Visual C++ 2008 SP1 Installed.

  16. Bookey says:

    Sorry guys! I take responsibility for this. I have added a note on the exmon.msi download site about the redistributable package being needed. I hope to have a new build of exmon.msi out on the download site early next week that will not require installing this redistributable. Thanks!!

  17. Mike Baker says:

    install on win2008 / ex2007 sp1 ru7 mbx role only

    "Another Version of this product is already installed.  Installation of this version cannot continue." etc etc

    Jetstress and swordfish are installed on this lab machine aswell.

  18. Exchange says:

    Mike Baker – are you saying that there is in fact no Exmon already installed on the box? In other words – if you go to Add/Remove Programs – you don’t see "Microsoft Exchange User Monitor" there? Do you have a "Program FilesExchange User Monitor" or "Program Files (x86)Exchange User Monitor" folder?

  19. Mike Baker says:

    that is correct.

    programs and features has the following.

    debugging for Windows (x64)

    HP tools

    .net 3.5 sp1

    Exchange Jetstress

    Exchange Load Generator

    Exchange Stress and Performance Tool

    FCS

    Microsoft network monitor

    Visual C++ 2005 Redistributable

    System Centre Operations Manager 2007 R2 Agent

  20. Mike Baker says:

    there is no btw.

    Program FilesExchange User Monitor" or "Program Files (x86)Exchange User Monitor"

  21. Blacktoe says:

    Bookey,

    Thank you for the heads up.  I’m looking forward to your fix early next week.  Have a great weekend!

  22. PatRick says:

    I’m having the same issue with MSIEXEC reporting that the software is already present.  I enabled verbose msiexec logging when attempting to install, and the product code it’s looking for appears to be that of JetStress, which is installed… seems to explain why this MSI package thinks the software is already there.

  23. Exchange says:

    Thank you Patrick (and Mike Baker – I expect this is what you ran into also) – we have a repro and are looking into it.

  24. David says:

    I’m having an issue with running exmon, ran first time but now get an error popup "Unknown StartTrace error (183)".   Can you help?  

  25. APatil says:

    David, with regards to your error?

    Refer to the last section of the below link.

    http://www.msexchange.org/tutorials/Microsoft-Exchange-Server-User-Monitor.html

  26. Jan Verhulst says:

    Why is the link to the x86 version of the C++ SP1 package being posted , while you actually need the x64 version for Exchange 2007 ?

    http://www.microsoft.com/downloads/details.aspx?familyid=BA9257CA-337F-4B40-8C14-157CFDFFEE4E&displaylang=en

    Or am I neglecting something ?

  27. Jan Verhulst says:

    Never mind :-) It IS the x86 version of course …

  28. Mike Baker says:

    any update on the exmon msi issue?

  29. Chad says:

    Patiently awaiting word on how to solve the MSI problem.  I too have a server that thinks EXMON is installed.  If it were my machine, I would feel perfectly comfortable hacking it to make it work.  But not with our mail server…

  30. Exchange says:

    Chad,

    Until we fix the MSI, you can install Exmon if you remove Jetstress.

  31. ExchangeGuy says:

    The download page for the Visual C++ 2008 SP1 Redistributable states that you “may use it with each validly licensed copy of Microsoft Visual Studio 2008 software (the “software”). You may not use the supplement if you do not have a license for the software.”

    If one doesn’t have a validly licenses copy of Visual Studio 2008, may we still use the Visual C++ 2008 SP1 Redistributable anyway?

  32. Exchange says:

    Everyone,

    We have just updated the MSI on the download site and removed the dependency on the C++ 2008 SP1 Redistributable…

Comments are closed.

Skip to main content