Recrear el Information Store

Hola a tod@s!

 

Hemos visto algunos casos en los que el Information Store no arranca, apareciendo errores 5000 y 1121 en el log de aplicaciones, con código de error 0x8004010f:

 

Estos errores pueden aparecer en caso de que el nombre de la organización contenga algún carácter extraño, como se describe en el siguiente artículo:

 

329599  Exchange Information Store does not start and events 1121 and 5000 are logged

http://support.microsoft.com/default.aspx?scid=kb;EN-US;329599

 

Otra de las posibles causas puede ser que el contenedor del InformationStore haya sido eliminado directamente. Las situaciones en las que hemos visto el problema han sido en errores de desinstalación. Para poder devolver la estabilidad al servidor necesitaremos recrearlo de forma manual. Para esto, necesitaremos seguir los siguientes pasos:

 

–          Desde ADSIEdit ir a la partición de configuración, Services, Microsoft Exchange, Nombre de la Organización, Grupos Administrativos, Grupo Administrativo del Servidor, Servidores y finalmente el servidor.

–          Sobre el servidor, botón derecho y seleccionar New -> Object.

–          Elegiremos la clase msExchInformationStore y en el valor fijaremos InformationStore, el resto de pasos por defecto:

–          Una vez creado editaremos las propiedades y fijaremos los siguientes valores:

 

adminDisplayName = InformationStore

msExchESEParamCircularLog = 0

msExchESEParamCommitDefault = 0

msExchESEParamDbExtensionSize = 256

msExchESEParamEnableIndexChecking = TRUE

msExchESEParamEnableOnlineDefrag = TRUE

msExchESEParamLogFileSize = 5120

msExchESEParamPageFragment = 8

msExchESEParamTempDBMin = 0

msExchESEParamZeroDatabaseDuringBackup = 0

msExchMaxRestoreStorageGroups = 1

msExchMaxStorageGroups = 5

msExchMaxStoresPerGroup = 5

msExchMaxStoresTotal = 5

 

–          Tras esto crearemos un Storage Group y una base de datos y finalmente reiniciar el servidor.

 

Indicar que estos pasos deben ser aplicados únicamente en situaciones de emergencia, la mejor opción una vez finalizado es desinstalar Exchange e instalarlo de nuevo para asegurar que todo está creado de forma correcta. También informaros que estos pasos son específicos de Exchange 2007, para Exchange 2010 y 2003 podemos tener otros atributos/valores distintos. En caso de que los necesitéis avisarnos para publicarlos.

 

Espero que os sea de utilidad.

 

Saludos,

Pablo