Error 25156. Failed to create MOM database error when installing SCOM 2007. Error Code: -2147217900.


You may experience this error when installing the SCOM database to a SQL 2005 cluster.

**Run the installation on the SQL node that hosts the Virtual Node** 

 

clip_image001

 

This error is caused when SQL 2005 is missing disk dependencies within the SQL 2005 Group. 

 

The Fix:

1.  Within the cluster administrator take the SQL group offline.

 

**If the disks are missing you MUST take the SQL group offline in order for any “new” disks to be recognized.  You will not be prompted to take it offline either…. 🙁

 

2.  Properties of SQL server – Dependencies tab -> make sure that all disks are listed.

 

You should have a SQL Network name dependency, and the Physical disk should be listed here as well.

 

3.  If the disks are not there – add them – bring the cluster back on-line

4.  Re-run the SCOM installation

 

*** For additional Information Please refer to:

http://technet.microsoft.com/en-us/library/bb381402.aspx

 

>edwalt


Comments (18)

  1. krakou says:

    I have that problem on a stand alone machine..

  2. zorba says:

    I do have this on a standalone machine as well…

  3. zorba says:

    i have to admit, I had a "-" in the DB name, that led to this error.

  4. zxevil135 says:

    aSR8f6 r u crazzy? I told u! I can’t read!

  5. zxevil136 says:

    iCrR5C r u crazzy? I told u! I can’t read!

  6. zxevil134 says:

    9OZPTR r u crazzy? I told u! I can’t read, man!

  7. zxevil141 says:

    jDKvFy r u crazzy? I told u! I can’t read!

  8. zxevil150 says:

    1nRu6t r u crazzy? I told u! I can’t read!

  9. zxevil151 says:

    ibtDPO r u crazzy? I told u! I can’t read!

  10. zxevil152 says:

    G36VRJ r u crazzy? I told u! I can’t read!

  11. zxevil153 says:

    sl5hSH r u crazzy? I told u! I can’t read!

  12. zxevil154 says:

    OP48I4 r u crazzy? I told u! I can’t read!

  13. zxevil155 says:

    im37Ae r u crazzy? I told u! I can’t read!

  14. Dave says:

    I found that since I was doing an dvanced setup and placing these in folders that were not already created it failed.

    Once I pre-created the folders for data and logs it installed perfectly.

    this is on Windows 2003 R2 x64 Ent SP2 single server with SQL 2005 x64 SP2

  15. Brian Deyo says:

    My fix was same as the previous post.  I didn’t have a standalone server, but wasn’t installing the datawarehouse in a cluster server.  All I needed to do was manually create the path and the install was fine.  

  16. NetworkGuru says:

    I found this is a problem when using the advanced options in the installer. You must first create the log and data sub-directories when running the advanced install with SCOM / Reporting.

    Windows Server 2008 x64 / Sql 2005 x64 – Standalone System Center

  17. Marc says:

    I had the same problem, using the advanced option. Creating the folders prior to the installation solved it.

    Thanks Guru!!!