Dynamics AX 2012 Versions Now Support .NET Framework 4.5.2


Dynamics AX 2012 CU5+, AX 2012 R2, and AX 2012 R3 now support .NET 4.5.2. For more information on the .NET 4.5.2 release go here

Comments (3)

  1. Bertrand Caillet says:

    Dynamics AX 2012 Feature Pack is included in this statement, so it also supports .NET 4.5.2 Framework

  2. Bernard Vander Beken says:

    Does this mean X++ code can reference CLR and custom .NET assemblies that depend on .NET 4.5.2?

  3. Toni says:

    Hi Bernard. Yes, referencing and calling into .NET assemblies built for version 4.5.2 should work. However you cannot create Visual Studio projects in the AOT that use .NET 4.5.2, since the development tools require Visual Studio 2010, which does not support
    building .NET 4.5.2 projects.

Skip to main content