SharePoint Tidbit – Error in SharePoint Management Shell

Hello All,

It’s been a while since I wrote up a SharePoint Tidbit, but I thought I had the perfect subject here since I have hit it with a few customers.

You open SharePoint 2010 Management Shell and get the following message

The local farm is not accessible. Cmdlets with FeatureDependencyId are not registered.

Then if you try to run any commands that connect with the farm you get an error like the following

Get-SPSite : Microsoft SharePoint is not supported with version 4.0.30319.296

of the Microsoft .Net Runtime.

At line:1 char:1

+ Get-SPSite

+ ~~~~~~~~~~

    + CategoryInfo : InvalidData:

   SPCmdletGetSite) [Get-SPSite], PlatformNotSupportedException

    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletGetSite


This affects Windows 7/Windows 2008 R2 servers and happens when you apply the update for Windows Management Framework 3.0. 

This means that you have installed PowerShell 3.0 to your server and SharePoint 2010 is not supported with that version of PowerShell (As the error says)

There are many blogs out there that tell you to do several different things to work around the issue.  But my recommendation is to uninstall the update KB2506143 as that should remove PowerShell 3.0.  This may require a reboot.

Comments (2)

  1. Hi Chris, IMHO it's better to use guide from this KB…/2796733

  2. Anonymous says:

    Pingback from SharePoint Tidbit – Error in SharePoint Management Shell – SharePoint Blogs in Spanish – Bamboo Nation