Linux Agent install issue


I tried discovering a linux box and deploying agent, But I see below error. 
My WinRM service is running perfectly fine on the management server.
My error is:
 
“”The WinRM client cannot complete the operation within the time specified. Check if the machine name is valid and is reachable over the network and firewall exception for Windows Remote Management service is enabled.””
 

  

 
When I telnet to port 1270, the connection fails. There we have an issue. Very simple
 
Run this to open the port on linux box. This command is not for Solaris
iptables -I INPUT -p tcp -m tcp –dport 1270 -j ACCEPT 
 
Ok now that your ports are open, now when you try to discover and try installation, you see “”access denied.””

When I see in the event Log of RMS, I see event ID 1002
 
 
Log Name:      Operations Manager
Source:        Cross Platform Discovery
Date:          12/16/2011 8:19:18 AM
Event ID:      1002
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      CHBH25062627-1.dc250626.local
Description:
Discovery of linux failed with the following error:
Installed Agent failed to initialize properly.
Details:
Access is denied.
Event Xml:
 
So it lies beyond 1270 port. Something that did a trick. Run below.
This could be that partially installed agent are not allowing the agent to be installed. See that installation fails at Validation step. I tried to remove the partially installed agent. Agent  was any way running on the Linux box. Try below step
 
rpm -e scx
rm -rf /etc/opt/microsoft/scx
Now, start the discovery and install of agent through console.
 
You see a happy face…
Success. 
Comments (3)

  1. Try Running debug view, Seems the services not getting started.  You may need to delete all the scx directory preexisting and try discovering and installing again

  2. Peter says:

    Do you have the Solution to fix the below error encountered while running discovery for a Linux agent:

    Failed to sign kit. Exit code: 1

    Standard Output: Failed to start child process '/sbin/init.d/scx-cimd' errno=13

    RETURN CODE: 1

  3. Kariger says:

    Hello

    A BIG thanks for this article, it worked for me !!!

    kind regards

    raphael

Skip to main content