Tip 28: Keep Slim and Trim





This tip is for Windows SharePoint Services 2.0, SharePoint Portal Server 2003, Windows SharePoint Services 3.0, Microsoft Office SharePoint Server 2007, SharePoint Foundation 2010 and SharePoint Server 2010.

To reduce update surface and reduce conflicts, it is always a good idea to only load the specific versions of the .Net Framework needed for SharePoint to function. This follows with best practice to only load what is needed for the application(s) to function. Windows 2008 and IIS 7 are good examples of this type of methodology.

For WSS 2.0 and Portal Server 2003, this would be .Net Framework 1.1.

For WSS 3.0 and MOSS 2007, this would be .Net Framework 2.0 (x86, x64) and 3.0 (x86, x64).

For SharePoint Foundation 2010 and SharePoint Server 2010, this would be .Net Framework 3.5 SP1.

Note that some custom web parts and solutions may require a different .Net Framework version loaded on the SharePoint servers.

Comments (0)

Skip to main content