“Sorry, this site has not been shared with you.” on PS2013 databases restored to a different domain farm.


I recently began working with a new Project Server 2013 customer and restored a copy of the databases to my test server, then ran into the “Sorry, this site has not been shared with you.” message when I attempted to access PWA.

The fix is to run this command as an admin in SharePoint Management Shell:

Grant-SPProjectAdministratorAccess -Url http://ps2013d/pwa -UserAccount brwhite1\farmadmin

For information about the Grant-SPProjectAdministratorAccess, go here: https://technet.microsoft.com/en-us/library/jj219518.aspx.

 

08:36.0 w3wp.exe (0x1AE0)                        0x03A8 Project Server                Security                      aiscy Medium  PWA:http://ps2013d/PWA, ServiceApp:Project Server Service Application 01, User:PROJECTSERVER\system, PSI: User i:0#.w|brwhite1\farmadmin could not be authenticated because logon permission has not been granted, LogLevelManager Warning-ulsID:0x00212098 has no entities explicitly specified.
08:36.1 w3wp.exe (0x1AE0)                        0x03A8 Project Server                Server-side Project Operations ajpkl High    [Forced due to logging gap, Original Level: Verbose] Looking for Project Web Instance for site Id = {0}. Looping thorugh all PSI Service applications
08:36.1 w3wp.exe (0x1AE0)                        0x03A8 Project Server                Security                      aeauy Medium  PJContext is not valid. PJContext is null.

Comments (0)

Skip to main content