Configure Web Deploy Publishing missing in IIS console


Scenario:

You have installed the Web Deployment Tool on your IIS7 webserver. Now you want to configure a site for Web Deploy Publishing like described in:

http://learn.iis.net/page.aspx/984/configure-site-for-web-deploy-publishing/

i.e. you want to to this using the “Configure Web Deploy Publishing” dialog:

IIS Manager UI configure web deploy publishing dialog

Problem:

You do a right-click the site you want to publish to, click Deploy and then there is no “Configure Web Deploy Publishing…” in the IIS Manager UI

i.e. the “Configure Web Deploy Publishing” sub menu is missing .

Solution:

You might, like me,  do not have the latest version of the Microsoft Web Deploy 2.0 (I had 2.0.1042) on your IIS:

Install the latest version (e.g. 2.0.1070) of the web deployment tool on your IIS7 –> this will add the “Configure Web Deploy Publishing…” to the IIS Manager UI:

configure web deploy publishing

I did so | prefer installing the “Web Deployment Tool 2.1 for Hosting Servers” using the Web Platform Installer:

installing web deployment tool 2.1 for hosting servers using WebPI


Comments (5)

  1. Anonymous says:

    I had the same issue and was able to fix it.

    On a Windows Server 2008 R2, with the base IIS install, and then installing the Web Deploy 2.0, the installer didn't offer the option to install the IIS Manager UI Module. Then in IIS, it didn't show the Configure Web Deploy Publishing.

    If you go into the Server Manager, Roles, Click on IIS, then Click on Add Role Services, then check the "Management Service". Close that out. Then reopen IIS Manager, and voila the option is available!

    Rob Bramhall

  2. frustrated developer says:

    Doesn't help did exactly what you did but still didn't get the option

    bfrank: What version number of the Web Deploy Tool 2.0 does "Add/remove Programs" say you have?

  3. Ryan O'Neill says:

    Annoying that this happens at all, Robert's approach works. For some daft reason, when you install it via Web PI you have four different versions offered and choosing the wrong one will not set up the UI.

    Thanks Robert.

  4. Andy Grant says:

    Awesome! Solved my problem – was pulling my hair out trying to figure out why this was missing from the menu!

  5. Joe says:

    You legend! I've been trying to figure this out for a few hours now – it was driving me insane.

     

    🙂