"One or more ActiveX controls could not be displayed" error when you open MMC “Extended” tab


Symptom:

=========

When you start MMC console like services.msc or gpedit.msc, you will get the following error message:

One or more ActiveX controls could not be displayed because either: 1) Your current security settings prohibit running ActiveX controls on this page, or 2) You have blocked a publisher of one of the controls. As a result, the page may not display correctly.

When you click OK in the error message, you receive the same error message again.

 

Another symptom is that Desktop sidebar gadgets stop working and just show as black squares with a green vertical line down the center.

 

Solution:

=========

Method 1:

1.

Click Start , click Run , type regedit , and then click OK .

2.

Expand the following registry subkey:

HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionInternet SettingsZones

3.

In the right pane, right-click 1200 , and then click Modify .

4.

In the Value data box, type either 1 or 0 to overwrite the existing value of 3. Then, click OK .

Note If you type 1 in the Value data box, you will receive the following prompt when you start Microsoft Project:

Do you want to allow software such as ActiveX controls and plug-ins to run?

Additionally, you will receive this prompt at other times when you use Microsoft Project. If you do not want to receive this prompt, type 0 in the Value data box.

The values 0, 1, and 3 are associated with the following behavior:

0 = Enabled, or the action is permitted

1 = Prompt

3 = Disabled, or the action is not permitted

5.

Quit Registry Editor.

Method 2:

 

If the issue still exists, please follow the following method:

1.       Click Start , click Run , type regedit , and then click OK .

2.       Expand the following registry subkey:

HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionInternet SettingsZones

3.       Delete 1 extra (parasite) zone from

HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionInternet SettingsZones

with pseudo-graphic number, you’ll see it before zone number 0. The pseudo-graphic number they speak of before zone number 0 looks like a miniature upper case “L”.



Edit: We published a KB article for it, you can use “FixIt” tool to fix the problem in one click
:

http://support.microsoft.com/kb/2506343/en-us

Comments (36)

  1. Anonymous says:

    Method 2 fixed me too. But looks like a NOT miniature upper case “L” BUT LIKE A SIMPLE SQUARE.

  2. Anonymous says:

    The cause could be virus or 3rd party application which created this registry.

  3. Thanks, Method 2 fixed it! Any idea what was causing this? Maybe becasue I installed the leaked bits of Windows 7 SP1 x86 'RTM' ???

  4. steve says:

    thanks – method 2 fixed me too.  would like to know what caused that.

  5. max Li says:

    but  I use this method , didn't resolve my problem,

    my mail address is lifeng2620155@hotmail.com

  6. Sophon L. says:

    I can use the method 2 to fix the problem.

  7. Jiri says:

    Thanks, method 2 fixed the problem.

  8. Dale says:

    I found a forum that thought Adobe update inserted a registry item just above the 1 in the fixes listed above.  It looks like an L.  I deleted this item and the problem was fixed.

  9. she says:

    it work! thanks a bunch!!! =)

  10. ARUN says:

    YEAH THANKS FOR SOL.2 ITS WORKS

    U ROCKS

  11. sumesh says:

    Thank you very much!!!! Method2 fixed the problem.:)

  12. rahil says:

    Thanks you so much, Method 2, has fixed the problem.

    error "One or more ActiveX controls could not be displayed because either: 1) Your current security settings prohibit running ActiveX controls on this page, or 2) You have blocked a publisher of one of the controls. As a result, the page may not display correctly".

    Error appears while:-

    1) Scanning document through "HP Printer".

    2) while opening "services.msc".

  13. Jedimaster100 says:

    Thanks fo much, Method 2 fixed my problem too.

  14. Ahsan says:

    Thanks hundreds and hundreds of times, for i spent hundreds of days for it,  ahsan_th32@yahoo.com

  15. salacnib007 says:

    thanks a lot !!! method 2 works

  16. Zero Monster says:

    TQ Very 99 times for this solution man

  17. Renzo says:

    Thanks for the post it really help..

  18. Samer Zohdi says:

    Method 2 is working >> Thaaaaaaanks

  19. HM says:

    yyyyyyyyyyyyeeeeeeeeeeepppppppppppppp

    Method 2 is the SOLVER.

  20. Amol says:

    Hi,

    I have faced the same issue.It has resolved now.Followed the procedure given on below links –

    support.microsoft.com/…/2506343

    am-techzone.blogspot.com/…/one-or-more-activex-controls-could-not.html

  21. Amol says:

    Thanks for the valuable information.

    Faced the same issue at my end.Followed the steps given on above link.

    am-techzone.blogspot.com/…/one-or-more-activex-controls-could-not.html

  22. avinash says:

    While deleting  the extra (parasite) zone from the Zones subkey: The parasite zone is a pseudo-graphic number listed before zone number 0. I had The pseudo-graphic number looks like a a squre and not miniature upper case "L"

    also there are few keys in zone1: lile 1004, 1809 which has a 3 value.

    shall that also be changed to 0 or 1

  23. celine says:

    thanks. Method 2 solved fixed my problem too..:)

  24. Alon says:

    Thanks !!!! Method 2 fixed my problem. I've been looking for this solution a really long time.

  25. Muhammad Tariq Ilyas says:

    Thaks Dear method 2 worked. Love you. tariq.ilyas96@gmail.com

  26. Ansaf M says:

    Thanks a lot.

    The method 2 did it for me.

  27. Didzy Me says:

    Method 2 fixed me as well. I was having problems with Karspersky Lab administration kit Console. Method 2 for real

  28. Udhay Kumar says:

    Solution 2 Worked .. Thanks a lot

  29. sam says:

    After 5 hours of trying to resolve this problem. the only one that worked is (Microsoft Fix it 50618). you just need to download it and it will do the work

  30. Carlos Lopez says:

    The second method fix the problem to me…  In my case I have delete an "small square" previous the Zone 0.

  31. MG says:

    none of these "solutions" works for me

  32. simple guys says:

    method 2 it works, thanks a lot man

  33. M says:

    it didnt work for me, no extra zones or value "3" in the name 1200 file. any other ideas please? also windows live mail dont work any more, win7 is the worse of all version of windows

  34. dalligator says:

    I had the same problem, and these methods did NOT help.

    I discovered by changing the font color (from blue to dark blue) erradicated that annoying error.

  35. Jacob says:

    Sorry, but  there is not pseudo-graphic number  before zone number 0. What to do ????

    Thank you!

  36. dpszmk says:

    I had an online computer geek try to fix this for me and they couldn't do it. followed your no. 2 instructions and fixed the problem. thanks so much.